X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox too slow to respond

Posted

Hi,

My OS is Windows Vista and I have used Firefox for several years with hardly no problems but for some months, starting with Firefox 14 (or 13?), it is now very, very slow. I use ADSL connection (broadband) with a speed of 6-8Mbit/s and the response time for Firefox is now around 120ms and receiving speed around 0.6Mbit/s. Sending is normal, though, with about 0.89Mbit/s. I also have Netscape Navigator 9 and Explorer and they are still fast, 7Mbit/s and 0.89Mbit/s (receiving and sending) and a response time of about 15ms. What have I done to solve the problem? This is what I have I tried:

- Searched for virus and trojans - Safe mode. - No add-ons. - No plugins. - No bookmarks. - Cleared cache and history. - Updated add-ons and plugins. - Shut down anti-virus and firewall. - Reinstalled with the Firefox button in the help menu. - Made a complete reinstallation after removing all profile files etc. - Changed the DNS servers. - Tried about:config and changed values

Yesterday I installed the Comodo IceDragon, that is almost identical to Firefox 15, and suddenly the speed was 7/0.89Mbit/s but, alas, only once for the Dragon and once for the Firefox. Then back to the normal 0.6/0.89Mbit/s. Is there anything more that I can do? Pleas bear in mind that both Netscape and Explorer are working perfectly and I do not receive any error messages.

Thanks in advance!

Lars Ahlberg Sweden

Chosen solution

Poor performance in Flash-based speed tests can be related to add-on conflicts and certain Flash features. If you have not already tried these:

(1) Disable protected mode (Win Vista and Win 7 only)

See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?

(2) Disable hardware graphics acceleration in Firefox and in Flash

(A) In Firefox, un-check the box here and restart:

orange Firefox button or classic Tools menu > Options > Advanced > General > "Use hardware acceleration when available"

(B) In Flash, see this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

(3) For video issues, make sure your RealNetworks add-ons are the latest versions

Read this answer in context 0

Additional System Details

This happened

Every time Firefox opened

This started when...

Some months ago

Installed Plug-ins

  • Google Update
  • Next Generation Java Plug-in 10.7.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.4 r402
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • RealJukebox Netscape Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • 4.1.10329.0
  • GEPlugin
  • Nexus Personal Plug-Ins
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:15.0) Gecko/20100101 Firefox/15.0.1

More Information

Programfakta
Namn
Firefox
Version
15.0.1
Användaragent
Mozilla/5.0 (Windows NT 6.0; rv:15.0) Gecko/20100101 Firefox/15.0.1
Profilmapp
Öppna mapp
Aktiva insticksmoduler
about:plugins
Byggkonfiguration
about:buildconfig
Kraschrapporter
about:crashes
Minnesanvändning
about:memory
Tillägg
Namn
Version
Aktiverad
ID
Google Translator for Firefox
2.1.0.2
true
translator@zoli.bod
NoScript
2.5.6
true
{73a6fe31-595d-460b-a920-fcc0f8843232}
Microsoft .NET Framework Assistant
0.0.0
false
{20a82645-c095-46ed-80e3-08825760534b}
RealPlayer Browser Record Plugin
15.0.4
false
{97E22097-9A2F-45b1-8DAF-36AD648C7EF4}
Viktiga ändrade inställningar
Namn
Värde
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
1048576
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
1048576
browser.places.smartBookmarksVersion
4
browser.startup.homepage_override.buildID
20120905151427
browser.startup.homepage_override.mstone
15.0.1
extensions.lastAppVersion
15.0.1
network.cookie.prefsMigrated
true
places.history.expiration.transient_current_max_pages
80472
privacy.sanitize.migrateFx3Prefs
true
security.default_personal_cert
Ask Every Time
security.warn_viewing_mixed
false
Grafik
Adapterbeskrivning
Radeon X1700 SE
Leverantörs-ID
0x1002
Enhets-ID
0x7291
Adapter-RAM
Unknown
Adapterdrivrutin
atiumdag atiumdva atitmmxx
Drivrutinsversion
8.332.0.0
Drivrutinsdatum
1-8-2007
Direct2D aktiverat
Blockeras på grund av grafikdrivrutinens version. Prova att uppdatera grafikdrivrutinen till version 10.6 eller senare.
DirectWrite aktiverat
false (7.0.6002.18592)
ClearType-parametrar
Hittade inga ClearType-parametrar
WebGL-renderare
Blockeras på grund av grafikdrivrutinens version. Prova att uppdatera grafikdrivrutinen till version 10.6 eller senare.
Grafikaccelererade fönster
0. Blockeras på grund av grafikdrivrutinens version. Prova att uppdatera grafikdrivrutinen till version 10.6 eller senare.
JavaScript
Incremental GC
0
Biblioteksversioner
Förväntad minimiversion
Version som används
NSPR
4.9.1
4.9.1
NSS
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS Util
3.13.6.0
3.13.6.0
NSS SSL
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS S/MIME
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC

jscher2000
  • Top 10 Contributor
2365 solutions 20923 answers

Chosen Solution

Poor performance in Flash-based speed tests can be related to add-on conflicts and certain Flash features. If you have not already tried these:

(1) Disable protected mode (Win Vista and Win 7 only)

See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?

(2) Disable hardware graphics acceleration in Firefox and in Flash

(A) In Firefox, un-check the box here and restart:

orange Firefox button or classic Tools menu > Options > Advanced > General > "Use hardware acceleration when available"

(B) In Flash, see this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

(3) For video issues, make sure your RealNetworks add-ons are the latest versions

Question owner

Thanks for the reply!

I tried (2) and unchecked the box but it did not help much, at times the reciving speed increased to about 1.2Mbit/s. BTW Netscape 9 is working perfectly with the same Flash version. Should not any problems with Flash also affect Netscape?

As for (1), I did find the file mms.cfg but please pardon my ignorance: How do I add the line "ProtectedMode=0" to it?

I also used diaxdiag to check the drivers but no troubles were detected.

Lars

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Which security software (firewall, anti-virus) do you have?

Try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that works.

Question owner

Hi again,

Thank you cor-el but I did not have to try your suggestion.

Suggestion (1) by jscher2000 solved the problem completely - I think. I located the file mms.cfg in C:\Windows\System32\Macromed\Flash and copied it to the desktop. Open it with WordPad, added the line ProtectedMode=0 and saved it. Renamed the original file mms.cfgBAK (just in case I would need it later) and moved the new file to the same folder. Restarted Firefox and tested it several times - 7Mbit/s! Yezzzzzz!!!

Thank you!

Lars