X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Unable to view video from YouTube because there is a filter enabled. It happens on work and home networks and only on Firefox (15.0.1).

Posted

After updating to Firefox 15.0.1 and Adobe Flash Player to 11.4, I was unable to view media from YouTube. I was given a message: "This video is unavailable with the Education Filter enabled. To view this video, the site network administrator will need to add it to a playlist". I work for a school district and use my laptop at work so I figured I got that message because YouTube is blocked on that network. But, when I got home, I was given the same message on my home network with YouTube videos. I reset Firefox and it took care of the issue until I went to work and the problem happened all over again with the same message......I tried to view the same videos on a different browser (Safari) and it worked just fine. I'm afraid if I reset Firefox again, I will have the same issue.

Chosen solution

It's possible that YouTube set a filter cookie which it still can see when you connect from home. To clear cookies for youtube.com, you can use either of these:

(1) "Show Cookies" dialog on the Preferences/Privacy tab:

Firefox > Preferences > Privacy > "Show Cookies"

Type yout in the search box at the top to filter the list, and remove each cookie individually.

(2) "View Cookies" dialog on the Page Info/Security tab:

While viewing a page on the site --

Tools > Page Info > Security > "View Cookies"

-- remove each cookie individually.

Then try reloading the page and see whether Youtube behaves differently.

Read this answer in context 5

Additional System Details

This happened

Every time Firefox opened

This started when...

After updating to first, Firefox 15.0.1 and Adobe Flash Player 11,4,402,265

Installed Plug-ins

  • Shockwave Flash 11.4 r402
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Adobe® Acrobat® Plug-in for Web Browsers, Version 10.1.4
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • 5.1.10411.0
  • DivX VOD Helper Plug-in
  • DivX Plus Web Player version 2.2.0.55
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • RealPlayer Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • npmnqmp 071504000001
  • iPhoto6
  • NPVeohVersion plugin

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:15.0) Gecko/20100101 Firefox/15.0.1

More Information

Updated Plugins
Reset Firefox

jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

I wonder whether this is implemented using the proxy feature? You can check the setting here:

Firefox > Preferences > Advanced > Network > "Settings" button

If you choose No Proxy, does that change anything?

Question owner

I used the No Proxy feature and it did not change anything. Maybe it still could be related to the proxy feature, I will keep trying. Thank you for your help.

jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

Chosen Solution

It's possible that YouTube set a filter cookie which it still can see when you connect from home. To clear cookies for youtube.com, you can use either of these:

(1) "Show Cookies" dialog on the Preferences/Privacy tab:

Firefox > Preferences > Privacy > "Show Cookies"

Type yout in the search box at the top to filter the list, and remove each cookie individually.

(2) "View Cookies" dialog on the Page Info/Security tab:

While viewing a page on the site --

Tools > Page Info > Security > "View Cookies"

-- remove each cookie individually.

Then try reloading the page and see whether Youtube behaves differently.

Helpful Reply

IT WORKED! I can view video again from YouTube. I removed all cookies for youtube in preferences and Page Info. Thank you so much! Now I know what to do if it happens again.