X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Pinch to zoom does not work. Firefox 15.0.1, Mac OS 10.7.4, how do I enable this?

Posted

How do I enable pinch to zoom? I don't want to type in code in about:config. If there is not a setting I can change, I'll go back to Safari.

Additional System Details

This happened

Every time Firefox opened

Installed Plug-ins

  • Displays Java applet content, or a placeholder if Java is not installed.
  • Shockwave Flash 11.4 r402
  • Version 3.6.1.9117
  • Google Talk Plugin Video Accelerator version:0.1.44.16
  • 5.1.10516.0
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Office Live Update v1.0
  • Facebook Video Calling by Skype
  • AmazonMP3DownloaderPlugin 1.0.15
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • Coupons Inc., Coupon Printing FireFox Plugin
  • doubleTwist Web Plugin
  • Picasa plugin.
  • npmnqmp 071706000001
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:15.0) Gecko/20100101 Firefox/15.0.1

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96972 answers

Try this extension if you do not want to change the related browser.gesture.* prefs on the about:config page

Modified by cor-el

Question owner

In other words pinch to zoom doesn't work in Firefox.

I'm not adding any extensions. If it's not in the stock browser, I'm going back to Safari.

Sadly, I just had to stop using Google Chrome because of the constant Shockwave Flash errors.

ideato
  • Top 25 Contributor
617 solutions 4264 answers

Helpful Reply

Hi Junebugapril

try in about:config

browser.gesture.pinch.in
value    cmd_fullZoomReduce

browser.gesture.pinch.in.shift   
value    cmd_fullZoomReset

browser.gesture.pinch.out         
value   cmd_fullZoomEnlarge

browser.gesture.pinch.out.shift
value  cmd_fullZoomReset

String all the above


thank you

Modified by cor-el

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96972 answers

Aren't there any of the browser.gesture.* prefs changed after installing the pinchy extension?

That is all what the extension does, so you do not have to do that yourself.
If the prefs are correct and zooming isn't working then something else is wrong.

Question owner

Cor-el, this should be a Firefox setting, not a script someone wrote. I'm going to unsubscribe from this post if possible.

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96972 answers

Firefox only comes with some basic settings accessible via the user interface.
For settings that aren't available via the user interface you have to make changes to the prefs or use an extension if there exist any.

superduper2012 0 solutions 1 answers

In other words junebugapril is a whiny little brat who can't understand that firefox is developed to work not only on OSX for mac and if she wants to copy safari she should either do as told or just keep safari.. it took the brat longer to register here to start this thread than the mere 1 minute to download the extension that works perfectly fine..

America is doomed with these idiots.

JamesRook 0 solutions 2 answers

I downloaded the add on to fix the problem. The zoom function only seems to work half the time however. For example, on chessmaniac.com the pinch zoom works fine. But on http://www.gamesheep.com/game/pool-multiplayer-online/ it doesnt work at all!

Please help!!! All I care about is the site where its not working.

Thanks

Nevermind, it's working now!!!

Modified by JamesRook