X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

FF 15 and Java 7 plugin on Win 8 not working

Posted

Just did a fresh install of Win8 on a totally new machine. Installed latest FF (15.0.1) and Java 7. Everytime I go to a page requiring Java it says I need the plugin. I've searched all over the web and can't find an answer although others have had the same problem and appeared to have worked around it.

Reinstalled FF Reinstalled Java Tried running program in Win 7 compatibility mode

If I go to Control Panel -> Programs -> Java -> Advanced and look at Default Java for Browser, it's set for IE, but the box for FF is unchecked. I check it, hit apply or OK (tried both) and after the window closes, I go back in and FF box is unchecked again.

about:plugins shows Java installed. At wits end here....

I'm not posting from my Win 8 box so installed plugins is hand typed.

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.7.2 for Mozilla browsers
  • Ad Block Plus
  • Flash Block
  • IE Tab
  • Weather Fox

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:15.0) Gecko/20100101 Firefox/15.0

More Information

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6635 answers

What version of Java do you have? It should be Java 7 update 7. All older versions (Except 6 update 35 I believe) are vulnerable to a major security issue and have been blocked.

also, make sure you have the 32 bit version of Java installed. 64 bit won't work in Firefox.

ideato
  • Top 25 Contributor
616 solutions 4260 answers

yes Tylerdowner is right, 6.35 java: http://java.com/en/download/manual_v6.jsp

Helpful Reply

I do have Java 7 U7. I originally had both 32 and 64 bit installed, now I've got it down to 32 bit only. Still no joy. I go to a website and it tells me to install the plugin, I try to and the installer says it's already there. Now there is a difference though, the Java console shows Mozilla Family checked but it no longer shows as being installed in the plug ins on the troubleshooting info page.

Here's the Troubleshooting Info as I'm back on there now.


 Application Basics
       Name
       Firefox
       Version
       15.0.1
       User Agent
       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1
       Profile Folder
         Show Folder
       Enabled Plugins
         about:plugins
       Build Configuration
         about:buildconfig
       Crash Reports
         about:crashes
       Memory Use
         about:memory
 Extensions
       Name
       Version
       Enabled
       ID
       Adblock Plus
       2.1.2
       true
       {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
       Adblock Plus Pop-up Addon
       0.4
       true
       adblockpopups@jessehakanen.net
       Flash Block
       2.00.13
       true
       {95ab36d4-fb6f-47b0-8b8d-e5f3bd547953}
       Forecastfox
       2.2.1
       true
       {0538E3E3-7E9B-4d49-8831-A227C80A7AD3}
       IE Tab Plus
       2.0.0.0
       true
       ietab@ip.cn
 Important Modified Preferences
     Name
     Value
       browser.cache.disk.capacity
       1048576
       browser.cache.disk.smart_size.first_run
       false
       browser.cache.disk.smart_size_cached_value
       1048576
       browser.places.smartBookmarksVersion
       4
       browser.startup.homepage
       http://www.google.com/
       browser.startup.homepage_override.buildID
       20120905151427
       browser.startup.homepage_override.mstone
       15.0.1
       extensions.lastAppVersion
       15.0.1
       gfx.direct3d.prefer_10_1
       true
       network.cookie.prefsMigrated
       true
       places.history.expiration.transient_current_max_pages
       104858
       privacy.sanitize.migrateFx3Prefs
       true
 Graphics
       Adapter Description
       NVIDIA GeForce GTX 550 Ti
       Vendor ID
       0x10de
       Device ID
       0x1244
       Adapter RAM
       2047
       Adapter Drivers
       nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
       Driver Version
       9.18.13.282
       Driver Date
       6-15-2012
       Direct2D Enabled
       true
       DirectWrite Enabled
       true (6.2.8400.0)
       ClearType Parameters
       ClearType parameters not found
       WebGL Renderer
       Google Inc. -- ANGLE (NVIDIA GeForce GTX 550 Ti) -- OpenGL ES 2.0 (ANGLE 1.0.0.1041)
       GPU Accelerated Windows
       1/1 Direct3D 10
       AzureBackend
       direct2d
 JavaScript
       Incremental GC
       0
 Library Versions
       Expected minimum version
       Version in use
       NSPR
       4.9.1
       4.9.1
       NSS
       3.13.6.0 Basic ECC
       3.13.6.0 Basic ECC
       NSS Util
       3.13.6.0
       3.13.6.0
       NSS SSL
       3.13.6.0 Basic ECC
       3.13.6.0 Basic ECC
       NSS S/MIME
       3.13.6.0 Basic ECC
       3.13.6.0 Basic ECC
Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6635 answers

Go to about:plugins in your address bar, copy the information from there to this thread.

Question owner

Java(TM) Platform SE 7 U7

   File: npjp2.dll
   Version: 10.7.2.10
   Next Generation Java Plug-in 10.7.2 for Mozilla browsers

MIME Type Description Suffixes application/x-java-applet Java Applet application/x-java-bean JavaBeans application/x-java-vm application/x-java-applet;version=1.1.1 application/x-java-bean;version=1.1.1 application/x-java-applet;version=1.1 application/x-java-bean;version=1.1 application/x-java-applet;version=1.2 application/x-java-bean;version=1.2 application/x-java-applet;version=1.1.3 application/x-java-bean;version=1.1.3 application/x-java-applet;version=1.1.2 application/x-java-bean;version=1.1.2 application/x-java-applet;version=1.3 application/x-java-bean;version=1.3 application/x-java-applet;version=1.2.2 application/x-java-bean;version=1.2.2 application/x-java-applet;version=1.2.1 application/x-java-bean;version=1.2.1 application/x-java-applet;version=1.3.1 application/x-java-bean;version=1.3.1 application/x-java-applet;version=1.4 application/x-java-bean;version=1.4 application/x-java-applet;version=1.4.1 application/x-java-bean;version=1.4.1 application/x-java-applet;version=1.4.2 application/x-java-bean;version=1.4.2 application/x-java-applet;version=1.5 application/x-java-bean;version=1.5 application/x-java-applet;version=1.6 application/x-java-bean;version=1.6 application/x-java-applet;version=1.7 application/x-java-bean;version=1.7 application/x-java-applet;jpi-version=1.7.0_07 application/x-java-bean;jpi-version=1.7.0_07 application/x-java-applet;deploy=10.7.2 application/x-java-applet;javafx=2.2.0 Java Deployment Toolkit 7.0.70.10

   File: npDeployJava1.dll
   Version: 10.7.2.10
   NPRuntime Script Plug-in Library for Java(TM) Deploy

MIME Type Description Suffixes application/java-deployment-toolkit iTunes Application Detector

   File: npitunes.dll
   Version: 1.0.1.1
   iTunes Detector Plug-in

MIME Type Description Suffixes application/itunes-plugin This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox. IE Tab Plug-in

   File: npCoralIETab.dll
   Version: 1.9.8.700
   IE Tab Plug-in for Mozilla/Firefox

MIME Type Description Suffixes application/coralietab IE Tab Plug-in

I had gone back to 6.35 that ideato had suggested, that installed and shows as a plug in in add ons, but the website that I'm going to (solitairenetwork.com) looks to be pushing 7.7 pretty hard, it says I need it, so went through the install again and it's behaving the same way.

Maybe it's my clue I should quit playing solitaire?  :-/