X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

FF15 hangs whenever plugin-container.exe is loaded in memory

Posted

I need help. Since at least in v14 and now v15, FF hangs becoming unresponsive whenever plugin-container.exe is loaded in memory, as monitored with Process Explorer of SysInternals. This happens in FF with all plugins manually disabled and with no extensions, loaded in either "normal" or safe mode, even after having reset it to default state in about:support. (The unresponsiveness is not absolute, since every some 90 seconds there is a brief refresh of the screen as indicated by an acknowledging screen change due to a prior click or mouse motion. (In this quasi-frozen condition, FF slowly ramps up its memory usage while plugin-container keeps alternating between two smaller vales in Process Explorer.) After some 15-20+ minutes, plugin-container unloads itself and FF starts responding again. If I then visit a page that triggers the loading of plugin-container, the described problem develops once more. Blocking the loading of plugin-container (e.g.,renaming or moving it out or blocking it with the firewall) hangs FF. The solution for FF 3.6.6 for dom.ipc in about:config does not work in these versions.

Ironically, the Mozilla support page about "Firefox crashes when loading certain pages" (http://goo.gl/i02Xz) is a page that loads automatically plugin-container and hangs my machine, so I had to enter the forums by selecting a different problem.

This occurs in a Windows-7 machine with sufficient memory (1025 MB physical, 1025 MB virtual) and a lean configuration (monitored and enforced with Autoruns and Process Explorer), which runs very well other browsers such as Chrome, Opera o IE9. I have been using FF since its v2 and would hate to switch permanently to a different browser. Any informed advice on how to fix the problem (or disable the plugin- container in a working manner) would be much appreciated. TIA.

Chosen solution

TO: christianberg

Adding this Windows environment variable is quite simple: right click My Computer ~> left click Properties ~> left click Advanced tab ~> left click Environment Variables. Then select New in the lower pane (System Variables, which are global) ; enter MOZ_DISABLE_OOP_PLUGINS in the name field and enter 1 in the value field. Click OK twice to save and exit.

To confirm the variable has been added, run CMD.EXE ; once you are in the DOS box, enter SET at the prompt and check that the variable is indeed listed and set to 1.

Also, consider installing the FF extension Flashblock to run only those Flash-based images you want. (For me, installing the Flash plugin but disabling it, has been a better option: Flash images are blocked unless I enable them by clicking on the disabled plugin warning [see attached JPG image]).

Read this answer in context 3

Additional System Details

Crash ID

LAST ID: 23f7e328-1d26-4475-bad4-371a5c6302c9 9/2/2012 2:18 PM

Installed Plug-ins

all PLUGINS have been manually disabled in this and other browsers (my default condition for using any of them).

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0

More Information

Application Basics
Name
Firefox
Version
15.0
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0
Profile Folder
Show Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Important Modified Preferences
Name
Value
browser.cache.disk.capacity
1048576
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
1048576
browser.places.smartBookmarksVersion
4
browser.startup.homepage_override.buildID
20120824154833
browser.startup.homepage_override.mstone
15.0
extensions.lastAppVersion
15.0
network.cookie.prefsMigrated
true
places.history.expiration.transient_current_max_pages
98744
privacy.sanitize.migrateFx3Prefs
true
Graphics
Adapter Description
Intel(R) HD Graphics
Vendor ID
0x8086
Device ID
0x0046
Adapter RAM
Unknown
Adapter Drivers
igdumd64 igd10umd64 igdumdx32 igd10umd32
Driver Version
8.15.10.2622
Driver Date
1-10-2012
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7600.16972)
ClearType Parameters
Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 300
WebGL Renderer
Google Inc. -- ANGLE (Intel(R) HD Graphics) -- OpenGL ES 2.0 (ANGLE 1.0.0.1041)
GPU Accelerated Windows
1/1 Direct3D 10
AzureBackend
direct2d
JavaScript
Incremental GC
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.1
4.9.1
NSS
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS Util
3.13.6.0
3.13.6.0
NSS SSL
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS S/MIME
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Does this also happen if you boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test?

Question owner

I do not know. Will try it. (Good question; and a scary one too: since the crash still occurs with the Startup list cleared, if it does not happen in the OS' Safe Mode, then it would likely be a conflict with some code, such as an original DLL or driver, that was later modified by some application, and this will take a lot of time and effort to solve.) Thank you, cor-el.

BTW, since the dom.ipc.plugins.enabled==false alternative for the earlier FF versions using Plugin Contain does not seem to work in v 14 & 15, since plugin container continues to load in my machine even though I have toggled to false those configuration settings, do I take it that now Mozilla has closed to door to the OOPP alternative of running without the container (with tested and trusted extensions)?

Helpful Reply

Solved by blocking the loading of Plugin Container . . .

Searching in the bugzilla.mozilla.org site for text or attachments on bugs related to dom.ipc.plugins...., I encountered several references to a Windows environment variable MOZ_DISABLE_OOP_PLUGINS, for example in the patch at http://goo.gl/jYJKL. I then added this variable to the Windows 7 system environment of my machine setting it to 1. It works : FF15 no longer loads plugin container (and therefore does not hang) when visiting web pages that before froze the browser.

NB : As I discovered shortly thereafter in googling this environment variable, this method of blocking the loading of plugin container was already reported 3 weeks ago by big_v in the Mozilla support forum, http://goo.gl/v7prA. Chapeau.

Klappis 0 solutions 46 answers

How did you do that? I've also disabled plugincontainer in dom.ipc.plugins.enabled== to false but it seems the plugincontainer still like to load as usual.

My machine is quite stronger than yours with quad cpu's and 8 gigs of ram so those freezing is less frequent for me but sites that are flash-ad heavy still makes my system go down to it's knees.

Chosen Solution

TO: christianberg

Adding this Windows environment variable is quite simple: right click My Computer ~> left click Properties ~> left click Advanced tab ~> left click Environment Variables. Then select New in the lower pane (System Variables, which are global) ; enter MOZ_DISABLE_OOP_PLUGINS in the name field and enter 1 in the value field. Click OK twice to save and exit.

To confirm the variable has been added, run CMD.EXE ; once you are in the DOS box, enter SET at the prompt and check that the variable is indeed listed and set to 1.

Also, consider installing the FF extension Flashblock to run only those Flash-based images you want. (For me, installing the Flash plugin but disabling it, has been a better option: Flash images are blocked unless I enable them by clicking on the disabled plugin warning [see attached JPG image]).