Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Update to 15 caused computer to run really slow....

  • 10 replies
  • 147 have this problem
  • 3471 views
  • Last reply by John99

more options

My computer was running great, then the update of firefox to version 15 caused everything to run slow. I an running windows XP. I deleted firefox and re-installed version 14. Everything ran great again. Firefox automatically updated to 15 again, and now the computer is running REALLY slow again. Is there a fix for this slow running in 15, or can I stay with 14 and get no updates???? This is really annoying.

All Replies (10)

more options

Which security software (firewall, anti-virus) do you have?

A possible cause is security software (firewall,anti-virus) that blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program.

Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full unrestricted access to internet for Firefox and the plugin-container process and the updater process.

See:


You can also try to disable hardware acceleration in Firefox.

Modified by cor-el

more options

You do want to update to Firefox 15, as it contains security updates. For the slowness, you can try the following:

Run all Windows Updates, install all needed service packs, etc.

Update your graphics driver (Firefox uses your graphics card for some rendering, and an out of date graphics card driver can cause problems. Upgrade your graphics drivers to use hardware acceleration and WebGL

Update all your plugins (Flash, Java, etc.): http://www.mozilla.org/plugincheck/.

Download and Install MalwareBytes Anti-Malware, run a full Scan. http://www.malwarebytes.org/. This helps check that there are no viruses on your computer causing issues. You can uninstall this program after you clean off any infections.

more options

Thanks, I will try the firewall info. I have MalwareBytes and have already run a full scan. First thing I did when all of this started. It comes back completely clean. That is when I deleted firefox 15 and re-installed 14. When I did that, the system went back to running just fine. When the update hit again, and it went to 15 again, the system just bogged down. I will try the firewall stuff and see if that helps. I'll report back on the outcome.

Thanks.

more options

Well, I followed the directions for the firewall exceptions. Windows Firewall. I deleted the firefox and then added it back. Still running slow. Very irritating. Might be time to get rid of firefox for something better. Shame really, as it was my favorite for the last several years. I don't understand why the update would slow it down. Seems odd. No other update over the last few years has ever done something like this. I checked all of my drivers as well. They are current for my operating system. I am sure it is something very simple, but finding that little thing is proving to be a bear..... Thanks for the help so far.

more options

I am very perplexed by the responses to Whopper 714's issue. He like the rest of us are victims of a terribly poor performing release. Life was wonderful under Version 14, and then one day Mozilla decides to automatically install Version 15 without the necessary performance testing. I reverted back to Version 14 and guess what? No performance issues. Asking Whopper 714 about firewall settings and other security software running is totally illogical unless Mozilla is trying to debug the performance issue in the moment. Why should a user who has made NO changes to the operating system and associated security software be asked to start tweaking settings due to the installation of a new browser version that should have never been released in the first place?

more options

Just as an update.....

I completely removed Firefox from my machine (still running XP out of necessity for one of my programs). I then found a link for the download of version 14 again. I re-installed Firefox 14 and everything is back to normal. I then went in and unchecked all of the automatic updates. I still get notices, but they don't install automatically anymore. For now, I am back in action. I am hoping that the next release will not have this same problem. PJ is spot on with his response. Why would 15 need these firewall changes when all of the other versions never did and worked fine (although making the firewall changes were not the problem here. Something else was slowing the system down - maybe it was my use of XP......). Strange. Something I hope they get cleaned up. I am still a Firefox guy and hope to stay there. I know that change is inevitable, but there are times when I subscribe to "If it ain't broken, don't fix it".....lol Thanks again for everyone who chimed in to help out.

W714

more options

I found this problem when installing firefox15 on new win7 PC. Disable shockwave flash v402 plugin and speed returns!

Any ideas how to get a flash player that works properly?

more options

Stop Press!

Found a work around from MozillaZine Knowlege Base, http://kb.mozillazine.org/Flash#Disabling_Protected_Mode_in_Flash_11.3

Disabling Protected Mode in Flash 11.3 You can disable Protected Mode in Flash 11.3 (or above) by adding the line ProtectedMode=0 to the Flash "mms.cfg" file located in: (Windows 32bit) C:\Windows\System32\Macromed\Flash (Windows 64bit) C:\Windows\SysWOW64\Macromed\Flash For example, on a Windows 7 64-bit system, open the C:\Windows\SysWOW64\Macromed\Flash folder, copy the file "mms.cfg" to the desktop, open it in Notepad, add a new line ProtectedMode=0 and then close Notepad, saving your changes. Next, go back to the C:\Windows\SysWOW64\Macromed\Flash folder, rename the original file to "mms.cfgBAK" (to save it as a backup) and then drag and drop in the modified "mms.cfg" file from the desktop. [30] [31] [32] [33] [34] [35] [36] Note: To re-enable Flash Protected Mode, either restore a backup of the original mms.cfg file, if you saved one, or else re-edit the mms.cfg file to remove the ProtectedMode=0 line you added. Updating Flash Player or installing a newer version does not automatically re-enable Protected Mode. [37] [38]

This now lets Firefox15 work with Flash 11.4 v402 without excess delays.

I am sure Mozilla will find a permanent solution soon.
edit now see new post /questions/938368
(Not sure I share your optimism -J99 )

BR Steve

Modified by John99

more options

Everyone,

One tip, please ensure you have telemetry enabled. That allows Mozilla Firefox developers to get real-world anonymised data about some of these problems


sburnell

It is probably worth you starting your own thread with a suitable title, and your full system details. Please post back if you do so and we can make sure the threads are cross linked.

This thread is a general one about Firefox 15 being slow and has over 100 votes, but it is probable there are more than one cause of such problems. I am not sure anyone has yet shown Flash Player to be a general cause of Firefox 15 slowness, although FlashPlayer 11.3 et sq often seem problematic on Firefox.

You could try editing the .cfg file to turn of FlashPlayer's protected mode assuming you are using Windows >= Vista

And for FlashPlayer problems also consider troubleshooting by turning off hardware acceleration and check for updates to graphics drivers.

more options