X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why does Firefox no longer display .php suffix web pages which are in my Mac?

Posted

I have a question about Firefox 14.0.1 displaying .php suffix web page files which are in a Mac running Mountain Lion OS 10.8. In eaarlier versions of Mac OS, for example 10.4.7, I was able to see properly displayed web page files with .html and .php suffixes when those web page files were in my computer. I refer to seeing the page as it should properly display, not seeing the source code. If a page had a .php suffix, the browser displayed the page properly although any php scripts embedded in that page were ignored.

Apple occasionallly updated its OS and browser makers occasionally updated browsers. One day, I noticed that Safari no longer displayed web page files in my Mac if those pages had a .php suffix. However, Firefox and other browsers continued to display web page files with .php suffixes although the embedded php scripts were ignored.

Now, I have Mountain Lion in iMac.

I can no longer see .php suffix web page files in my computer regarless of the browser I use. No browser displays those pages.

A .php suffix web page file which Firefox and other browsers display in 10.4.7 does not display in 10.8 if that web page file is in the computer.

In my computer, I have html and php suffix web page files I want to see using a browser. The files I want to see and the browser both are in my computer. Html files display perfectly with one exception: if php scripts are embedded in the html files, the scripts are ignored. A file the name of which ends with ".php" will not be displayed regardless of whether there is a php script in the file. Safari displays the source code only. Chrome does not display the file at all. Firefox and SeaMonkey, which displayed .php suffix web page files in earlier versions of the Mac OSm now respond to such pages by providing a dialog box which seems to assume that the file is about to be downloaded from the Internet. The dialog box asks me if I want to use the browser to open the file or if I want to save it to disk. The file is on the disk at the time, and the computer is disconnected from the Internet. I click that I want to use the browser to open the file. Then the dialong box reopens with the same question. This happens over and over. I never get to see a web page file in my computer the name of which ends with ".php". With Firefox 14.0.1, I can see .php suffix web pages which are on the Internet or in a 10.4.7 Mac but not in a 10.8 Mac. Did I miconfigure Firefox? It seems unlikely that Firefox lost the ability to display pages in Mac OS 10.8 which it displays in `10.4.7. How can I solve this web page display problem?

Chosen solution

Thank you for your prompt reply, Ideato. I now think that the problem is not a browser problem but a Mac problem. Although Mac OS 10.8 is much better than 10.4.7 generally, it is worse at displaying .php suffix files. There is an online artile which solved my problem: "How to enable and configure Apache / PHP support for OSX 10.8 Mountain Lion"; July 29, 2012; by Haneez Haroon. There are two solutions Haroon mentions. One is to download and install the latest php, which comes with a web server. The other, which is easier and which Haroon explains in detail, is to turn on apache web server in Mountain Lion and enable loading the php module which comes with Mountain Lion. That module is not as recent as the most recent php whoich comes from php.net.

Read this answer in context 1

Additional System Details

This happened

Every time Firefox opened

This started when...

In Lion OS, 10.7.

Installed Plug-ins

  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:14.0) Gecko/20100101 Firefox/14.0.1

More Information

Name
Firefox
Version
14.0.1
User Agent
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:14.0) Gecko/20100101 Firefox/14.0.1

ideato
  • Top 25 Contributor
616 solutions 4258 answers

Hi gravel,

try in about:config to Resetting download actions, do all the steps and be careful to NOT delete MimeTypes.rdf file from program folder.

Delete(or rename) the MimeTypes.rdf file only inProfile folder .

tell us if the above solve the issue.


thank you

Chosen Solution

Thank you for your prompt reply, Ideato. I now think that the problem is not a browser problem but a Mac problem. Although Mac OS 10.8 is much better than 10.4.7 generally, it is worse at displaying .php suffix files. There is an online artile which solved my problem: "How to enable and configure Apache / PHP support for OSX 10.8 Mountain Lion"; July 29, 2012; by Haneez Haroon. There are two solutions Haroon mentions. One is to download and install the latest php, which comes with a web server. The other, which is easier and which Haroon explains in detail, is to turn on apache web server in Mountain Lion and enable loading the php module which comes with Mountain Lion. That module is not as recent as the most recent php whoich comes from php.net.

ideato
  • Top 25 Contributor
616 solutions 4258 answers

If you try the solutions you mention and solve the problem, please report back to us the solution and choose the solution as Solution Chosen to help other people with the same problem.


thanks again

Question owner

Haroon mentions two solutions. I used the easier one, which is to start the Apache webserver already in Mountain Lion and to enable the php already in Mountain Lion. It worked. I see the file correctly displayed with html, css, and php. I see the page by using Firefox. I enter an address in the address bar. For example, the address might be "localhost/example/example.php". I cannot see the page by using Firefox's "Open File ..." menu option or by dragging the file's icon onto Firefox's icon. I tried using your solution also but was unable to find the specific preference to modify. I found the page of preferences which may be modified but I could not find the one I need. I found a list of descriptions of the preferences at http://kb.mozillazine.org/Firefox_:_FAQs_:_About:config_Entries but I could not find the specific preference which I need.

By the way, to enable loading the php module, one uncomments a line of code by deleting the initial "#" character, and one does that by pressing control key and "P" key while the cursor is over the "#" character.

Also by the way, when I use Firefox or Safari to look at the Apache web directory in which my files are, the files are listed case sensitively. For example, the files are listed: Ace, Zygote, bar. This is because lower case follows upper case. THis annoys me. I prefer case insensitive listing. When I llok directly athe directory without using a browser, the files are listed case insensitively. For example, they are listed: Ace, bar, Zygote. I guess taht Apache is doing this.