X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

how to get rid of bing

Posted

OK, I had to reinstall Firefox, and now, every time I try searching off URL bar, Bing comes as default search engine. I have read this: Bing is added to the search engines that you can use for searching via the search bar on the Navigation Toolbar. If Bing is selected then you can choose another search engine by clicking the search engines icon. Open Manage Search Engines and click "Restore defaults" is some are missing or do a search on the Mycroft site.

See also:

   Removing the Search Helper Extension and Bing Bar 

You can open the about:config page via the location bar and do a search for bing via the Filter at the top of that page. You can reset all bing related prefs via the right-click context menu to their default values.

I have removed Bing from search engines list. 5 times. Clicking "restore defaults" actually brings Bing back into list. I have modified Bing to Google via "about:config". Same difference - Bing stubbornly defaults as search engine when searching from URL bar.

Suggestions?

Additional System Details

Sites Affected

http://

Installed Plug-ins

  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20100101 Firefox/14.0.1

More Information

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6641 answers

Chosen Solution

Try installing https://addons.mozilla.org/en-US/firefox/addon/searchreset/.

Question owner

Worked. Thank you.

Question owner

and Bing is back....

jscher2000
  • Top 10 Contributor
2365 solutions 20923 answers

Helpful Reply

If you have add-ons that change your settings, then this will happen, possibly each time you restart Firefox. You probably need to review your add-ons and disable or remove everything nonessential.

orange Firefox button or classic Tools menu > Add-ons

Check the Plugins and particularly the Extensions. After restarting Firefox, run the search reset again and hopefully this time it will stick.

Question owner

Thank you. What exactly to look for? I see no Bing name bearing s/w anywhere.

I have older version of FFx at home and have none of this trouble.
jscher2000
  • Top 10 Contributor
2365 solutions 20923 answers

There are many possibilities. You can post of list of extensions for review if you like. If you open the following page, you can copy/paste the table under the heading Extensions:

Help > Troubleshooting Information

Question owner

OK, I have no add ons that even remotely refer to Bing; all extensions same way. MOF, I have only 2 plgins enabled, and only Java running, and all add ons disabled. So, it's a mystery.

jscher2000
  • Top 10 Contributor
2365 solutions 20923 answers

I think the trick is that it isn't an official Microsoft Bing extension. If you click the "More" link for an Extension, sometimes the detailed write-up will mention using Bing technology. But it also could be completely hidden. Did you try disabling all (nonessential) extensions?

jscher2000
  • Top 10 Contributor
2365 solutions 20923 answers

I may have misread your last post. After disabling nonessential extensions, run the search reset again. Hopefully then it won't revert back.

Question owner

Everything is disabled or removed. Bing comes back like a bad penny. Just did it again. I run search tool, it goes away - and is back in a heartbeat. And it does this only from latest FFx and only from URL bar. I guess, I wasted enough time on this.

Thank you for your help. I'll just stay away from url searches. Reason being, that's how I log into my bank account. Simple Google search already brought me several times to phishing sites.

jscher2000
  • Top 10 Contributor
2365 solutions 20923 answers

You also can disable URL bar searching to avoid accidental searches. It's one of two related preferences:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste keyword and pause while the list is filtered

(3) To reset the search provider, right-click keyword.URL and choose Reset. To turn off the feature, double-click keyword.enabled to toggle it to false. In that case, search attempts will return a server not found error (or, if your ISP/DNS provider has its own search, their page).

Question owner

OK, I did it and it worked for url bar. Also, I recall doing this once before. Apparently, there's something on my machine that keeps restoring bing. Also, I came across a post somewhere that Microsoft is imposing Bing onto browsers.. true or not.

Thank you. I'll report later, if it comes back.

njnicholas.micalone 0 solutions 2 answers

I have FF 17 and XP. A search shows dozens of Bing files, most of which I can not delete. Registry shows multiple Bing and Google entries. Can they be replaced with DuckDuckGo? There is a Google registry entry whose value is a string of numbers; Is that the item preventing Google deletion as a default search engine? Can I safely delete it?

An aside- do these misfits really believe usurping search engines engenders good feelings for their product? I believe they are psychopaths suffering from a weakling complex.

jscher2000
  • Top 10 Contributor
2365 solutions 20923 answers

Hi njnicholas.micalone, when you say a search shows multiple files, where did you search? Most of Firefox's search-related settings are stored in your personal settings (AKA Firefox profile) folder in various settings files, and are subject to be altered by add-ons. This makes it complicated to give general advice in a few paragraphs.

Which searches do you want to change?

  • Default in search box (the one with the drop-down on the left)
  • Address bar
  • Built-in Firefox home page
  • "New tab" page
  • Other

On the third one, the code for DuckDuckGo is in this thread: Can you change the search engine from Google to something else on the Firefox default home page?

igbar 0 solutions 1 answers

My problem is a little different. When creating a new tab (ctrl-t or +) a new tab is created and it looks *almost* like my google page startup but in fact if you use the search bar center page it is Bing. The rat *#&$ at Microsoft corrupted it so bad I had to RESET firefox so it would stop happening. None of the suggestions here would fix the problem. Only extensions were java, quicktime, adobe and silverlight (possible culprit). If anyone knows of any other way to fix this please let me know for the future.

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

If there is a problem with searching via the default about:home page then try to reset the search engine used on the about:home page.

Reset the browser.startup.homepage_override.mstone pref via the right-click context menu to the default on the about:config page and close and restart Firefox to restore the about:home page to its default.

  1. Open the about:config page via the location bar
  2. Type in the Filter bar: mstone
  3. Right-click the browser.startup.homepage_override.mstone line and select: Reset
  4. Close and restart Firefox

If this didn't help then delete the delete the chromeappsstore.sqlite file in the Firefox Profile Folder and repeat the above.

dutchie1994 0 solutions 1 answers

I tried the suggestion about monitoring add-ons, but couldn't get my add-ons to come up. In fact, since I (finally) got rid of Bing & switched it back to Google, I often have this "click and nothing happens" problem. And there's a very annoying little box which will NOT close, which says "an attempt to change your home page and default search has been blocked." Can't close that box.

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.