X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

firefox 14.0.1 do this automatically is greyed out

Posted

I run Firefox 14.0.1 but the same problem was on 13.0.1 on my Mac. I have been downloading the same type of file and it has previously opened in Preview. Now Firefox says the default app is TextEdit and I can manually select Preview or Adobe buyt I cannot select the "do this automatically . . . : as it is greyed out. The downloaded file is a document file.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.3 r300
  • Plugin that detects installed Citrix Online products (visit www.citrixonline.com).
  • Java Plug-In 2 for NPAPI Browsers
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Office Live Update v1.0
  • Garmin Communicator Plug-in Version 4.0.1.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:14.0) Gecko/20100101 Firefox/14.0.1

More Information

Have searched the web but found no recent relevant info.

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

This usually happens if the file is send with a specific MIME type that is currently associated with the TextEdit application.
You can check if you find that action in Tools > Options > Applications and change accordingly.

See also:


You can to delete the mimeTypes.rdf file in the Firefox Profile Folder to reset all file actions.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Open Containing Folder

Question owner

Thanks for the tips. Am a bit lost though as I cannot find Tools>Options>Applications. In Firefox>preferences>Applications I find Content type and Actions but there is nothing listed as documents in Content Type and nothing listed as TextEdit in Actions. Yesterday I deleted the mimetypes.rdf file but Firefox still behaves the same as yesterday - files not recognized. Under the Tools menu I have Web Search, Downloads, Add-ons, Plugins, Sync Now, Web Developer, Page Info, Start Private Browsing and Clear Recent History. Where can I find Tools>Options>Applications that you refer to? Thanks in advance.