Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Wordpress Blog Slow in Firefox

  • 6 replies
  • 2 have this problem
  • 2 views
  • Last reply by Dado

more options

Firefox is having problems loading our wordpress blog (i.e. it is very slow). Anyone else having this problem or have suggestions? It seems to be working just fine in other browsers. Seem to have a few pages load fine and then it slows down considerably.

Firefox is having problems loading our wordpress blog (i.e. it is very slow). Anyone else having this problem or have suggestions? It seems to be working just fine in other browsers. Seem to have a few pages load fine and then it slows down considerably.

All Replies (6)

more options

I didn't notice anything unusual; I find Wordpress to be a bit slow in general.

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

1. Clear Firefox's Cache

(MAC) Firefox > Preferences > Advanced
(WIN) orange Firefox button or Tools menu > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

2. If needed, delete the site's cookies here while viewing a page on the site (this will log you out)

(MAC) Tools > Page Info > Security > "View Cookies"
(WIN) right-click > View Page Info > Security > "View Cookies"

Then try reloading the page. Does that help?

more options

Thanks, jscher2000.

Unfortunately that did not resolve the issue. In the error console I'm getting a lot of warnings like the following:

Timestamp: 8/9/12 12:52:36 PM Warning: Unknown property '-moz-border-radius'. Declaration dropped. Source File: http://www.glutenfreegrapevine.com/wp-content/themes/parallelus-salutation/assets/css/bbpress.css Line: 208



Timestamp: 8/9/12 12:52:36 PM Warning: Unknown property '-moz-border-radius'. Declaration dropped. Source File: http://www.glutenfreegrapevine.com/wp-content/themes/parallelus-salutation/assets/css/bbpress.css Line: 237




Timestamp: 8/9/12 12:52:36 PM Warning: Unknown property '-moz-border-radius'. Declaration dropped. Source File: http://www.glutenfreegrapevine.com/wp-content/themes/parallelus-salutation/assets/css/bbpress.css Line: 249


Not sure if any of this is relevant?

Also, some wordpress sites can be slow, but I'm not getting that in any other browsers. Just Firefox.

Thanks for your help!

more options

Those style sheet warnings would not affect the speed of the site, just the roundness of boxes and buttons. Your theme might have an update for that.

I can only compare Fx14 and IE8, and I don't see an appreciable difference.


A standard diagnostic for interference by add-ons is to try Firefox's Safe Mode.

First, I recommend backing up your Firefox settings in case something goes wrong. See Back up and restore information in Firefox profiles. (You can copy your entire Firefox profile folder somewhere outside of the Mozilla folder.)

Next, restart Firefox in Firefox's Safe Mode (Diagnose Firefox issues using Troubleshoot Mode) using

Help > Restart with Add-ons Disabled

In the Safe Mode dialog, do not check any boxes, just click "Continue in Safe Mode."

Any change?

more options

Thanks again for the reply!

I did exactly as you said and I'm still getting the same issue. Oddly, my partner had the same issue but it seems to be resolved for her after we made some changes in Apache rewrite. Not me. Odd!

more options

Reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Press and hold Shift and left-click the Reload button.
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Cmd + Shift + R" (MAC)
more options

probably there is a problem with your cache plugin in your WP.... try to modified it to cache requests from Mozilla browsers in diferent folder an forbide for mozilla browsers to create their own cache on your computer (or other client computer)... if that didnt work, change it... forbide your cache plugin to cache and serve cached files to mozilla browsers but let them to create their own cache on clients computer... try to use manifest file it will reduse loading yours site and it is much better then cache plugins... or use it both... and, but this is very long workout, lookout and check all of CSS files on your WP because maybe Mozilla/Firefox will ignore that mistakes and maybe he try to find solution or get him self in circuling around... lookup on internet sites what have suggestions how to make and code css files friendly with mozilla browsers (firefox) and for other browsers with same css file... and DO NOT FORGET that every time you made one of my suggestions EMPTY BOTH, and WP cache and Firefox cache... if it didnt help you answer me with this information: list of plugins on your WP, text in your .htacces file in the root (dont worry, that cannot help me to hack your site) because I need to now how you did tell Apache to rewrite requests for WP and witch mods are you using and what is the behavier of cache if there is instaled... if you can, write me too which Apache is installed on server, MySQL and other information, like max memory an so on, and is your server on windows platform or on unix/linux.... trust me, I have made a hundreds of WP sites, try tousends wp plugins, read hundreds of programming forums and so on...

Modified by Dado