X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

typing in url for my company website sends it to https index page in Firefox, but not IE or Chrome, and the behavoir is not wanted

Posted

After upgrading Firefox to version 14.0.1 i noticed when i typed in my company's website address that firefox went to the https:// version of the site when it never did that before.

Example, if you type in amazon.com in the URL bar, you briefly see that firefox turns the url to https://www.amazon.com before being auto directed to the normal www.amazon.com site.

My website did not have a secure index page and people were getting a server generated message until I found this issue out.

Is there a setting in Firefox to prevent the URL bar from selecting a secure connection first? This behavior does not occur in the most recent versions of I.E. or Chrome browsers on a desktop.

Any help would be greatly apprecaited

Chosen solution

Following solution worked for me. Just put following in the .htaccess file on your server and put your domain name instead of domain example below:

Read this answer in context 1

Additional System Details

Sites Affected

http://www.WorldMusic.org

Installed Plug-ins

  • Shockwave Flash 11.3 r300
  • Pando Web Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Next Generation Java Plug-in 1.6.0_32 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.5.635
  • iTunes Detector Plug-in
  • 4.1.10329.0
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.1"
  • QUAKE LIVE
  • LogMeIn, Inc. Remote Access Components
  • Unity Player 3.1.0f4
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:14.0) Gecko/20100101 Firefox/14.0.1

More Information

jscher2000
  • Top 10 Contributor
2366 solutions 20923 answers

Hi pfeely, this --

When I specify "http" - and the page is redirected to "https" - it makes it very difficult to test the page.

-- shouldn't happen. In other words, if you specify the full URL yourself, Firefox should use that URL. But if you accept the autofill suggestion based on partial input, then https may be used contrary to your expectations.

Unless there's something new going on, autofill is the cause of this problem. If you have a scenario where an item from the autocomplete drop-down, or a bookmark, or a link is having its protocol switched, that probably would be a new bug. (New to me, at least.)

pfeely 0 solutions 2 answers

The mod rewrite option is not a solution when some sections of the site are supposed to work over ssl, but others are not.

Its also a bit extreme to do a mod rewrite for a glitch/bug in one browser

jscher2000
  • Top 10 Contributor
2366 solutions 20923 answers

Hi pfeely, here on the support side, it's mostly about workarounds. Have you voted for the bug to be fixed? (You need to create a Bugzilla account in order to vote.) 769994 – Inline autocomplete selects HTTPS domain against HTTP domain by default

amibangali 0 solutions 2 answers

I used to like firefox but now I have to say it is garbage browser now. The above solution also works fine in all other browsers except firefox but other browsers did not have any issue to the posted solution is useless.

In my scenario my SSL is for http and firefox forcing https://www.mydomain.com

I modified this to

RewriteEngine On RewriteCond %{HTTPS} on RewriteRule ^$ http://mydomain.com/ [R=301,L]

Am I missing anything? Confused how it fixed others issue?

Looks like I have to buy another SSL to fix this annoying firefox bug?

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Note that this only happens if auto fill in the location bar is enabled in Firefox (browser.urlbar.autoFill and browser.urlbar.autoFill.typed are true) and you have visited pages on that server in the past via a secure HTTPS connection.

amibangali 0 solutions 2 answers

I know but we run an eCommerce store with thousands of old customers and if they see this problem some leave, some get angry thinking it is our fault where it is actually firefox bug. Telling them to turn off url autocomplete is not always an option.