X
Tap here to go to the mobile version of the site.

Support Forum

us.battle.net Connection Not Trusted.

Posted

When I try to connect to https://us.battle.net (World of Warcraft). I get connection not trusted. But only on this laptop, my desktop will connect. So far just battle.net has given me this error, I can connect to other https:// sites.

error info; us.battle.net uses an invalid security certificate.

The certificate is not trusted because no issuer chain was provided.

(Error code: sec_error_unknown_issuer)

It can't be a default setting as my other computer loads fine. and yes, I have read many posts, even the system clock idea. My clock is right on with the current U.S. pacific time.

When I try to connect to https://us.battle.net (World of Warcraft). I get connection not trusted. But only on this laptop, my desktop will connect. So far just battle.net has given me this error, I can connect to other https:// sites. error info; us.battle.net uses an invalid security certificate. The certificate is not trusted because no issuer chain was provided. (Error code: sec_error_unknown_issuer) It can't be a default setting as my other computer loads fine. and yes, I have read many posts, even the system clock idea. My clock is right on with the current U.S. pacific time.

Chosen solution

Hey, looks like Blizzard or Digicert finally fixed the broken link. Run the site test and it shows it's working.

I checked and no more untrusted site error from us.battle.net, and no more black box when clicking the quick sign in.

Read this answer in context 0

Additional System Details

Sites Affected

https://us.battle.net

Installed Plug-ins

  • Shockwave Flash 11.2 r202
  • Unity Player 3.5.2f2
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.5.1 for Mozilla browsers
  • 5.1.10411.0
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.2
  • Intel Indeo® video 5.1 PD Plug-In

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1

More Information

I completely removed Firefox 14 and reinstalled, still no go.
I tried using cocoon, the privacy proxy addon, and it will connect with no trouble.
This gets me thinking, is it a fire fox proxy issue?
If so, why one computer and not the other?
Could it be a Norton internet security bug/setting? My other computer is using Avast. I tried disabling all of Norton but still blocked.

cor-el
  • Top 10 Contributor
  • Moderator
13046 solutions 119473 answers

The us.battle.net server doesn't send all required intermediate certificate(s).

You can inspect the certificate chain via a site like this:

You can copy the "DigiCert High Assurance EV CA-1" certificate text to a plain text file and import the file in the Certificate Manager.

  • Tools > Options > Advanced : Encryption: Certificates - View Certificates: Authorities

Do not check off any of the boxes on the import confirmation pop-up as those aren't required for intermediate certificates.

Also available here:

The us.battle.net server doesn't send all required intermediate certificate(s). You can inspect the certificate chain via a site like this: *http://www.networking4all.com/en/support/tools/site+check/ *http://www.digicert.com/help/ You can copy the "DigiCert High Assurance EV CA-1" certificate text to a plain text file and import the file in the Certificate Manager. *Tools > Options > Advanced : Encryption: Certificates - View Certificates: Authorities Do not check off any of the boxes on the import confirmation pop-up as those aren't required for intermediate certificates. Also available here: *https://www.digicert.com/ssl-support/windows-cross-signed-chain.htm

Modified by cor-el

Helpful Reply

Thank you for the reply, I may have read a similar fix, but I'm wondering if there isn't a setting or fix that doesn't involve downloading and importing files yourself.

As I said, one computer using FF 14 will connect and have the info while this laptop wont. For the life of me I can't figure out why one works and not the other.

can anyone see the trouble shooting I've done so far? O.o If not, I tried an add-on called "cocoon" it's a proxy privacy tool. If I use cocoon, battle.net will load. also I was wondering if Norton internet security may have changed the way FF gets the info for a certificate. I disabled Norton and still couldn't get battle.net to open though. Just a guess because my other computer is using Avast.

Thank you for the reply, I may have read a similar fix, but I'm wondering if there isn't a setting or fix that doesn't involve downloading and importing files yourself. As I said, one computer using FF 14 will connect and have the info while this laptop wont. For the life of me I can't figure out why one works and not the other. can anyone see the trouble shooting I've done so far? O.o If not, I tried an add-on called "cocoon" it's a proxy privacy tool. If I use cocoon, battle.net will load. also I was wondering if Norton internet security may have changed the way FF gets the info for a certificate. I disabled Norton and still couldn't get battle.net to open though. Just a guess because my other computer is using Avast.
cor-el
  • Top 10 Contributor
  • Moderator
13046 solutions 119473 answers

It is a problem on the server and it should be fixed on their side.
You only see this error if you have never visited a website before that has send this intermediate certificate because Firefox stores them in the cert8.db file and use them automatically if needed (I didn't have the SSL error).

You should contact the website and inform them of the incorrect server configuration.
They can verify the SSL chain via the DigiCert test site.

It is a problem on the server and it should be fixed on their side.<br /> You only see this error if you have never visited a website before that has send this intermediate certificate because Firefox stores them in the cert8.db file and use them automatically if needed (I didn't have the SSL error).<br /> You should contact the website and inform them of the incorrect server configuration.<br /> They can verify the SSL chain via the DigiCert test site. *http://www.digicert.com/help/

Question owner

sadly this problem has been posted a few times on blizzard forums. however because the admins don't get the error they seem very reluctant to admit anything is wrong.

I did successfully visit battle.net using cocoon, but when I turn it off, FF still errors. Is this part of the private browsing feature? even certificate info isn't being saved?

sadly this problem has been posted a few times on blizzard forums. however because the admins don't get the error they seem very reluctant to admit anything is wrong. I did successfully visit battle.net using cocoon, but when I turn it off, FF still errors. Is this part of the private browsing feature? even certificate info isn't being saved?
cor-el
  • Top 10 Contributor
  • Moderator
13046 solutions 119473 answers

You can easily reproduce the error in Firefox if you (temporarily) remove the cert8.db file or use a new profile or delete the intermediate "DigiCert High Assurance EV CA-1" certificate in the Certificate Manager.

  • Tools > Options > Advanced : Encryption: Certificates - View Certificates > Authorites.
You can easily reproduce the error in Firefox if you (temporarily) remove the cert8.db file or use a new profile or delete the intermediate "DigiCert High Assurance EV CA-1" certificate in the Certificate Manager. *Tools > Options > Advanced : Encryption: Certificates - View Certificates > Authorites.

Chosen Solution

Hey, looks like Blizzard or Digicert finally fixed the broken link. Run the site test and it shows it's working.

I checked and no more untrusted site error from us.battle.net, and no more black box when clicking the quick sign in.

Hey, looks like Blizzard or Digicert finally fixed the broken link. Run the site test and it shows it's working. I checked and no more untrusted site error from us.battle.net, and no more black box when clicking the quick sign in.