X
Tap here to go to the mobile version of the site.

Support Forum

Address bar search is not working

Posted

When I type keywords into the address bar, it used to return a list of google search results. Now, it returns "The address isn't valid". I know I can use the search bar to search google, but the ability to search keywords straight from the address bar is my number one favourite feature of Firefox and I want it back.

The problem started after I returned the keyword.URL setting in about:config to default after it was maliciously changed to some Russian search/spam site, which also added a bunch of useless links to my bookmarks bar. This is the second time this has happened, no idea how, but the first time I fixed it the address bar search started working again right away.

I have not installed any new plugins or add-ons recently.

I have checked that keyword.enabled is set to true, and keyword.URL is blank, which are the default settings. Are there any other settings that might have been changed/that I should change to make this work again?

When I type keywords into the address bar, it used to return a list of google search results. Now, it returns "The address isn't valid". I know I can use the search bar to search google, but the ability to search keywords straight from the address bar is my number one favourite feature of Firefox and I want it back. The problem started after I returned the keyword.URL setting in about:config to default after it was maliciously changed to some Russian search/spam site, which also added a bunch of useless links to my bookmarks bar. This is the second time this has happened, no idea how, but the first time I fixed it the address bar search started working again right away. I have not installed any new plugins or add-ons recently. I have checked that keyword.enabled is set to true, and keyword.URL is blank, which are the default settings. Are there any other settings that might have been changed/that I should change to make this work again?

Chosen solution

You could try this add-on to see whether it cures it: SearchReset

If not, you could use this for keyword.URL, which appears to be the default in Firefox 14 (just based on what I get running a search):


https://www.google.com/search?ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a&channel=fflb&q=
Read this answer in context 8

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.3 r300
  • Next Generation Java Plug-in 1.6.0_33 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • VLC media player Web Plugin 2.0.2
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • 4.1.10329.0
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.1"
  • Easy and convenient screenshot tool
  • Picasa plugin
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Office Plugin for Netscape Navigator

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1

More Information

jscher2000
  • Top 10 Contributor
3272 solutions 29859 answers

Chosen Solution

You could try this add-on to see whether it cures it: SearchReset

If not, you could use this for keyword.URL, which appears to be the default in Firefox 14 (just based on what I get running a search):


https://www.google.com/search?ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a&channel=fflb&q=
You could try this add-on to see whether it cures it: [https://addons.mozilla.org/en-US/firefox/addon/searchreset/ SearchReset] If not, you could use this for keyword.URL, which appears to be the default in Firefox 14 (just based on what I get running a search): <br>https://www.google.com/search?ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a&channel=fflb&q=
jscher2000
  • Top 10 Contributor
3272 solutions 29859 answers

It's also possible that your system is not yet clean. This isn't the best board for removal of sophisticated malware, but I can at least suggest two tools for supplemental scans:

Malwarebytes Anti-malware : http://www.malwarebytes.org/products/malwarebytes_free

SUPERAntiSpyware : http://www.superantispyware.com/

It's also possible that your system is not yet clean. This isn't the best board for removal of sophisticated malware, but I can at least suggest two tools for supplemental scans: Malwarebytes Anti-malware : http://www.malwarebytes.org/products/malwarebytes_free SUPERAntiSpyware : http://www.superantispyware.com/
cor-el
  • Top 10 Contributor
  • Moderator
12361 solutions 114347 answers
You can also check for possibly installed extension. *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes If you do not keep changes after a restart then see: *http://kb.mozillazine.org/Preferences_not_saved *https://support.mozilla.org/kb/Preferences+are+not+saved

Question owner

Thanks for the links. I have the unpleasant feeling that the recurring nature of the original bug means my system isn't clean, so hopefully these will help get rid of the original issue.

Thanks for the links. I have the unpleasant feeling that the recurring nature of the original bug means my system isn't clean, so hopefully these will help get rid of the original issue.