X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 14 User Interface font size wrong and can't be changed

Posted

Following auto-upgrade to Firefox 14, all the Firefox user interface strings are in Times New Roman pt 8 or 9 (way too small). I cannot change them any which way, I have tried Settings, no change (including restart and reboot). I have used the Restore function. No change.

System is Windows XP Pro.

Following auto-upgrade to Firefox 14, all the Firefox user interface strings are in Times New Roman pt 8 or 9 (way too small). I cannot change them any which way, I have tried Settings, no change (including restart and reboot). I have used the Restore function. No change. System is Windows XP Pro.

Modified by akerbeltz

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.3 r300
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.5.1 for Mozilla browsers
  • 5.1.10411.0
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.1"
  • Google Update
  • Yahoo Application State Plugin version 1.0.0.7

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1

More Information

dumdidadida 155 solutions 1440 answers

Hi,

If you had used an add-on previously you can try to adjust its Options in Tools (Alt + T) > Add-ons > Extensions.. You can also consider the Reset Firefox feature via Help (Alt + H) > Troubleshooting Information.

Hi, If you had used an add-on previously you can try to adjust its '''Options''' in '''Tools''' ('''Alt''' + '''T''') > '''Add-ons''' > '''Extensions'''.. You can also consider the [https://support.mozilla.org/en-US/kb/reset-firefox-easily-fix-most-problems Reset Firefox] feature via '''Help''' ('''Alt''' + '''H''') > '''Troubleshooting Information'''.

Question owner

No addon affecting layout/style etc was used. Ever. And I already reset Firefox (see above, sorry, called it Restore, same thing)

No addon affecting layout/style etc was used. Ever. And I already reset Firefox (see above, sorry, called it Restore, same thing)
dumdidadida 155 solutions 1440 answers

If you would like to change the defaults you can try an add-on like the Theme Font & Size Changer.

Can you also please create a screenshot of the problem you're seeing by following the guide mentioned at How do I create a screenshot of my problem?.

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. You really help us to visualize the problem.

If you would like to change the defaults you can try an add-on like the [https://addons.mozilla.org/en-US/firefox/addon/theme-font-size-changer/?src=search Theme Font & Size Changer]. Can you also please create a screenshot of the problem you're seeing by following the guide mentioned at [[How do I create a screenshot of my problem?]]. Once you've done this, attach the saved screenshot file to your forum post by clicking the '''Browse...''' button below the ''Post your reply'' box. You really help us to visualize the problem.

Question owner

They can't be the default because I have 2 more machines, different OS (Win 7 and Ubuntu) but also running Firefox 14 who *don't* have that problem. I'm attaching a screenshot. Thanks for your efforts :)

They can't be the default because I have 2 more machines, different OS (Win 7 and Ubuntu) but also running Firefox 14 who *don't* have that problem. I'm attaching a screenshot. Thanks for your efforts :)

Question owner

These are the current font settings. I know 16 is way too big but I wanted to make sure that if there's a change I can see it - yet everything remain stubbornly tiny and TNR.

These are the current font settings. I know 16 is way too big but I wanted to make sure that if there's a change I can see it - yet everything remain stubbornly tiny and TNR.
dumdidadida 155 solutions 1440 answers

It certainly looks tiny. The Firefox options is for the displaying of the web pages. It doesn't affect the UI. I think the user interface follows the Windows resolution, and Firefox's own internal preference, and can be changed by either changing the Firefox theme, using CSS, using an add-on, or increasing the Windows OS resolution or font DPI. Do all the PCs have the same resolution and DPI, how do the menus appear on other programs on the same PC??

It certainly looks tiny. The Firefox options is for the displaying of the web pages. It doesn't affect the UI. I think the user interface follows the Windows resolution, and Firefox's own internal preference, and can be changed by either changing the Firefox theme, using CSS, using an add-on, or increasing the Windows OS resolution or font DPI. Do all the PCs have the same resolution and DPI, how do the menus appear on other programs on the same PC??

Question owner

Same resolution on all PCs and it's ONLY the Firefox menus which are tiny/affected. If it was the Windows settings, then I'd expect other programs to be affected too but that's not the case.

Same resolution on all PCs and it's ONLY the Firefox menus which are tiny/affected. If it was the Windows settings, then I'd expect other programs to be affected too but that's not the case.
dumdidadida 155 solutions 1440 answers

There is a similar thread here that goes through different methods you can try to resolve this.

There is a similar thread [https://support.mozilla.org/en-US/questions/932159 here] that goes through different methods you can try to resolve this.

Question owner

No corrupted fonts and ff is a unicode program so that other doesn't apply. Also just tried starting Firefox with all addons disabled - no difference.

No corrupted fonts and ff is a unicode program so that other doesn't apply. Also just tried starting Firefox with all addons disabled - no difference.
jscher2000
  • Top 10 Contributor
8684 solutions 70998 answers

Hi akerbeltz, did you try the add-on suggested in https://support.mozilla.org/en-US/questions/932621#answer-353089 ?

Hi akerbeltz, did you try the add-on suggested in https://support.mozilla.org/en-US/questions/932621#answer-353089 ?
John99 971 solutions 13138 answers

You may also be interested in the threads /questions/932481 & /questions/932512

Additionally note it is possible to effectively increase user interface magnification by adjusting a preference layout.css.devPixelsPerPx /questions/780925

You may also be interested in the threads [/questions/932481] & [/questions/932512] Additionally note it is possible to effectively increase user interface magnification by adjusting a preference ''layout.css.devPixelsPerPx'' [/questions/780925]

Question owner

Which one? There's a number of them and I think I tried most. I'm not entirely sure that, given that a large number of addons can cause instabilities, an addon is the solution?

Which one? There's a number of them and I think I tried most. I'm not entirely sure that, given that a large number of addons can cause instabilities, an addon is the solution?

Question owner

Thanks John99 but I'm not talking about the icons - it's the fonts. Just the fonts :/

Thanks John99 but I'm not talking about the icons - it's the fonts. Just the fonts :/
jscher2000
  • Top 10 Contributor
8684 solutions 70998 answers

Which one? There's a number of them and I think I tried most. I'm not entirely sure that, given that a large number of addons can cause instabilities, an addon is the solution?

It's true, add-ons can conflict, and I'm sure having a lot of them can slow down Firefox. But I think this one is worth a try to see whether it helps until we figure out why your default theme is not matching your system font settings. (Or your system font is corrupted, as the case may be.)

Theme Font & Size Changer :: Add-ons for Firefox

''Which one? There's a number of them and I think I tried most. I'm not entirely sure that, given that a large number of addons can cause instabilities, an addon is the solution?'' It's true, add-ons can conflict, and I'm sure having a lot of them can slow down Firefox. But I think this one is worth a try to see whether it helps until we figure out why your default theme is not matching your system font settings. (Or your system font is corrupted, as the case may be.) [https://addons.mozilla.org/en-US/firefox/addon/theme-font-size-changer/ Theme Font & Size Changer :: Add-ons for Firefox]
cor-el
  • Top 10 Contributor
  • Moderator
17465 solutions 157833 answers

The font setting in Tools > Options only applies to web pages and not to the user interface.

  • Tools > Options > Content : Fonts & Colors > Advanced

If there are problems with the font in the user interface then it is most likely a problem with the used font (possibly MS Shell Dlg)or with hardware acceleration.

You can check the used font with the DOM Inspector.

Open the browser window in the DOMi (File > Inspect Chrome Document) and choose the first from the list.
Click the "Find a node to inspect by clicking on it" button and use the keyboard (Alt Tab) or the Task bar to go back to the browser window (do not click in the browser window other than the title bar).
Click that element (URL bar) with the mouse and keep the button pressed until you see a red border to indicate the the DOMi has located that element in the DOM tree.
If you go back to the DOMi then that element should be selected in the left pane of the DOM Inspector.
You can click the header icon in the right pane to switch the display to Computed Style and check the font-family.

Maybe also do a font test to see if you can identify corrupted or otherwise not working font(s).

The font setting in Tools > Options only applies to web pages and not to the user interface. *Tools > Options > Content : Fonts & Colors > Advanced If there are problems with the font in the user interface then it is most likely a problem with the used font (possibly MS Shell Dlg)or with hardware acceleration. You can check the used font with the DOM Inspector. * DOM Inspector: https://addons.mozilla.org/firefox/addon/dom-inspector-6622/ Open the browser window in the DOMi (File > Inspect Chrome Document) and choose the first from the list.<br /> Click the "Find a node to inspect by clicking on it" button and use the keyboard (Alt Tab) or the Task bar to go back to the browser window (do not click in the browser window other than the title bar).<br /> Click that element (URL bar) with the mouse and keep the button pressed until you see a red border to indicate the the DOMi has located that element in the DOM tree.<br /> If you go back to the DOMi then that element should be selected in the left pane of the DOM Inspector.<br /> You can click the header icon in the right pane to switch the display to Computed Style and check the font-family. Maybe also do a font test to see if you can identify corrupted or otherwise not working font(s). *http://browserspy.dk/fonts-flash.php?detail=1

Modified by cor-el

DAOWAce 0 solutions 16 answers

I don't see how people don't see the change in FF14.

Maybe they don't change their default Windows font from the god awful Segoe UI and FF14 is now using a system font that was set for whatever reason.

This is not in the changelog.

Regardless, this and the auto-complete change (which is probably an option, but I never checked once I saw the worse font) is stopping me from updating to FF14.

More on fonts: I can't use hardware acceleration in FF4+ because it wrecks the font and makes it look absolutely terrible and gives me a headache if I try to read it. I've tweaked the font rendering settings trying everything possible and all of them look terrible, so the only solution has been to disable DirectWrite/Direct2d; so I have a slower than normal browser, yay.

Don't know why companies have to keep changing UI's, all it does is irritate and drive away old users.

I don't see how people don't see the change in FF14. Maybe they don't change their default Windows font from the god awful Segoe UI and FF14 is now using a system font that was set for whatever reason. This is not in the changelog. Regardless, this and the auto-complete change (which is probably an option, but I never checked once I saw the worse font) is stopping me from updating to FF14. More on fonts: I can't use hardware acceleration in FF4+ because it wrecks the font and makes it look absolutely terrible and gives me a headache if I try to read it. I've tweaked the font rendering settings trying everything possible and all of them look terrible, so the only solution has been to disable DirectWrite/Direct2d; so I have a slower than normal browser, yay. Don't know why companies have to keep changing UI's, all it does is irritate and drive away old users.

Question owner

I had already tried http://browserspy.dk/fonts-flash.php?detail=1 and mentioned that according to it, there are no problems.

Ok, I ran Theme Font & Size Changer. When it came up, it had all set to Normal (see screenshot). Changing the size and font is working, so so far, so good ;)

I'd still like to get to the bottom of this though cause in theory, I shouldn't have to install an addon to get the default size/font :)

I had already tried http://browserspy.dk/fonts-flash.php?detail=1 and mentioned that according to it, there are no problems. Ok, I ran Theme Font & Size Changer. When it came up, it had all set to Normal (see screenshot). Changing the size and font is working, so so far, so good ;) I'd still like to get to the bottom of this though cause in theory, I shouldn't have to install an addon to get the default size/font :)
dumdidadida 155 solutions 1440 answers

One more thing you could try is to set the Windows theme to Windows XP style to check if the problem repeats in the default system theme.

One more thing you could try is to set the Windows theme to Windows XP style to check if the problem repeats in the default system theme.
jscher2000
  • Top 10 Contributor
8684 solutions 70998 answers

I don't see how people don't see the change in FF14. Maybe they don't change their default Windows font from the god awful Segoe UI and FF14 is now using a system font that was set for whatever reason.

I use Tahoma for menus on my XP systems. Which font did you choose?

Sorry, DAOWAce, you are new on this thread and didn't mention your OS version. I'll have to check the font I use on my Windows 7 systems. But I haven't noticed any change in Fx14. I also minimize the use of ClearType and turn off hardware acceleration because I find the anti-aliasing unattractive.

''I don't see how people don't see the change in FF14. Maybe they don't change their default Windows font from the god awful Segoe UI and FF14 is now using a system font that was set for whatever reason.'' I use Tahoma for menus on my XP systems. Which font did you choose? Sorry, DAOWAce, you are new on this thread and didn't mention your OS version. I'll have to check the font I use on my Windows 7 systems. But I haven't noticed any change in Fx14. I also minimize the use of ClearType and turn off hardware acceleration because I find the anti-aliasing unattractive.

Modified by jscher2000

Question owner

All the system display is still default anyway, which for XP is ... XP as I said. Firefox is the ONLY place on the entire system where this font problem occurs.

All the system display is still default anyway, which for XP is ... XP as I said. Firefox is the ONLY place on the entire system where this font problem occurs.