X
Tap here to go to the mobile version of the site.

Support Forum

How do I get rid of MySuperCheap that comes up on travel sites?

Posted

When I'm selecting the fares on travel sites, MySuperCheap pop up appears on the page and will pop up options for other default sites.

When I'm selecting the fares on travel sites, MySuperCheap pop up appears on the page and will pop up options for other default sites.

Chosen solution

I got rid of it by going to Tools -> Add-ons and then the Extensions tab and removed YonToo.

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:13.0) Gecko/20100101 Firefox/13.0.1

More Information

ideato 893 solutions 6250 answers

Helpful Reply

In Tools > Options > Content > check "Block Popup Windows" .

If the above is not helpful try the awesome Adblock Plus add-on

see also for info: Popups not blocked


thank you

Please mark "Solved" the answer that really solve the problem, to help others with a similar problem.

In Tools > Options > Content > check "Block Popup Windows" . If the above is not helpful try the awesome [https://addons.mozilla.org/en-us/firefox/addon/adblock-plus/ Adblock Plus add-on] see also for info: [http://kb.mozillazine.org/Pop-ups_not_blocked Popups not blocked] thank you Please mark "Solved" the answer that really solve the problem, to help others with a similar problem.

Question owner

It is more like an ap that has hijacked my browser. i.e. on the Southwest airlines website, I do not get this if I use Explorer or Firefox on another PC (see attached image).

It is more like an ap that has hijacked my browser. i.e. on the Southwest airlines website, I do not get this if I use Explorer or Firefox on another PC (see attached image).
Tyler Downer
  • Administrator
  • Moderator
1334 solutions 8868 answers

First, try to reset Firefox. Refresh Firefox - reset add-ons and settings. This simple step will eliminate many Firefox problems with only one click.

A few other basic trouble shooting things you can try is this: Run all Windows Updates, install all needed service packs, etc.

Update your graphics driver (Firefox uses your graphics card for some rendering, and an out of date graphics card driver can cause problems. Upgrade your graphics drivers to use hardware acceleration and WebGL

Update all your plugins (Flash, Java, etc.): http://www.mozilla.org/plugincheck/.

Download and Install MalwareBytes Anti-Malware, run a full Scan. http://www.malwarebytes.org/. This helps check that there are no viruses on your computer causing issues. You can uninstall this program after you clean off any infections.

Download and Run TDSSKiller http://support.kaspersky.com/faq/?qid=208283363

Download and Install Microsoft Security Essentials http://windows.microsoft.com/en-US/windows/products/security-essentials (not an official endorsement, but I personally recommend MSE as an awesome permanent anti-virus)

First, try to reset Firefox. [[Reset Firefox – easily fix most problems]]. This simple step will eliminate many Firefox problems with only one click. A few other basic trouble shooting things you can try is this: Run all Windows Updates, install all needed service packs, etc. Update your graphics driver (Firefox uses your graphics card for some rendering, and an out of date graphics card driver can cause problems. [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Update all your plugins (Flash, Java, etc.): [http://www.mozilla.org/plugincheck/ http://www.mozilla.org/plugincheck/]. Download and Install MalwareBytes Anti-Malware, run a full Scan. [http://www.malwarebytes.org/ http://www.malwarebytes.org/]. This helps check that there are no viruses on your computer causing issues. You can uninstall this program after you clean off any infections. Download and Run TDSSKiller [http://support.kaspersky.com/faq/?qid=208283363 http://support.kaspersky.com/faq/?qid=208283363] Download and Install Microsoft Security Essentials [http://windows.microsoft.com/en-US/windows/products/security-essentials http://windows.microsoft.com/en-US/windows/products/security-essentials] (not an official endorsement, but I personally recommend MSE as an awesome permanent anti-virus)

Chosen Solution

I got rid of it by going to Tools -> Add-ons and then the Extensions tab and removed YonToo.

I got rid of it by going to Tools -> Add-ons and then the Extensions tab and removed YonToo.

Question owner

This also got rid of Drop Down Deals too.

This also got rid of Drop Down Deals too.