X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 13.0.1, Flash 11.3.300.262, No video for some sites

Posted

After both firefox and flash upgraded to the newest versions i've found i have no video for certain flash sites. Youtube works fine but sites like metacafe.com don't.

I've tried rolling back to firefox 13.0.0. I've aso tried rolling flash back to 11.2 and 10.3 to no avail. I have also tried disabling protected mode for flash, still no video. I have done a complete reinstall of both firefox (including deleting my profile data) and flash, but it still won't work.

The only time i get video is when i restart firefox in safe mode. However when i restart in normal mode with all addons disabled i get no video. I don't have realplayer installed either.

Anyone got any ideas as to what I could try that i haven't already?

Modified by hunter551

Chosen solution

Try to "disable the hardware acceleration" in the Flash Player.

See also:

Flash "Display settings" window:


Try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"
Read this answer in context 16

Additional System Details

Installed Plug-ins

Shockwave Flash 13.3.300.262

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0.1

More Information

I've tried rolling back to firefox 13.0.0. I've aso tried rolling flash back to 11.2 and 10.3 to no avail. I have also tried disabling protected mode for flash, still no video. I have done a complete reinstall of both firefox (including deleting my profile data) and flash, but it still won't work.
The only time i get video is when i restart firefox in safe mode. However when i restart in normal mode with all addons disabled i get no video. I don't have realplayer installed either.

jessbee 2 solutions 25 answers

Try a system restore to a time when both firefox and flash were working. This worked for me. Then i updated firefox, but didn't update flash. Still working fine.and no problem with video.

Question owner

Unfortunately after all the uninstalls and re-installs i have no restore point from before flash updated

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Chosen Solution

Try to "disable the hardware acceleration" in the Flash Player.

See also:

Flash "Display settings" window:


Try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

Question owner

I already had hardware acceleration disabled in flash but not firefox. I turned it off in firefox and video seems to be working fine now. Thanks.

Modified by hunter551

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

You're welcome

topossibilities 0 solutions 4 answers

Some flash sites not working after 11.3.300.262 (FF V 13.0.1)

Tried all the solutions, mentioned last 4 days, including uninstall and roll back to 10.3

Uninstalled 10.3 and reinstalled 11.3.300.262, still no go, but now getting error message

TypeError: Error #1034: Type Coercion failed: cannot convert flash.events::SecurityErrorEvent@6ead0e9 to flash.events.IOErrorEvent. at flash.events::EventDispatcher/dispatchEventFunction() at flash.events::EventDispatcher/dispatchEvent() at flash.net::URLLoader/redirectEvent()

Update: When I disabled Adblock, for the specific site (e.g. Bloomberg.com/tv) that would not display with version 11.3.300.262 flash player, the video stream ran fine. Ads now play within the stream as well :=(

Same may be true for other sites that embed ads within the video stream.'

Modified by topossibilities

Skeptical Bright 0 solutions 17 answers

There was an update to Flash today (July 4, 2012) that I first noticed on Safari when I went to a flash site. Adobe insisted that I install the new version. I did and my Flash problems on Firefox went away have gone away but the designation on the plugin has not changed. I have no explanation as to what change. I suppose you can download the "latest" and see if it moves the problem.

topossibilities 0 solutions 4 answers

Helpful Reply

As posted above I managed to get FF 13.0.1 and Flash 11.3.300.262 working, on most Flash sites, by making sure before I installed the new FlashPlayer, I first uninstalled the prior version and then disabling AdBlock on sites that still problematic.

That said I followed exactly the same procedures on my second laptop (both Win 7) and it did not work (e.g. FlashPlayer works on some some Flash sites, but not all).

Given that this issue (upgrade to FF 13.0.1 and Flash 11.3.300.262) is several weeks old now, I keep looking for a final/workable solution from Mozilla and/or Adobe.

Lastly, given the number of people having issues, have concerns as to why these upgrades are not Q-A'd and thoroughly tested before before release?

Modified by topossibilities