Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Add-on tool bar icons can't be moved

  • 9 replies
  • 28 have this problem
  • 2 views
  • Last reply by Jaydear

more options

I have my Noscript icon placed on the right-hand side of the add-on tool bar, that is until I installed the Ghostery extension.

Now it is stuck in the middle of the bar, along with the resize icon!

There is usually one flexible space required to push the Noscript icon across to the right. I can put more of them in there and the icons do move across a bit, but not all the way.

There is a 'zebra' pattern in the right-hand space. I've tried to delete it or move it out, but it won't budge.

Modified by Jaydear

All Replies (9)

more options

If the icons are positioned in the middle of the toolbar then that suggests a flexible space at both sides of the icon.
Needing more than one flexible space at the left hand side seems to confirm that.

Did you check for that and try to remove the flexible space at the right hand side?


You can also try to reset the toolbars.

more options

Yes, I did. There isn't a flexible space there but there is a 'zebra' stripe pattern. I've tried to delete it or move it out, but it won't budge. The window resize icon is also in the middle, next to the Noscript icon. If I grab it and try to move it, it resizes the Firefox window - but it should be locked in the right hand end, not loose in the middle.

The zebra pattern is made up of alternating light and dark diagonal bars and it fills the area between the window resize icon and the right hand end of the add-on bar.

more options

I have also just replaced the localstore.rdf file with a known good one, but it made no difference. I also removed ghostery - no difference. Gr-r-r-r-r!

more options

Is that 'zebra' stripe pattern still there in Safe mode?

  • Help > Restart with Add-ons Disabled
more options

Yes, but it is only a small area because in safe mode the icons are in the right place. I put the Sync icon in there becasue, of course, Noscript is disabled in safe mode. Have a look at the screen grabs.

I have also tried disabling extensions one by one in normal mode, but no change.

more options
more options

No, I use Nautipolis on all my computers.

more options

Does it help if you revert to the default theme?

Modified by cor-el

more options

Yes, so I disabled Nautipolis and installed the LavaFox V2-Purple 2.0.3 theme which is also OK. Then I installed Walnut2 which is from the same developer as Nautipolis and it's OK. I then uninstalled Nautipolis and re-downloaded and installed it, but it is still affected. I suppose I'll have to ask the developer why. Interestingly, the Lava theme doesn't have a window resize icon in the right-hand end of the add-on bar.

For this reply I'm on a different PC (using FF13 and Nautipolis) and there is no window resize icon in the add-on bar. Thinking about it, you don't want one there... so why did it appear when Ghostery was installed on the other machine and how do I get rid of it? It is not included in the Customise Toolbar window, so I assume that's why I can't put it "back".