Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

scroll bar

  • 9 replies
  • 3 have this problem
  • 43 views
  • Last reply by webbrewers

more options

The vertical scroll bar on the right hand side of the screen disappears when the web site I'm visiting is short enough not to require a scroll bar (i.e. there is no need to scroll up or down because all the content fits onto one screen). If I move to another website, the scroll bar will appear if it is needed. Generally this is not a problem. However, if you are moving between links of the same website, if all the pages have the same format, the pages shift left when the scroll bar appears and right when the scroll bar disappears, and this is quite annoying. This is a huge problem if you have a text box that appears when you hover the mouse over a link. This is a good example: Example of website If you move the mouse over one of the logos at the bottom of the screen, the page shifts left, and if you move the mouse off the logo, it shifts back again. If you do this quickly, the page just looks awful. In Internet Explorer, the scroll bar doesn't appear and disappear, it is just disabled when not needed. Is there a solution to this?

Modified by ChopStix

Chosen solution

webbrewers...you are a genius! It worked perfectly. No more wobbly screens. Thanks!

Read this answer in context 👍 0

All Replies (9)

more options

hello, when i go to the site, the scrollbars only appear when the popup attached to the mouse pointer is going beyond the bottom of the page - this seems to be a legitimate behaviour for me...

more options

If you move the mouse pointer on and off the logo a few times quickly, the page wobbles. I can't see how that would be acceptable. If I'm reading content on the site and I happen to move the mouse over the logo, the page shifts to the left - don't you think that's off putting.

more options

well, but then it's rather a design issue of the webpage - firefox is just rendering the page as it is receiving it (i get the exact same issue when i vew the page with ie8 btw)...

Modified by philipp

more options

I hadn't noticed that in IE8; I'm still using IE7 on my desktop and that doesn't hide the scroll bar. It seems to do it in Chrome too. I've seen this wobble on other websites too (not just the one I posted) Go to http://www.lboro.ac.uk/about/ and then click on the next tab (Schools and departments) - The same thing happens and they don't have popups at the bottom of the page. I don't understand why all the new browsers want to hide the scroll bar?

more options

on this example the content becomes longer and doesn't fit onto the screen anymore, so the scrollbar appears, again very normal behaviour. browsers apparently want to give the contents they render as much space as possible, so elements of the chrome are hidden when not needed or neccessary.

you can overwrite that behaviour in firefox so that a bar is always shown, but it's not plain simple. you'd have to rename the userContent-example.css file in the chrome subfolder of your profile folder into userContent.css & add the following line (below the @namespace line):

html { overflow: -moz-scrollbars-vertical; }

here are instructions on how to work with the file: http://kb.mozillazine.org/UserContent.css

more options

Ok, sounds good. Thank you very much. I will have a play.

more options

I usually just add html{height:101%;} to the stylesheet to force the scroll bars to always show.

more options

Chosen Solution

webbrewers...you are a genius! It worked perfectly. No more wobbly screens. Thanks!

more options

Wish I could take credit but I picked this idea up from someone else - and at this point I don't remember who.