X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox + plug-in container taking 100% of cpu.

Posted

OK, I have followed all steps listed in the following article.

"The plugin-container.exe is using 100% cpu usage???"

With only Shockwave flash 11.2.202.235 runninng, which has to be for video to play, I am still having the problem.

I upgraded from XP to Windows 7, and installed a new video card.

I also tried the Beta version of FF.

The plug-in is still using 50% of my CPU.

Problem doesn't occur in IE9.

I have also installed the following add-ons- Adblock pluss 2.03 Flashblock 1.5.15.1 and enable my "Symantec Intrusion Prevention 10.1.1.8".

After enabling these add ons there was and increase in FireFox CPU ussage. This seems to spike off and on depending on my surfing activities.

Modified by DoingItRight

Additional System Details

Installed Plug-ins

Enabled plug-ins microsoft office 2010 reallusion ct4 player for mozilla 1.0 shockwave flash 11.2

Disabled plugins adobe acrobat 10.1 divx vod helper 1.1 java deployment tookit 7 java platform se 7 u4 10..4 nvidia 3d vision 7.17 shockwave for director 11.6.5 sliverlight 5.1 vlc web plugin 2.0 windows live photo gallery

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:12.0) Gecko/20100101 Firefox/12.0

More Information

Application Basics
Name
Firefox
Version
12.0
User Agent
Mozilla/5.0 (Windows NT 6.1; rv:12.0) Gecko/20100101 Firefox/12.0
Profile Directory
Show Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Adblock Plus
2.0.3
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Download YouTube Videos as MP4 and FLV
1.3.8
true
{b9bfaf1c-a63f-47cd-8b9a-29526ced9060}
Flash Video Downloader Youtube Downloader
3.6.1
true
artur.dubovoy@gmail.com
Flashblock
1.5.15.1
true
{3d7eb24f-2740-49df-8937-200b1cc08f8a}
Symantec Intrusion Prevention
10.1.1.8 - 3
true
{BBDA0591-3099-440a-AA10-41764D9DB4DB}
Test Pilot
1.2.1
false
testpilot@labs.mozilla.com
Important Modified Preferences
Name
Value
browser.cache.disk.capacity
1048576
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
1048576
browser.places.smartBookmarksVersion
2
browser.startup.homepage_override.buildID
20120420145725
browser.startup.homepage_override.mstone
rv:12.0
extensions.lastAppVersion
12.0
network.cookie.prefsMigrated
true
places.history.expiration.transient_current_max_pages
80482
privacy.sanitize.migrateFx3Prefs
true
Graphics
Adapter Description
NVIDIA GeForce GT 520
Vendor ID
0x10de
Device ID
0x1040
Adapter RAM
1024
Adapter Drivers
nvd3dum nvwgf2um,nvwgf2um
Driver Version
8.17.12.9610
Driver Date
2-29-2012
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17789)
ClearType Parameters
ClearType parameters not found
WebGL Renderer
Google Inc. -- ANGLE (NVIDIA GeForce GT 520 ) -- OpenGL ES 2.0 (ANGLE 1.0.0.963)
GPU Accelerated Windows
1/1 Direct3D 10
AzureBackend
direct2d

alex_mayorga 12 solutions 164 answers

Helpful Reply

Review and follow Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems, see if that helps.

John99
  • Top 25 Contributor
  • Moderator
624 solutions 8062 answers

It may be interesting to see how you go on without AdBlock enabled, or even with it uninstalled. IIRC someone posted to say the latest adblock version may sometimes be implicated in Firefox12 problems.

Question owner

Removed all plug-in's, even Symantec! No Change.

Question owner

Did the "Review and follow Troubleshooting plugins, see if that helps."

Couldn't get video to even play, reinstalled FF 12, same problems.

I disabled the plug-in and FF grabed the extra CPU and sucked it all up.

At this point I believe the solution is to make IE my default browser and fall back on FF when IE won't work.

As this solution doesn't fit well with me either; I will try a fresh Windows install later and see if I can locate the problem by trial and error.

Thank you for taking the time to reply.

Signed, IhateIE but I.E. it works!

John99
  • Top 25 Contributor
  • Moderator
624 solutions 8062 answers

DoingItRight,

Sorry you are still having problems.Lets explore some other possibilities.

I disabled the plug-in and FF grabed the extra CPU and sucked it all up. 
  • Are you referring to the ad-block plugin, if so that my confirm comments that the latest version can be problematic with Firefox 12. You could also try the previous version to see if that works better.
    • I wonder if others note any similar problem
I upgraded from XP to Windows 7, and installed a new video card. 
  • If it is an old machine maybe you re sometimes reaching its performance limits or having problems after the video card update. You comment on going from 100% CPU to 50% CPU usage, maybe that is a reasonable expectation.
  • have a look at Flash Plugin - Keep it up to date and troubleshoot problems
    • in particular try experimenting with with hardware acceleration turned off in Flash Players settings. (That may not be expected to help with a new video card, but if it does it highlights a problem area a possibly the video card)
  • you mention
    IhateIE but I.E. it works!
    • is IE coping with the same FlashPlayer videos and a indicating much lower CPU usage
ideato
  • Top 25 Contributor
617 solutions 4264 answers

Helpful Reply

Try Disabling Plugin-container and check it again.

see also : Troubleshoot Firefox issues caused by malware


thank you

Question owner

Sorry I wasn't clear in my post, "I disabled the plug-in and FF grabed the extra CPU and sucked it all up."

- I was refering to the "plugin-container.exe" which the second poster suggested.

       This seemed to help on the front end but, as another poster noted, the CPU would continue to grow until I would have to recycle FF.

While IE is also a resource hog it will at least play the video and audio without skipping.

I am coming to the conclusion that the problem is with Windows 7 32bit 3GB of RAM.

1. while on XP it wasn't uncommon for the cpu to run at 100% but I never experienced the video and audio skipping. 2. I only have 2 processors.


I have run malwarebytes scans, didn't find anything. I also use CCleaner on a daily basis and browse in private no matter which Browser I use.

A couple of ideas just came to mind, let me try those and get back with you.

thanks again.

Question owner

Believe I located the culprit, "Spybot S&D". After removing and rebooting It appears that my system is now back to the previous state of hovering below 100% (which is acceptable considering my limited resources), but I was able to kick-off three videos and listen to to all of them at the same time.

I had Spybot installed before my upgrade, with the Tea-Timer excluded from the install and only using the IE protection, just as now.


I still have several tests before I am going to close this case but maybe this can help someone else.

dwhitcombe 0 solutions 1 answers

I have a similar problem, though I'm pretty sure it isn't cpu performance or memory related. Core i7-980, 24GB of ram. Video stalls in Firefox 12, plays great in Chrome or IE. Haven't tried opera. Windows 7 professional 64.

globalinternethosting 0 solutions 1 answers

i see an AWFUL LOT of COVER STORIES for the inadequacy of plugin-container.exe. Make no mistake - i like FireFox. But i also believe that somebody has SOLD OUT to big media so that FF leans toward swallowing everything that madison ave can throw at you. And i believe that burning 100% of your processor is not an issue with people who sell out to MAD-AVE'S who would prefer that you cannot do anything else except become ass-fixated to the advertising they shovel.

is there something wrong with plugin-container.exe? yes there is. will the sug's fix things for you? no they wont. it is a badly designed piece. let me remind you - at this time i prefer FF over anything else - at this time. will plugin-container.exe get fixed? probably not.

we have entered the era of information domination. and, ITS ONLY GOING TO GET WORSE.

my advice? create a browser, network and site standard that connects people to people without the interference of big media pigs.

disclaimer: this is all my opinion and even tho i have done this sort of things since the beginning of time, what do i know.

mhek 0 solutions 3 answers

Hi, I've got the same problems with plugin-container.exe. When a homepage (facebook, ebay) uses flash it takes the cpu power of a complete core.

I tried a lot of the things described above. Nothing helped.

There are no problems with chrome or IE.

(Windows Vista home premium, FF 15.0.1, Flash Plugin 11.4 r402)

Modified by mhek

mhek 0 solutions 3 answers

Using the IE Tab Plug-in 2.2.0.1 it seems to work fine. plugin-container.exe takes a core on opening the Facebook page but falls back to zero when ready loaded.

John99
  • Top 25 Contributor
  • Moderator
624 solutions 8062 answers

mhek

I am not sure what IE Tab plugin does exactly, possibly it runs Flash in IE and displays the results within a Firefox tab, if so it is similar to using IE and that uses a totally different system of running Flash Player. If so it is a workaround that some users may prefer to abandoning Firefox.

John99
  • Top 25 Contributor
  • Moderator
624 solutions 8062 answers

EVERYONE

By all means read this thread for information, and if you know of solutions that may help the original poster feel free to add links to such solutions.

Also remember this is now a relatively old thread, Flash & Firefox versions have changed,and there has been critical security updates of Flash (even applied to otherwise unsupported Flash Linux version - although the exploit may be avoidable ) that necessitates change of advice.

PLEASE If you have your own problem even if it is similar please start your own question by using /questions/new (cross link it to this thread if you feel that helps)

As I understand it FlashPlayer no longer support the use of Windows Flash in Firefox unless within the Plugin container, and in fact Firefox is likely to enforce use of plugincontainer on Vista and above. (bug 769721)

Please keep in mind the fact that this is a rather complex subject. Some versions of Flash Player have had known issues with Firefox, and can even be affected by the Flash installer used. Also there have been and no doubt are still problems with the protected mode feature (something Flash introduced as a security feature). That can be disabled manually if necessary.

As I understand it Adobe FlashPlayer no longer support the use of Windows Flash in Firefox unless within the Plugin container. In fact Firefox is likely to enforce use of plugincontainer on Vista and above when using Flash.

There are some Firefox Knowledge Base articles on FlashPlayer and the problems with it, but these unfortunately may not always be fully updated, and may not have always explained full details of the problems. ( another question of similar age with information bold text)

mhek 0 solutions 3 answers

Thank you John99 for the summary. I tried a lot of things the last few days to stop flash occupying my computer including switching off the protected mode. For some reason it did not help.

Today I tried the "ProtectedMode=0" again and surprisingly it works fine now.