X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Good popups not working while popup blocker is disabled

Posted

I have several popup that I need to open. such popups from us.battle.net login is not giving me option to put in username or password. and my jobs popup to view my paycheck or change information that I need to change is not working. My friend is having the same problem both using firefox 12. and we are using two different versions of windows, I am uing win 7 64bit she is using win vista 32bit. This has only been happening for about 2 to 3 weeks. also I have an inability to open the addons option

Chosen solution

They use a DIV that opens a document via an OBJECT tag.

The password field also uses autocomplete=off to that extra problems.

Read this answer in context 0

Additional System Details

This happened

Every time Firefox opened

This started when...

almost a month ago

Installed Plug-ins

cannot be sure as I cannot open my addons or popups.

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0

More Information

Reinstalled, tried safemode, after safemode the addons folder works for a little bit then goes away

Michael Verdi
  • Administrator
  • Moderator
107 solutions 739 answers

Pop-up blocker settings has instructions for manually adding a list of websites that are allowed to open pop-up windows. You should be able to add the site you want like this.

Question owner

yeah this still does not fix the issue it persists and remains.

Question owner

It's some sort of java script issue, if I disable java it works, but not in the intended way. it replaces the current window which I do not want.

Michael Verdi
  • Administrator
  • Moderator
107 solutions 739 answers

So I have an account on us.battle.net so I went to see if I can recreate the problem. What I saw is that they don't actually use a pop-up window for logins. It's just a div displayed over the main content (it's actually part of that main page). So there is no way to control whether they show up or not. As far as the auto-fill working, some websites (like this one apparently) disable that for security reasons. For me it works the exact same way in Chrome. I'm not sure if that's the case with your paycheck website but it might be.

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Chosen Solution

They use a DIV that opens a document via an OBJECT tag.

The password field also uses autocomplete=off to that extra problems.

Modified by cor-el

Question owner

I'm not understanding why the overlay does not give me the password fields, and the paycheck viewing info actually opens a new window to another page. It's less of a popup when you really think about it. but do know that if I disable java, the paycheck page and some of the other random pages simlar to that will simply open in the current window, I do not want this because then have to relogin in to do anything else other than the paycheck issue. It's an annoyance.

Question owner

It is a 100% java issue that I cannot seem to get resolved and this is pissin me off.

Question owner

okay the battle.net issue I've fixed, and had to use an extension to fix the other issue... hope this gets corrected so I don't have to use extensions to do normal functions..