Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox has problem in opening some website,that is oening fastly in chrome and Windows explorer,site is "www.keralatourismmart.com"

  • 5 replies
  • 1 has this problem
  • 389 views
  • Last reply by cor-el

more options

We are trying to visit the web page in firefox 4.0 beta 7, the page can't open, and some times it taken very long time to take to open the site, but as the same time I try to open it with my chrome browser(beta version) and explorer 8. The site is open quickly in Google Chrome(beta version), opened in explorer (but not fast as chrome). If I try to surf on that site firefox take very long time to open profiles on that site but chrome takes only seconds.Site details is :- http://keralatourismmart.com

Chosen solution

Upgrade Firefox to version 12

-> Download latest Firefox version from the following link using some other Web Browser:

-> Install Firefox 12 as described in this article -> Installing Firefox

Check and tell if its working.

Read this answer in context 👍 0

All Replies (5)

more options

Chosen Solution

Upgrade Firefox to version 12

-> Download latest Firefox version from the following link using some other Web Browser:

-> Install Firefox 12 as described in this article -> Installing Firefox

Check and tell if its working.

more options

Yes its great & working smoothly Thank you very much

Modified by pramoddevaraj

more options

Glad to see it worked..


To help other users find solutions, please return to this Thread and click on "Solved It" button Next to the reply ABOVE that BEST solved your Question

Note:- DO NOT click "Solved It" next to this reply

more options

Thank you for your useful reply. But same problem occurring in http://www.indigenoustour.com/

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works better then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.

See:

You can also try to reset Firefox:


Also make sure that you allow Firefox with restrictions in your security software (firewall, anti-virus).