X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

in latest flashplayer webcam doesn't work, firefox 12 disables old flash, nice one!

Posted

I installed the latest flash, as i always do but my webcam doesn't work with it (known problem at adobe) Their fix is to install an older flash version. this worked fine untill today firefox decides to disable it and force me to upgrade flash. Can i please decide myself which version to use thank you very much? this is really annoying, the plug in dissapeared from the list so i can't even enable it if i wanted to...

Chosen solution

you'll have to install the flashplayer11_1r102_63_win_32bit.exe file from the link you've posted - the ax version is for IE only (ActiveX).

it works for me on firefox 12, nothing is blocklisted or disabled here, the plugin shows up in addon manager as Shockwave Flash 11.1.102.63. when i perform a plugin scan, flash is shown as outdated but no further action is taken. the "flash has been disabled" message on mozilla's plugin check page was probably just incorrect since it is shown per default in certain situations (see bug 633285).

if you're still haveing troubles i'd recommend that you delete the file named blocklist.xml inside your firefox profile folder and disable the getplusplusadobe16263 plugin.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 1.6.0_31 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.4.634
  • 5.0.61118.0
  • DivX VOD Helper Plug-in
  • Google Update
  • Winamp Application Detector
  • Yahoo Application State Plugin version 1.0.0.7
  • getplusplusadobe16263
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Npdsplay dll
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20100101 Firefox/12.0

More Information

philipp
  • Top 10 Contributor
  • Moderator
2043 solutions 8891 answers

firefox has a blocklist feature that allows for deactivation (not uninstalling!) of addons and plugins which cause crashes or security issues. however, this feature was as of yet not used to disable any old legit versions of adobe flash that might cause problems - for a full list of affected addons see https://addons.mozilla.org/en-US/fire.../blocked/ (note that the flash addons listed there are all malware disguised as flash player to trick users, but no versions from adobe).

therefore it's likely that something else (maybe security software on your pc or an update from adobe itself) has caused the behaviour that you have observed.

Question owner

I downloaded the old version pack from adobe through a link on their forum posted by an adobe tech (i did that before but deleted the archive since it was working fine), it worked fine untill today. Now firefox has disabled it and the plugincheck page says "Firefox has disabled your outdated version of Flash" I'm sure it has nothing to do with any other software. If it did FF would have been looking fine and it would just have not worked... Besides, nothing changed on my machine, i tried going from FF11.0 to 12.0 and reinstalled flashplayer11_1r102_63_winax_32bit.exe but FF just disables it and doesn't show it in the plug in list so i can't enable it back even if i wanted to.

Edit: file download location:http://fpdownload.macromedia.com/get/flashplayer/installers/archive/fp_11.1.102.63_archive.zip adobe forum post: http://forums.adobe.com/message/4325258

Modified by KeiraTG

philipp
  • Top 10 Contributor
  • Moderator
2043 solutions 8891 answers

Chosen Solution

you'll have to install the flashplayer11_1r102_63_win_32bit.exe file from the link you've posted - the ax version is for IE only (ActiveX).

it works for me on firefox 12, nothing is blocklisted or disabled here, the plugin shows up in addon manager as Shockwave Flash 11.1.102.63. when i perform a plugin scan, flash is shown as outdated but no further action is taken. the "flash has been disabled" message on mozilla's plugin check page was probably just incorrect since it is shown per default in certain situations (see bug 633285).

if you're still haveing troubles i'd recommend that you delete the file named blocklist.xml inside your firefox profile folder and disable the getplusplusadobe16263 plugin.

Question owner

Insane! I used the wrong installer..., omg... That's what happens when you stop thinking and just do as someone says like: "Internet Explorer for all Windows 32-bit systems: flashplayer11_1r102_63_win_32bit.exe Other browsers for all Windows 32-bit systems: flashplayer11_1r102_63_winax_32bit.exe"

Still weird why it stopped working all of a sudden though. But it works again now i installed the right version, doh and thanks. :)