X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox (Mac Lion)cannot display PDF directly

Posted

My firefox on lion cannot display any kind of PDF files. It can recognize the file as PDF, but the whole page is blank, only the titles says: application/pdf object. I use acrobat, I have change the default application to preview and tried using the js extension, but none of them works. Helps! Now I can only right click to download pdf, which sucks. By the way, the windows version works just fine.

Additional System Details

This happened

Every time Firefox opened

This started when...

open pdf

Installed Plug-ins

  • Shockwave Flash 11.2 r202
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Version 2.8.8.6978
  • Google Talk Plugin Video Accelerator version:0.1.44.15
  • Adobe® Acrobat® Plug-in for Web Browsers, Version 10.1.3
  • NPSafeInput Plug-in
  • iPhoto6
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • aliedit for cocoa
  • NPClientBinding Plug-in
  • NPCleanHistory Plug-in
  • NPSafeSubmit Plug-in
  • Folx Downloader Netscape plug-in
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • 4.0.60831.0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:12.0) Gecko/20100101 Firefox/12.0

More Information

firefox 12, 13. Mac Lion 10.7.3. Adblock disabled. Tried safe mode by disabling any plugins, tried reinstall firefox.

cor-el
  • Top 10 Contributor
  • Moderator
10742 solutions 96657 answers

There have been problems reported with the latest Adobe Reader update on Mac.
See [/questions/925119]

You can disable the Adobe Reader plugin in Firefox and use the Adobe Reader program or Preview instead.

  • Firefox > Preferences > Applications > Adobe PDF document : Use Adobe Reader

Question owner

Thank you very much for your reply. But what I'm using is acrobat, not reader. What's wired will be whatever softwares or plugins I use to open PDF, it just gives me a blank page. I deleted Firefox completely, reinstalled it, it seems to be opened using the js plugin. Still different from the Windows. So this is Adobe's problem?

cor-el
  • Top 10 Contributor
  • Moderator
10742 solutions 96657 answers

Did you try to disable the plugin and use either Preview or the Adobe program to open the PDF files?

Modified by cor-el

Question owner

Thank you so much for the reply. I did disable all the plugins by starting the browser in safe mode, and changing the default applications to open the PDF files, but none of them worked. And I finally deleted all the data of Firefox and had a fresh install. Sadly, it is still not working. But I realized that there is a "Adobe PDF" file format shows up in the application panel. I tried changing it into Adobe Acrobat, but it ended up by opening the file using js plugin rather than Adobe. Although it is not the exact way I want it do, but at least it worked. I am kinda disappointed at Firefox, there is a lot of problems about it. Chrome works way better. I kept using it just because I have get used to it using it from version 2 so long ago. I hope it can be better rather than race on the version against chrome.

dmorris78 0 solutions 1 answers

I have had the same problem. My Uni course uses Pdf's in their web site. Now I have had to go back to Safari and use this instead. Very Anyoying.....I also re installed everything but it is still not working.

Question owner

So sad about that. Try to go to options-- applications, and look for "PDF" in the content type, change the default program to open it. You can try the plugin or the adobe software. I am on my Windows Machine, sorry cannot post a screenshot. Maybe later.

rosiegrl320 0 solutions 2 answers

Helpful Reply

"If using a Mac, go to the Firefox Plugins and disable the Adobe Acrobat NPAPI Plug-in, Version 10.1.3. This is a recent plugin update, and as soon as it was installed I noticed that PDFs wouldn't download.

Location: [Menu] Tools/Add-Ons/Plugins

I don't know what other side-effects it can create, but it solved my problem."