X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

after the update to firefox 12 some pages do not display correctly. for example my scottrade login page has no button to login.

Posted

After automatic update to firefox 12 some pages do not display correctly. As an example my Scottrade login page has no login button. My CNN money page has text along the left side of the page but very little graphics. Suggests some graphics setting has been changed? Need experts help. Thanks, Fred

Additional System Details

This happened

Every time Firefox opened

This started when...

4/26/2012

Installed Plug-ins

  • Shockwave Flash 11.2 r202
  • Google Update
  • Next Generation Java Plug-in 1.6.0_31 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 4.1.10111.0
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.0"
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • GEPlugin
  • iTunes Detector Plug-in
  • Version 0.9.18, Copyright 2006-2009 Veetle Inchttp://www.veetle.com/
  • Version 0.9.18, copyright 2006-2010 Veetle Inchttp://www.veetle.com/
  • 2,5,3,1
  • Version 1.0.5, copyright 1996-2010 The VideoLAN Teamhttp://www.videolan.org/
  • npdivxplayerplugin
  • DivX Web Player version 2.0.0.254
  • 1.9.0042.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Store Netscape Plugin
  • Npdsplay dll
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20100101 Firefox/12.0

More Information

OS is XP pro SP3. Rebooted with no help.

Swarnava Sengupta 482 solutions 3135 answers

Helpful Reply

eload web page(s) and bypass the cache.

  • Press and hold Shift and left-click the Reload button.
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Cmd + Shift + R" (MAC)

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

Cheng Wang
  • Administrator
  • Moderator
36 solutions 435 answers

Do you have a screenshot?

Can you try the steps at Websites look wrong or appear differently than they should?

Question owner

Reloaded web pages with shift held while hitting reload and this solved the problem. Thanks for your help Cww.

Question owner

It appears that I will have to keep holding shift and refresh for some web pages. Can you tell me how to make a permanent fix? The display is fine once you hold shift down and refresh. Would like to avoid having to do this each day. Thanks Fred

Safwan Rahman 7 solutions 41 answers

it seems that upgrading to firefox 12 has many problem. Most of the people have problem after upgrading firefox 12. Most of the time the upgrade from firefox 11 to 12 not successful. so the problem has occurred. I recommend u to download Firefox 12 from mozilla.org and install it. It is the easiest way to solve ur problem. There are many other ways to solve the problem. but the easiest way is this

Modified by Noah_SUMO

Safwan Rahman 7 solutions 41 answers

@Swarnava u have to see what operating system he using. U have to reply solve according to his operating system.he is using windows. so u have to give solve according to windows not others. Ur reply of this question seems very much complicated because u give the solve for all operating system. So most of the people can't understand ur reply. I hope u wouldn't mind of my reply. Thanks

Modified by Noah_SUMO

Cheng Wang
  • Administrator
  • Moderator
36 solutions 435 answers

I think either the site is using the Firefox cache incorrectly or you have something else that's corrupting your cache. We've seen this problem before where some object in the cache (with CNN Money, it seems to be the style sheet) gets caught by an antivirus program or messed up by an add-on and now that cache item won't stay.

I'd try disabling add-ons from Tools > Add-ons and also clearing the cache completely (Tools > Clear Private Data, select only cache and click Clear now)

This doesn't sound like the kind of problem that re-installing from mozilla.org will fix, honestly, since the site loads ok when you bypass the cache (holding shift on reloads).

CSFF 0 solutions 4 answers

I had a similar problem (under Win 7 Pro) that seems partly due to FF not handling pages that it remembers that I usually view zoomed-in 1 or 2 steps (view/zoom/zoom in, or CTRL_+).

If I reset the zoom (view/zoom/reset, or CTRL_0 [zero]), then usually most of the missing text reappears, but not always.

For example, please see the attached screenshot from a Mozilla site page, which shows 2 empty bullet items with their content missing. (I'd highlighted the navigation line before taking the screenshot, so that part is OK.)

There are probably other places where this info should be posted, but I've wasted too much time already trying to Google needles in the haystack. Hope this helps save at least a few people a few hours.

I think the FF release cycle really needs to be stretched out a couple of extra weeks to do much better testing!! I love FF and its huge recent improvements for supporting many windows with many dozens of open tabs without more-or-less dying, but I hate the time wasted dealing with repeated random breakage of previously working things.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Looks like you have a white text color (I see it in the title bar as well).
You can verify that by using the mouse to select the text or select all via Ctrl+A.

You can check the default colors:

  • Tools > Options > Content : Fonts & Colors > Colors
  • [X] "Allow pages to choose their own colors, instead of my selections above"

Did you ever install a persona (Tools > Add-ons > Appearance/Themes)?

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

See also:


Did you make changes in the Windows appearing settings or have a Windows theme that sets the color to white?

CSFF 0 solutions 4 answers

Thanks much for the suggestions.

Unfortunately I don't have the old session/tab available, but I saw similar problems on slashdot.org -- but Ctrl+A only showed already-visible text.

The "Allow pages to choose their own colors...." option was already selected. Appearance/Themes had whatever the default was.

I didn't see anything unusual looking in font options.

Safe Mode made things go from bad to worse (Beside rendering issues, FF wouldn't finish shutting down, and it crashed on startup twice, among other problems. I suspect FF was probably overloaded from all the junk flashblock and adblock normally stop.)

Anyway, the attached images show normal mode case after doing reload and Ctrl_0 (which is OK) and safe mode case under the same conditions (which is bad). Ctrl_A didn't reveal any white text.

However, doing a Ctrl_= causes the "bad" page to be rendered correctly. However, the FF button drop down menu (which you can see in the 2nd screenshot) was still seriously messed up.

Anyway, I've had too many problems and wasted way too much time on FF 12, so I've removed it and reinstalled FF 11.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

There may be a problem with one or more fonts.

Try to disable the website fonts as a test and try a few different default (serif/sans-serif) fonts.

  • Tools > Options > Content : Fonts & Colors > Advanced [ ] Allow pages to choose their own fonts, instead of my selections above

If that works then you need to reinstall the corrupted font.

You can do a font test to see if you can identify corrupted font(s).

You can try different default fonts.

  • Tools > Options > Content : Fonts & Colors > Advanced
  • [ ] "Allow pages to choose their own fonts, instead of my selections above"

You can use this extension to see which fonts are used for selected text.

CSFF 0 solutions 4 answers

As I mentioned at the end of my last reply, I've reinstalled FF 11, and I'm not going to try FF 12 again until a more stable release is available.

I don't know if reinstalling FF 11 changes whatever fonts are installed or not, but deselecting/reselecting the "Allow pages to choose their own fonts, ..." option in FF 11 didn't cause any rendering problems at various (and default) zoom levels this time on the slashdot.org site.

Thanks anyway.