Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Remove firefox 12 glass / transparent background?

  • 12 replies
  • 114 have this problem
  • 6315 views
  • Last reply by jrmourning

more options

I just updated to Firefox 12, and hate it's new appearance. Once again, they've changed it simply for the sake of changing it...

My problem is with it's default glass theme. It's horrible.

Is there any way to give firefox an opaque background (DISABLING THE TRANSPARENT DEFAULT).

any and all help is greatly appreciated! Thank you in advance =)

All Replies (12)

more options

I'm aware of themes, I don't want to use them... I just want the classic opaque background I had in firefox 3.

more options

Try installing a persona such as http://www.getpersonas.com/en-US/persona/78780. Unfortunately, besides disabling Aero for your whole computer, installing a theme or persona is the only way to disable Aero for Firefox.

Modified by user633449

more options

You can also disable aero for your entire system: http://www.howtogeek.com/howto/window.../disable-aero-on-windows-vista/

more options

New theme is all buggy. With one tab it's transparent and with 2 tab it's opaque.

more options

A persona is the quickest and simplest solution, but it also renders the title bar opaque.

Alternatively, it can be done with a user style, which should preferably be applied with the Stylish extension, but can also be applied through userChrome.css.


more options

Neither of those helped me. I cannot read the menu at all because of this problem. Has anyone found a fix yet?

more options

Alright, so this is a bit of a workaround. It does NOT solve the problem, simply masks it...

I've decided to use a theme, this one seems to be the best I've found so far: http://ffaddons.game-point.net/ff3ff4/

Again, it's NOT a fix, just a solution.

Disabling aero did nothing... Mozilla shouldn't have made the transparent background. It's silly. 

I hope that THEME helps.

more options

I thought the idea was to preseve the general appearance and just get rid of the transparency. If you don't mind a completely new look, then you can use pretty much any theme. Nearly all are opaque.


more options

Thank you aldernon. That fixed it - I can now read my menu. I can not understand at all why a programmer would consciously change the menu area to transparent. I can see no positive results from doing that.

more options

Was using Firefox 3.6 all this time until yesterday a message popped up saying that there will be no more updates for it or something along those lines. So I decided maybe it's finally time to update. And after updating, I'm like "WTF is this? Who the hell gave this theme the green light?" aldernon's link helps fix most of it. But tabs are still wonky. Turning into different odd colours. Like this: http://i.imgur.com/aBDId.png After so many years of being a big fan of Firefox, this is rather disappointing. I might look into Chrome or IE9 if this nonsense isn't fixed soon.

more options

An annoying workaround I've tried is setting your firefox.exe compatibility to disable desktop composition, it works, but aero will be disabled system wide until Firefox is closed.

more options

The problem is apparently with the windows settings, not Firefox. Right click the desktop, personalize, click windows colors and unclick "enable transparency.." This worked for me. Firefox is no longer has a transparent frame.