X
Tap here to go to the mobile version of the site.

Support Forum

awesome bar shows old bookmarks

Posted

Hello, my awesome bar still show old bookmarks with a yellow star and tags. I did everything that was suggested in several help pages, included clearing all history, cookies, cache, and also deleting the results listed in the awesome bar. They still show up, even if they do not exist anymore in my bookmarks library (at least a search for them has yielded no results). Is there a way to remove those false and unwanted no-longer existing bookmarks?

Hello, my awesome bar still show old bookmarks with a yellow star and tags. I did everything that was suggested in several help pages, included clearing all history, cookies, cache, and also deleting the results listed in the awesome bar. They still show up, even if they do not exist anymore in my bookmarks library (at least a search for them has yielded no results). Is there a way to remove those false and unwanted no-longer existing bookmarks?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.2 r202
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.3
  • Next Generation Java Plug-in 1.6.0_31 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Yahoo Application State Plugin version 1.0.0.7
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Version 2.6.1.5251
  • Google Talk Plugin Video Accelerator version:0.1.44.14
  • 5.0.61118.0
  • ActiveTouch General Plugin Container Version 105
  • GEPlugin
  • np-mswmp
  • Yahoo! activeX Plug-in Bridge

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17467 solutions 157849 answers

You can open such an entry with a yellow star via the location bar.
Then you can click the star to see in which folder that item is and decide if you want to remove it.

You can open such an entry with a yellow star via the location bar.<br /> Then you can click the star to see in which folder that item is and decide if you want to remove it. *https://support.mozilla.org/kb/Deleting+Bookmarks
finitarry 251 solutions 3421 answers

You can set Options > Privacy > Location Bar to suggest History rather than History and Bookmarks.

You can set Options > Privacy > Location Bar to suggest History rather than History and Bookmarks.

Question owner

Thx Corey, unfortunately I am talking about bookmarks that no longer exist, so I cannot remove them manually from the library. I know it sounds strange, but that's why I posted on here, as any available help file could not solve the issue. I searched for those bookmarks in the library, but they are nowhere to be found, but they still show up in the awesome bar.

Thx Corey, unfortunately I am talking about bookmarks that no longer exist, so I cannot remove them manually from the library. I know it sounds strange, but that's why I posted on here, as any available help file could not solve the issue. I searched for those bookmarks in the library, but they are nowhere to be found, but they still show up in the awesome bar.

Question owner

Thanks Finitally, but I dont think that would be a good option, because that way I would exclude ALL bookmarks from a search. I just want to get rid of no-longer existing bookmarks. However, earlier I had tried that, and then re-set the option to "bookmarks and history". It didn't solve anything.

Thanks Finitally, but I dont think that would be a good option, because that way I would exclude ALL bookmarks from a search. I just want to get rid of no-longer existing bookmarks. However, earlier I had tried that, and then re-set the option to "bookmarks and history". It didn't solve anything.

Modified by myeurop

cor-el
  • Top 10 Contributor
  • Moderator
17467 solutions 157849 answers

Helpful Reply

A possible cause is a problem with the file places.sqlite that stores the bookmarks and the history.

You can also try to repair the places database with this extension:

A possible cause is a problem with the file places.sqlite that stores the bookmarks and the history. *http://kb.mozillazine.org/Bookmarks_history_and_toolbar_buttons_not_working_-_Firefox *https://support.mozilla.org/kb/Bookmarks+not+saved#w_fix-the-bookmarks-file You can also try to repair the places database with this extension: *https://addons.mozilla.org/firefox/addon/places-maintenance/

Question owner

Thanks everyone! I ran the Place Maintenance add-on: that didn't help. Then I rebuilt a new places.sqlite file following the instructions found in the pages you posted: That didn't help either, aside from losing all the favicons. So I put back the old places.sqlite file. I also downloaded an HTLM version of my bookmarks, and looked for the olde bookmarks (that show up in the awesome bar) in the page source: they were not there, they do not exist anymore in the library. So, back at square one now. Still have those bookmarks showing up in the not-so-awesome bar..(-:

Last ween I had posted another issue with the awesome bar at: https://support.mozilla.org/en-US/questions/924584 "not all tags show up in the awesome bar" I am afraid the two issues are related. Here is that post:

"I have noticed that when I type a tag in the awesome bar, only a few of my bookmarks tagged with that word show up as suggestions, even though they appear as correctly saved in my bookmarks library. I restarted the browser in safe mode, but that didn't make a difference. Another user suggested the issue was related to the FastestFox - Browse Faster add-on, but I don't have that add on installed. I also typed a + and an * after the tag (in the search bar), but it didn't help. The search result is incomplete." PS: ....instead, old, deleted bookmarks are shown

Thanks everyone! I ran the Place Maintenance add-on: that didn't help. Then I rebuilt a new places.sqlite file following the instructions found in the pages you posted: That didn't help either, aside from losing all the favicons. So I put back the old places.sqlite file. I also downloaded an HTLM version of my bookmarks, and looked for the olde bookmarks (that show up in the awesome bar) in the page source: they were not there, they do not exist anymore in the library. So, back at square one now. Still have those bookmarks showing up in the not-so-awesome bar..(-: Last ween I had posted another issue with the awesome bar at: https://support.mozilla.org/en-US/questions/924584 "not all tags show up in the awesome bar" I am afraid the two issues are related. Here is that post: "I have noticed that when I type a tag in the awesome bar, only a few of my bookmarks tagged with that word show up as suggestions, even though they appear as correctly saved in my bookmarks library. I restarted the browser in safe mode, but that didn't make a difference. Another user suggested the issue was related to the FastestFox - Browse Faster add-on, but I don't have that add on installed. I also typed a + and an * after the tag (in the search bar), but it didn't help. The search result is incomplete." PS: ....instead, old, deleted bookmarks are shown

Modified by myeurop

finitarry 251 solutions 3421 answers

Can you not simply delete the unwanted lines from the dropdown list? One used to be able to do that. I can still do that with Shift-Delete on the keyboard.

Can you not simply delete the unwanted lines from the dropdown list? One used to be able to do that. I can still do that with Shift-Delete on the keyboard.

Question owner

Thx Finitarry, I had already deleted those unwanted bookmarks from the list that appears under the awesone bar. Unfortunately, when I search again, they will still be listed.

Thx Finitarry, I had already deleted those unwanted bookmarks from the list that appears under the awesone bar. Unfortunately, when I search again, they will still be listed.
finitarry 251 solutions 3421 answers

Maybe changing these settings in the about:config window will finally get rid of that.

  • places.frecency.bookmarkVisitBonus - set to 0 (zero)
  • places.frecency.unvisitedBookmarkBonus - set to 0

I had set those values for Firefox 3.0 because then that was the only way to stop bookmarks getting into the dropdown list under the address bar.

Maybe changing these settings in the about:config window will finally get rid of that. * places.frecency.bookmarkVisitBonus - set to 0 (zero) * places.frecency.unvisitedBookmarkBonus - set to 0 I had set those values for Firefox 3.0 because then that was the only way to stop bookmarks getting into the dropdown list under the address bar.

Question owner

Hi Finitarry, Thanx for the suggestion. Unfortunately it doesn't solve the issue.

Hi Finitarry, Thanx for the suggestion. Unfortunately it doesn't solve the issue.

Modified by myeurop

Question owner

Another thing I noticed is this. Here is one of those old, deleted, unwanted bookmarks: http://www.globalfocus.org.nz/gec_med.../factsheets When I click on it, I get redirected automatically. I changed Firefox option and set them to prevent automatic redirection and set it to "Warn me when site tries to redirect." Unfortunately, those old bookmarks continue to be automatically redirect. Does make the scenario even more complicated? Any takers?

Another thing I noticed is this. Here is one of those old, deleted, unwanted bookmarks: [http://www.globalfocus.org.nz/gec_media/files/factsheets ] When I click on it, I get redirected automatically. I changed Firefox option and set them to prevent automatic redirection and set it to "Warn me when site tries to redirect." Unfortunately, those old bookmarks continue to be automatically redirect. Does make the scenario even more complicated? Any takers?

Modified by myeurop

Duarte Ramos 0 solutions 9 answers

I also have this problem. On Firefox 15 when I search for bookmarks old ones that I have deleted show up in the address bar dropdown results, or if the URL for an existing bookmark changed the old URL shows up along with the new one as separate entries. The annoying thing is since the old result had a lot more hits then the new one it shows up first in the list since it is ranked higher.

Anyone know how to fix this?

I also have this problem. On Firefox 15 when I search for bookmarks old ones that I have deleted show up in the address bar dropdown results, or if the URL for an existing bookmark changed the old URL shows up along with the new one as separate entries. The annoying thing is since the old result had a lot more hits then the new one it shows up first in the list since it is ranked higher. Anyone know how to fix this?
Duarte Ramos 0 solutions 9 answers

I backed up my bookmarks and tried opening the resulting JSON file with a text editor (Notepad++). Curious thing is after doing a search for text strings of the supposedly deleted bookmarks I can still find results of occurrences. Not only were they not deleted they are still being exported, so doing a clean install and restoring the bookmarks has no effect. So it seems the problem is not in the awesome bar, but in the delete option of the bookmark manager.

I tried the mozilla addon to check for integrity of the sqlite file and it solved nothing. Anyone know how to manually clean the json file? I would like to do it but cannot understand its structure, I would not know where to start deleting an entry since the text doesn't seems to be properly indented or paragraphed.

I backed up my bookmarks and tried opening the resulting JSON file with a text editor (Notepad++). Curious thing is after doing a search for text strings of the supposedly deleted bookmarks I can still find results of occurrences. Not only were they not deleted they are still being exported, so doing a clean install and restoring the bookmarks has no effect. So it seems the problem is not in the awesome bar, but in the delete option of the bookmark manager. I tried the mozilla addon to check for integrity of the sqlite file and it solved nothing. Anyone know how to manually clean the json file? I would like to do it but cannot understand its structure, I would not know where to start deleting an entry since the text doesn't seems to be properly indented or paragraphed.
cor-el
  • Top 10 Contributor
  • Moderator
17467 solutions 157849 answers

You will have to delete the places.sqlite file(s) to recover from such an issue with not being able to delete bookmarks.

You will have to delete the places.sqlite file(s) to recover from such an issue with not being able to delete bookmarks. *http://kb.mozillazine.org/Bookmarks_history_and_toolbar_buttons_not_working_-_Firefox *https://support.mozilla.org/kb/Bookmarks+not+saved#w_fix-the-bookmarks-file
Duarte Ramos 0 solutions 9 answers

Bah, thanks for the tip, cor-el, I guess I'll have to do that, thought I will have to rebuild my bookmarks from scratch. At least the Bookmarks.html export seems to be working correctly, no "ghost" bookmarks, but I will still loose keywords and tags, since those are not exported to HTML.

Upon further investigation, using an SQLite viewer as expected the deleted bookmarks are in fact in places.sqlite, thought they do not show up in the bookmarks manager, only in awesome bar suggestions. Too bad I cant seem to manually edit the SQLite database manually so I would delete the false entries by hand.

Bah, thanks for the tip, cor-el, I guess I'll have to do that, thought I will have to rebuild my bookmarks from scratch. At least the Bookmarks.html export seems to be working correctly, no "ghost" bookmarks, but I will still loose keywords and tags, since those are not exported to HTML. Upon further investigation, using an [http://www.yunqa.de/delphi/doku.php/products/sqlitespy/index SQLite viewer] as expected the deleted bookmarks are in fact in places.sqlite, thought they do not show up in the bookmarks manager, only in awesome bar suggestions. Too bad I cant seem to manually edit the SQLite database manually so I would delete the false entries by hand.

Modified by Duarte Ramos