X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Java plugin not showing up in firefox 11 on windows 7 system

Posted

Problem: Java plugin works in IE 9 (32 bit), does not work in firefox. Does not show up in list of plugins when entering about:plugins in address bar. It was working until an automatic Java update. What I have tried: - Uninstalled all java programs in windows control panel and then installed java version 6 update 31 (32 bit). - have reinstalled firefox (twice now). - Selected Mozilla family in java browser options in windows control panel. still no java plugin shows up in firefox plugin manager. - Clicking on the "check to see if your plugins are up to date" link takes me to page that says java is missing and following "upgrade to latest version" link goes to a java update page, however the update fails to install (EULA page doesn't even load). - Downloaded offline install file (jre-6u31-windows-i586-s) and tried that, but still nothing. - Checked programs in windows control panel and only the current 32 bit version of java shows up there. No Mozilla based browser works (firefox, opera etc). Now what? I really kind of need this working but I don't know where to go from here? Thanks

Additional System Details

Installed Plug-ins

  • Novell iPrint Scriptable Plug-in provides functions for the iPrint Map Designer
  • iPrint Plug-in 1.0.0 - Provides iPrint client services for Windows
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Foxit Reader Plug-In For Firefox and Netscape

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0

More Information

Snate686 0 solutions 2 answers

It is possible a registry cleaner like ccleaner will do the job. It depends on how good a job the cleaner does. I'm not surprised uninstalling Firefox completely and reinstalling did not fix it. I tried that as well. The issue isn't directly with Firefox but with Java itself, or more specifically the Java uninstaller leaving things behind.

soaringaa 0 solutions 3 answers

I just had the same problem of only having the Java Deployment Toolkit Plugin but not the Java Platform plugin. This was because I had installed the Java 7 JDK, which also comes with Java SE. So I thought I was good. I took a chance and downloaded and installed the Java SE as well and the Java Platform Plugin showed up in the Firefox Plugins list. Maybe some of you with this problem have just downloaded the JDK too.

AliceWyman
  • Top 25 Contributor
  • Moderator
190 solutions 1961 answers

Helpful Reply

alandadams, Thanks for reporting that you were able to solve the problem with the Java platform plugin not being detected. You said you had installed the Java 7 JDK and what solved the problem was downloading and installing the Java SE... by which I'm assuming you meant the Java JRE. Both the Java JRE and JDK 7 can be downloaded from the Java SE Downloads page, which says:
Quote:


"What Java Do I Need?" You must have a copy of the JRE (Java Runtime Environment) on your system to run Java applications and applets. To develop Java applications and applets, you need the JDK (Java Development Kit), which includes the JRE.


One quick question, the Java 7 SDK you had installed was also the 32-bit (Windows X86) version?

It's puzzling, since the JDK (Java Development Kit) is supposed to include the JRE according to the paragraph I quoted above and http://www.oracle.com/technetwork/java/javase/jdk-7-readme-429198.html#contents ... maybe there was an option during JDK installation to include the JRE that Firefox and other browsers need? (See http://docs.oracle.com/javase/7/docs/webnotes/install/windows/jdk-installation-windows.html#private "Private Versus Public JRE".)

In any case, thanks for the information. This thread is already over 5 months old, so if you want to reply, please do it quickly, since threads are closed and locked automatically at 6 months!

Modified by AliceWyman

soaringaa 0 solutions 3 answers

As you noted, the JDK does come with a JRE. When I installed the JDK I did check and see that the JRE was installed. However I did not have any browser plugins.

I did not uninstall the JDK when I downloaded and installed Java SE from Oracle's web site. I actually need the JDK as well as the JRE.

My guess one of the reasons why it is called Java SE is that it contains the JRE and all of the browser plugins. (Along with other things like antivirus tools and/or browser toolbars from other vendors that you have to "unckeck" to not have installed.)

I installed the Windows 64-bit version of Java 7. I doubt there is a difference in this behavior with the 32-bit version.

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Firefox is a 32 bit application and thus requires the 32 bit Java version.
Firefox won't work with 64 bit Java, so you need to install at least the 32 bit JRE version.

soaringaa 0 solutions 3 answers

Since my Firefox and other 32 bit Java apps seem to be working just fine, I hunted around my file system and found that while I only have a 64-bit JDK. I have both 64 and 32-bit versions of the v7 JRE. I had neither before my Java 7 JDK and Java 7 "SE" download/install. (I cleaned out my Java directories first)

It appears that some smart person at Oracle figured out that most Windows folks installing the 64-bit JRE would need the 32-bit JRE too and included it in the install package.