X
Tap here to go to the mobile version of the site.

Support Forum

What is best FIrefox ver. to load on Ibook G4 w/ OSx 10.4.11

Posted

Mac G4 PPC Mac OSX 10.4.11 with Firefox 2.0.0.7 having problems showing certain lines of text, Click and Drag option not working. Is there a specific version of Firefox that works best for this configuration?

Mac G4 PPC Mac OSX 10.4.11 with Firefox 2.0.0.7 having problems showing certain lines of text, Click and Drag option not working. Is there a specific version of Firefox that works best for this configuration?

Additional System Details

This happened

Every time Firefox opened

This started when...

Not sure

Installed Plug-ins

Flash 9.0.115.0 Java 1.3.1 & 1.4.2

Application

  • User Agent:

More Information

Everything works fine on Safari, restricted by District from making any changes or doing any other troubleshooting.

ideato 893 solutions 6250 answers

Firefox 4 versions and later do not run on a PowerPC Mac(like yours) and require at least OS X 10.5 and an Intel Mac. Firefox 11.0 System Requirements

The latest supported version for your mac is 3.6.28 you can download from here:

http://www.mozilla.org/en-US/firefox/all-older.html

Firefox 3.6 System Requirements

1. Download a new copy of the Firefox program(3.6.28) from the above link

2. Trash the current Firefox application to do a clean (re-) install.

3. Install the new version that you have downloaded(3.6.28).

Your profile data is stored elsewhere in the Firefox Profile Folder, so you won't lose your bookmarks or other personal data.

see also: Installing Firefox on Mac


[For older Macs that aren't supported in Firefox 4+ versions, if you like, try TenFourFox for PowerPC's running Mac 10.4.11 & 10.5.8]

http://www.floodgap.com/software/tenfourfox/

http://tenfourfox.blogspot.com/

https://code.google.com/p/tenfourfox/wiki/PluginsNoLongerSupported


thank you

Please mark "Solved" the answer that really solve the problem, to help others with a similar problem.

Firefox 4 versions and later '''do not run on a PowerPC Mac'''(like yours) and require '''at least OS X 10.5''' and an '''Intel Mac'''. [http://www.mozilla.org/en-US/firefox/11.0/system-requirements/ Firefox 11.0 System Requirements] The latest '''supported version for your mac is 3.6.28''' you can download from here: http://www.mozilla.org/en-US/firefox/all-older.html [http://www.mozilla.org/en-US/firefox/3.6/system-requirements/ Firefox 3.6 System Requirements] 1. Download a new copy of the Firefox program(3.6.28) from the above link 2. Trash the current Firefox application to do a clean (re-) install. 3. Install the new version that you have downloaded(3.6.28). Your profile data is stored elsewhere in the [http://kb.mozillazine.org/Profile_folder_-_Firefox Firefox Profile Folder], so you won't lose your bookmarks or other personal data. see also: [https://support.mozilla.org/en-US/kb/Installing%20Firefox%20on%20Mac Installing Firefox on Mac] [For older Macs that aren't supported in Firefox 4+ versions, if you like, try TenFourFox for PowerPC's running Mac 10.4.11 & 10.5.8] http://www.floodgap.com/software/tenfourfox/ http://tenfourfox.blogspot.com/ https://code.google.com/p/tenfourfox/wiki/PluginsNoLongerSupported thank you Please mark "Solved" the answer that really solve the problem, to help others with a similar problem.