X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I don't have a 3D DOM inspector button

Posted

On my home computer, a fresh Firefox 11 install has the 3D button, but on my work computer where I just upgraded from 10 to 11, the button is not there.

Are there some prerequisites for the 3D DOM inspector that I don't know about? Is there a way to find out why it's not showing up, or to forcibly enable it?

Chosen solution

Please also see this. The More system details on the top right of this page or via Firefox Help (Alt + H) > Troubleshooting Information, says WebGL rendering is blocked for the particular graphics driver.

Read this answer in context 7

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.1 r102
  • Next Generation Java Plug-in 1.6.0_31 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • 4.1.10111.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.2
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • 04.0000.0007
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0

More Information

Application Basics
Name
Firefox
Version
11.0
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Adblock Plus
2.0.3
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
ColorZilla
2.6.4
true
{6AC85730-7D0F-4de0-B3FA-21142DD85326}
Firebug
1.9.1
true
firebug@software.joehewitt.com
FoxGuide
1.4
true
{66B2CEAE-80B4-46b0-8E4D-586721E5C1FA}
MeasureIt
0.4.10
true
{75CEEE46-9B64-46f8-94BF-54012DE155F0}
NoScript
2.3.4
true
{73a6fe31-595d-460b-a920-fcc0f8843232}
Tamper Data
11.0.1
true
{9c51bd27-6ed8-4000-a2bf-36cb95c0c947}
Modified Preferences
Name
Value
accessibility.typeaheadfind
true
browser.places.smartBookmarksVersion
2
browser.startup.homepage_override.buildID
20120312181643
browser.startup.homepage_override.mstone
rv:11.0
browser.tabs.warnOnClose
false
extensions.lastAppVersion
11.0
gfx.blacklist.direct2d
3
gfx.blacklist.layers.direct3d10
3
gfx.blacklist.layers.direct3d10-1
3
gfx.blacklist.layers.direct3d9
3
gfx.blacklist.layers.opengl
3
gfx.blacklist.suggested-driver-version
10.6
gfx.blacklist.webgl.angle
3
gfx.blacklist.webgl.msaa
3
gfx.blacklist.webgl.opengl
3
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1330370444
places.history.expiration.transient_current_max_pages
104858
privacy.donottrackheader.enabled
true
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
ATI Radeon HD 4200
Vendor ID
1002
Device ID
9710
Adapter RAM
368
Adapter Drivers
atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
Driver Version
8.652.0.0
Driver Date
9-1-2009
Direct2D Enabled
Blocked for your graphics driver version. Try updating your graphics driver to version 10.6 or newer.
DirectWrite Enabled
false (6.1.7601.17776)
ClearType Parameters
ClearType parameters not found
WebGL Renderer
Blocked for your graphics driver version. Try updating your graphics driver to version 10.6 or newer.
GPU Accelerated Windows
0. Blocked for your graphics driver version. Try updating your graphics driver to version 10.6 or newer.

Vivek 310 solutions 2084 answers

Please check if this happens in a new profile. If it's okay, you can later copy the needed personal data from the old profile. Firefox stores your personal data and settings in another location separate from its files/folder. A new profile would have the default Firefox settings (Tools (Alt + T) > Options, and about:config ), and usually would also be empty of any Extensions and themes (Appearance) in Tools > Add-ons) and their settings. Also, a new profile would have no previous stored website data/settings etc., (Tools > Clear Recent History).

Profiles Howto

Profile Folder & Files

about:config Entries

Question owner

Alas, even with a new profile there still isn't a 3D button.

Vivek 310 solutions 2084 answers

Chosen Solution

Please also see this. The More system details on the top right of this page or via Firefox Help (Alt + H) > Troubleshooting Information, says WebGL rendering is blocked for the particular graphics driver.

Question owner

Thanks, I guess I should have actually read that troubleshooting information, eh?

I'll update my drivers and that should take care of it.

Thanks!

Vivek 310 solutions 2084 answers

No problem :) Please also see this.

lzlzlz 0 solutions 1 answers

No 3D button for Web Developer -> Insptect, no matter what!

Firefox 11.0 (Mozilla Firefox for Ubuntu canonical - 1.0), Ubuntu 10.4, current version of Nvidia accelerated graphics driver, 12 Gbyte memory.

Followed http://www.ubuntugeek.com/howto-enable-webgl-on-firefox-4.html:libosmesa6 installed and the link in about:config is in place.

I disabled allmost all add-ons, only session manager, tabkit2 (absolutely necessary for orientation among about 200 tabs) and Ubuntu Firefox Modifications (default on Firefox/Ubuntu) are left. I tested to start Firefox in a new, clean profile.

Testing with mesa-utils works. I attach a screenshot from visited http://www.doesmybrowsersupportwebgl.com/, it says that webgl is supported. I can follow examples on pages like http://guciek.github.com/teflyjs.htmll.

WebGL i Chromium works.

Still, there is NO 3d button! On the rigth bottom edge of Firefox there are only two bottons - HTML and Style. I attach a screenshot as documentation.

(totaly 3 screenshots attached)

Where is the problem?

Vivek 310 solutions 2084 answers

Hi lzlzlz,

Please also see this. You can also start a new thread which would be helpful in providing more details as you post the question: https://support.mozilla.com/questions/new

Wisco 0 solutions 8 answers

Without the 3d button, the new DOM inspector is pretty useless. Any way to get the old one back?

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

WebGL is required for the 3D View button to work properly.

Does the Graphics section on the Help > Troubleshooting Information page show that WebGL is disabled?

Do you have the latest updates for your graphics display driver?

Wisco 0 solutions 8 answers

My graphics card doesn't seem to support it. What do I do now?

Gingerbread Man
  • Top 25 Contributor
227 solutions 939 answers

Helpful Reply

Wisco wrote:

Without the 3d button, the new DOM inspector is pretty useless. Any way to get the old one back?

Same as before, DOM Inspector is a separate extension.