Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

FF 11.0 does not word wrap many of my pages

  • 35 replies
  • 25 have this problem
  • Last reply by w0rmz

more options

I have been having trouble with some but not all websites not performing is like a full paragraph of text on one line. Pain in the neck to read and am ready to go back to IE but do not want to. Using FF 11.0 on a 64 bit W7 computer. Many things have changed on this computer in the last few months with updates and versions changing. I have disabled all add-ins to no avail. I searched the web and most articles that I find deal with word wrap problems that page developers are happening. I searched FF help and got 117 pages...and actually went through four pages, finding nothing even remotely relevant to this problem.

Can some one help?



Modified by NoahSUMO

Chosen solution

Can you post a part of generated page source by selecting a one or more long lines and using View Selection Source in the right-click context menu to see if that gives any clues?

Read this answer in context 👍 0

All Replies (20)

more options

Can you provide a link to a page that has this behavior? It's likely something with the HTML code.

more options

I suspected a problem on an individual site too. In fact, I notified one web site. But the problem does NOT manifest itself on just one web site. Of course that does not preclude multiple programmers/compilers from having the same errant coding practice. I personally can barely read HTML and would never figure out what is happening here by looking at it. Maybe some day, I will teach myself the language. But Java may be higher on my self education list.  :-)

It happens a lot on Kim Komando's sites but also Investopedia and others. and i cn past the URL from FF into IE and everything is fine. I can copy the text and paste it into Word and it is then readable but there is still some mangling.

Here are two links: --i attached an image from this one.

Here is a second site:

I cannot remember where else this has happened, but there were others.

I attached an image from both the URLs above in case your copy of FF works there. Incidentally, I also tried installing FF again but I did not do an uninstall first. But at this point, i won't do anything unless you ask me to so cut maintain a consistent basis for discussion..

Hope this helps.

Thanks for you time and interest.


more options

It looks like you're not loading the CSS for those pages. You can try forcing it by going to View > Page Style and selecting something that's not "None". You may have a buggy copy of the CSS in the cache: hold Shift and reload the page (Shift-Ctrl-R) and see if that fixes it.

more options

Thank you. I found the answer under view. I changed it from Basic Page Style to No Style and did the trick. For anyone else with this problem, i uploaded an image of the solution.

I guess somehow, during an upgrade, it got set to Basic Page Style. I actually did not have the FF menu bar visible and, as such, would never have touched the Page Styles.

Thanks again to all who bothered to look at this.


more options

After using this solution for a while, I have concluded that it is not the right solution. It does get me wrapped text but the rest of the page formatting is incorrect. I will live with this, however. I just wanted others who might see this to know that this is temporary fix.

I believe that I will have to blow away all my profile settings (complete FF uninstall) and then install FF over again and start with a fresh slate...I am convinced that this will be easier than piece-meal trying to track down the problem. But then, even this might not work, who knows. If i remember to, I will update this after I do that but that won't be for a while as I have other pressing tasks. \ But thanks to all who helped me.

Terry .

more options


Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

more options

Thanks, Cor-el....tried it...did not help. Details of what i tried below. 1. I read about the localstore. from the link you sent. I searched my system and found two earlier versions of it. I saved the current one and tried both of the old ones. It did not help. I restored the copy of the current one that i had made to get back to way things were. 2. i went to as directed and followed the instructions there, checking the box for "Reset Toolbars and Controls" and then continued into Safe Mode and tried a Kim Komando tip web page. Still getting the original problem. 3. I then tried the suggestion below the bar in your reply to start Safe Mode and check the default theme. That page showed "Default 11.0 (Disabled)" and no other themes.

So, i was unable to improve the situation.

Any other ideas, guys/gals?


more options

Create a new profile as a test to check if your current profile is causing the problems.

See "Basic Troubleshooting: Make a new profile":

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.

If that new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.


more options

Thanks again, but i have given up on FF. I am going to uninstall FF and try from scratch. Nothing is working in FF anymore. I cannot run the Speakeasy speed test (Flash problem of some sort) nor can i click on the link from the Mozilla notification and have FF open the link.

I think tht as we try things to fix the original problem, i am not getting things back exactly as they were and I am just compounding the problem, making a molehill into a mountain.

In fact, I had to use IE to even reply to this problem.

If after a full uninstall and reinstall it does not work, i will just have to go back IE which i hate to do.

Do you, with your knowledge of FF, have any special insight to a FULL uninstall. I would like to back up my book marks.



more options

Ok, I am still having the same word wrap problems as before i did a clean install. I did the following to get the clean install: 1. Backed up my bookmarks 2. Did an uninstall. On the uninstall window, selected the option to remove user profiles 3. Ran CC cleaner and cleaned he registry 4. Deleted the Mozilla FireFox folders in the Programs86 folder 5. Downloaded and installed a clean version of FF 6. Imported the Bookmarks from step 1 7. Did NOT install any extensions. 8. The Appearance says Default 11.0 9. I am doing PRIVATE browsing. (I also turned off private browsing and have the same display problem.) 10. There are a number of Add-ins active. I assume that FF installed these when it installed as I did nothing to install them. These add-ins are: Adobe Acrobat Java Deployment Tookit 6.0.310.5 Java Platform SE 6 U31 6.0.310.5 Microsoft Office 2010 14.0.4761.1000 Microsoft Office 2010 14.0.4730.1010 Nitro PDF Plug-in npFFAPI Shockwave Flash Silverlight Plug-in VLC Web Plugin Windows Live Photo Gallery 15.4.3539.513 11. I looked for the localstore folder but it appears to have been removed when the user profile was removed.

Did i do something wrong in the uninstall? During the install? At least the re-installation of FF finally fixed the Flash player problem that i had after trying some of the earlier fixes.  :-)

There are a lot of things I like better about FF, including that it is not MS. But I cannot use it like this.

Any more suggestions???? I have not tried Opera or Chrome....but would rather not do that either.

Thanks folks. I am not going to touch FF until i hear some new suggestion...


What is carrying over that is causing FF to be virtually useless?

more options

Talked to a developer on this and his second question was "is he on a slow/shaped connection?" I know IE doesn't do this but some firewall/network optimizers may be messing with the data coming through.

For what it's worth those pages look fine here and I tried testing it on all three operating systems and with many different versions of Firefox.

more options

A lot of CSS files are loaded via @import on the pages that you linked above.

Do you have security software that can block CSS files?

How are your screen dimensions reported?

data:text/html;charset=utf-8,<script>alert("Current Width: "+window.outerWidth+"\n\nCurrent Window: "+window.outerWidth+" x "+window.outerHeight+"\nScreen Available: "+screen.availWidth+" x "+screen.availHeight+"\nFull Screen Size: "+screen.width+" x "+screen.height);</script>
more options

Thanks guys, I appreciate your persistence. For Cww: I am on a 650 Mpbs DSL connection. But I have been on this connection for several years now and did not have this problem a few months (or weeks back--I wish i could pinpoint when it started). I am using Zone Alarm, AVG, Spybot S&D and Adaware on this machine. I have not changed any of their settings but they may have gone through an update...I generally update when told to lest i miss some security patch. The pages look fine in IE and on my laptop computer which is configured similarly but not identically as it is not a very fast laptop. The laptop is running FF 6.0 however. Is FF 11.0 a relatively recent upgrade and could this be the reason that it used to work in my environment and now does not? I understand it SHOULD work as well as any older version and it is useful to stay with the current version for security purposes, if for no other reason.

For cor-el: You are getting beyond my knowledge level. I do not speak HTML but recall from some of my reading that CSSs are some sort of Sheet Style Classes or something I have no idea what the implication of being loaded via @import might be so if it is important, you will have to hold my hand. I mentioned the security software above. As for screen dimensions, I do not know how to get that info or what the small script you provided is used/or means.

I have been poking around trying to find info on the screen dimensions. I did find that "allow pages to choose their own font" is checked, if that is any help.

I just found a tool called Tryit ( and pasted your script into it and got the following: Current Width 1114 Current Window: 1104 x 1011 Screen Avail: 1920 x 1050 Full Screen Size: 1920 x 1080 Is that what you needed? I have no idea what i was doing...but it ran something. (I believe that this is old/original definition of hacking: trying things that you do not fully understand, making (hopefully) intelligent guesses, and trying them to see what you get?)

Let me know what else i need to do, guys. Is the older version of FF avail and is that a viable test? Are there some tweaks in the security SW that might help? \

Thanks for the patience.


more options

Ok, found someone to look at the code on both pages. They're both designed to have text that wraps around a pre-defined ad area. Something on your computer (likely a firewall, a system-wide ad-blocker, network controls or a modified hosts file) is removing the ad (it doesn't show up in your screenshots) and hence the wrapping gets completely screwed up.

I think the way Firefox handles that kind of wrapping may have changed in Firefox 11 (still trying to find someone to confirm that) but that may be what caused the odd behavior.

more options

Your Firefox window dimensions look OK as reported, so that shouldn't cause this issue.

You aren't using code in userContent.css that might cause this?

It almost looks that there is some white-space: nowrap property active.

Is that table cell (#Side) with the ad visible on the page?

more options

I have started writing my response in WORD and pasting them into the upload area because three times (different replies) I have clicked a link that wiped out an hour’s worth of data collection… Grrrrrr.


For Cww: I searched for “ad” and “block” where “and” is a logical and –no files with that. As for the hosts file, I am not sure what to look for in it. I did rename it and go to the Investopedia page and got the same result as before. Part of hosts file—I deleted some of the comment material at the top… If this is of interest, I can send the whole file. Let me know

Copyright (c) 1993-2009 Microsoft Corp.
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.

# Start of entries inserted by Spybot - Search & Destroy

I have made no special changes to my firewall settings…pretty much stock from Zone Alarm…ditto for the router. Certainly, I have not KNOWINGLY made any changes there in the last three months or longer.


For cor-el I searched for a file “usercontent.css” and found none. I also looked inside my profile file folder (provided by FF via the help function) and manually looked and found no .css files therein. I did find an .xml file there that had an interesting name and included part of it below: blocklist.xml:

<?xml version="1.0"?>
-<blocklist lastupdate="1332437927000" xmlns=""> -<emItems> -<emItem id="" blockID="i58"> <versionRange maxVersion="*" minVersion="0"> </versionRange> </emItem> -<emItem id="{99079a25-328f-4bd4-be04-00955acaa0a7}" blockID="i41"> <versionRange maxVersion="" minVersion="0.1" severity="1"> </versionRange> </emItem> -<emItem id="" blockID="i71"> <versionRange maxVersion="*" minVersion="0"> </versionRange> </emItem> -<emItem id="{B13721C7-F507-4982-B2E5-502A71474FED}" blockID="i8"> <versionRange minVersion=" " severity="1"> </versionRange> </emItem> <emItem id="" blockID="i43"> </emItem> -<emItem id="" blockID="i65"> <versionRange maxVersion="*" minVersion="0"> </versionRange> </emItem> -<emItem id="" blockID="i66"> <versionRange maxVersion="*" minVersion="0"> </versionRange> </emItem> -<emItem id="" blockID="i54"> <versionRange maxVersion="*" minVersion="0"> </versionRange> </emItem> -<emItem id="{27182e60-b5f3-411c-b545-b44205977502}" blockID="i16"> <versionRange maxVersion="1.0" minVersion="1.0"> </versionRange> </emItem>

Not sure what you are asking when you say table cell (#Sude) , Looking at the Investopedia page with FF there are no ads except at the far right. I attached that to this reply. There is a lot of white space to the left of that portion of the page.
======================= I don’t know if I helped or not…I will try any other ideas you guys come up with. And thanks again.


Modified by cor-el

more options

You do have ad blocking, it's in your hosts file and was put in place by Spybot Search & Destroy -- Delete all of those entries, save and restart windows.

more options

I will do so sometime tomorrow...cannot reboot right now. But there are some mighty bad looking websites in there being blocked from Russia and China, for example. It turns out that EVERYTHING IN THERE is from Spybot so i will just rename the file and do a test.

And report back tomorrow. Note that i have had Spybot on the machine for years but perhaps they have recently started using using the hosts file as their immunization mechanism.

Here is hoping for the best. I may be able to modify that hosts file after i get things working and kill the foreign sites that i have no use for and keep the US sites...and divide and conquer if it starts misbehaving.

I will certainly replay back.

Thanks for figuring this out. It was obvious to me that those sites were being blocked but did not see how they affected the page layout. My lack of knowledge of how page set ups work.


more options

It's not the sites, it's the ads. What you can try to do is install adblock plus (which blocks ads but does it in a more logical way than what spybot does). You'll also find that since all your lookups won't go through this giant file that Firefox (and web browsing in general) will be a lot faster.

more options

As much a I would like, this is not the solution.

1. I renamed the hosts file 2. I rebooted the computer 3. Opened one of the offending URLs and got the same result.

More supporting evidence: 1. I went to my laptop and it updated a bunch of things (including Vista) and installed FF 11.0. 2. i checked its host file...yes there was a big one similar to the one on the desktop 3. I went to one of the offending URLs and it works fine

So, there has to be something else causing the problem. It does not seem to be the hosts file blocking anything. I have not re-installed the hosts file on the desktop that is not working, however.

Boy, this is getting hard now. When we find it, just as i did in my old Fortran programming days, i will be shouting AHA because it was so obvious. But i am surely stumped for now...

Any other ideas or places to look?


  1. 1
  2. 2