Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Java not recognized

  • 6 replies
  • 121 have this problem
  • 13106 views
  • Last reply by AliceWyman

more options

I have followed all the steps to correct this problem. I have completely uninstalled FF and reinstalled Java several times. I have windows 7 with the latest version of FF and Java. Java console 6.0.29 is listed in the Add-ons Manager and I've tried to configured the Java console through the control panel, checked the Mozilla family box in the default Java for browsers button, click apply then okay. when I reopen Java console it is unchecked.

Chosen solution

As of right now, according your your system details is doesn't look like you have Java installed :/

I'm going to have you do a few things.

1. Go into your Control Panel, then find Programs and Features, and uninstall every instance of Java you fin there (there may be multiple versions, so remove them all).

2. Go to this page (http://javadl.sun.com/webapps/download/AutoDL?BundleId=61043) and download and install this version of Java. Make sure you have all browsers closed.

3. Restart your computer, then open Firefox. In the address bar of Firefox, type "about:plugins" (without the quotes) then press Enter. See if Java shows up. If it does, you have installed it successfully.

The java console isn't java, it is a tool for some versions of Java that is installed inside Firefox as an extension. There tend to be lots of problems with the Console, so we won't touch it for right now. I just wan to make ure java shows up in your about:plugins page.

Read this answer in context 👍 3

All Replies (6)

more options

Chosen Solution

As of right now, according your your system details is doesn't look like you have Java installed :/

I'm going to have you do a few things.

1. Go into your Control Panel, then find Programs and Features, and uninstall every instance of Java you fin there (there may be multiple versions, so remove them all).

2. Go to this page (http://javadl.sun.com/webapps/download/AutoDL?BundleId=61043) and download and install this version of Java. Make sure you have all browsers closed.

3. Restart your computer, then open Firefox. In the address bar of Firefox, type "about:plugins" (without the quotes) then press Enter. See if Java shows up. If it does, you have installed it successfully.

The java console isn't java, it is a tool for some versions of Java that is installed inside Firefox as an extension. There tend to be lots of problems with the Console, so we won't touch it for right now. I just wan to make ure java shows up in your about:plugins page.

more options

The Java plugin that you see in "Tools > Add-ons > Plugins" is used to run Java applets.
You only need the Java Console extension (Tools > Add-ons > Extensions) if you want to check and debug Java applets.

Be aware that you need a 32 bit Java version for a 32 bit Firefox version.

more options

I did everything suggested (see below) and Java is still not working. When I type "about:plugins" (without the quotes) into the address bar of Firefox, Java does show up. I have deleted and reinstalled Java seven times. I have followed every instruction. I am now completely frustrated and at a total loss about what to do next. Java was working fine until just four days ago. Windows did an update (I'm running Windows 7 on a X64-based PC) and it hasn't worked since then. I don't know if that has anything to do with my problem or not, just thought I'd mention it.

1. Go into your Control Panel, then find Programs and Features, and uninstall every instance of Java you fin there (there may be multiple versions, so remove them all).

2. Go to this page (http://javadl.sun.com/webapps/download/AutoDL?BundleId=61043) and download and install this version of Java. Make sure you have all browsers closed.

3. Restart your computer, then open Firefox. In the address bar of Firefox, type "about:plugins" (without the quotes) then press Enter. See if Java shows up. If it does, you have installed it successfully.

more options

The version of Java you are using is out of date and blocked by Firefox, which is most likely why you are having trouble. Try using the newest version: http://javadl.sun.com/webapps/download/AutoDL?BundleId=65692

more options

Thank you for your response. Even though I'd already tried the latest version of Java, I tried it again. It's still not working. I was hoping an older version might work as Java has preformed perfectly in the past -- up until about a week ago. I've always been able to figure out the Java problems on my own before this occurrence. This has me stumped.

more options

Catryce214, If you need help getting Java installed and working, see these articles:

If you need more help should start your own thread since this one was started by a different user over five months ago. Support threads that are six months old are now automatically closed (locked).

You can use this link as a starting point to ask a new question and start a new thread: https://support.mozilla.org/questions/new