X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Flash has no sound

Posted

Using Firefox 10, now 11, under OS X Lion, I have no sound in flash videos and animations. I have sound in flash videos and animations under Chrome & Safari. I have sound in all other apps. I have sound in Firefox when the video or animation is not flash (HTML 5, for example.)

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.1 r102

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:11.0) Gecko/20100101 Firefox/11.0

More Information

I have checked all the settings suggested in the No Sound with Flash article in the Firefox knowledge base. This includes checking global storage, making sure third party sites can store information for embedded videos, clearing the cache, allowing pop ups. I've also checked the Midi set up to make sure sound is correctly set at 44,000 khz. I have completely uninstalled and reinstalled Firefox. I have completely uninstalled and reinstalled Flash. I have rolled back to an older version of Flash. I have removed all plug ins and extensions except for Shockwave Flash. Nothing has worked.
Here is the information from Help > Troubleshooting Information
Application Basics
Name
Firefox
Version
11.0
User Agent
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:11.0) Gecko/20100101 Firefox/11.0
Profile Directory
Show in Finder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Modified Preferences
Name
Value
browser.places.smartBookmarksVersion
2
browser.startup.homepage_override.buildID
20120312181643
browser.startup.homepage_override.mstone
rv:11.0
extensions.lastAppVersion
11.0
network.cookie.prefsMigrated
true
places.history.expiration.transient_current_max_pages
104858
privacy.sanitize.migrateFx3Prefs
true
Graphics
Vendor ID
10de
Device ID
0a29
WebGL Renderer
NVIDIA Corporation -- NVIDIA GeForce GT 330M OpenGL Engine -- 2.1 NVIDIA-7.18.11
GPU Accelerated Windows
1/1 OpenGL
AzureBackend
skia

kingdhanu 1 solutions 7 answers

try to add https always to the firefox. Prob will solve

Question owner

That did not work

ideato
  • Top 25 Contributor
617 solutions 4264 answers

see if this is helpful : No audio when Flash video originates from an external site


thank you

Question owner

Thanks. Already tried that. Didn't work.

cor-el
  • Top 10 Contributor
  • Moderator
10778 solutions 97004 answers

Helpful Reply

Try to clear the Flash cookies (LSO).

Flash Website Storage Settings panel:

Global Storage Settings Panel:

Flash Local storage settings Help:

zorblek 1 solutions 10 answers

I'm having the same problem with Firefox 11 and Flash 11.2.202.228 on Windows 7. Flash works normally in both Chrome and IE, but I get no sound in Firefox. HTML5 videos play normally. I've tried all the above fixes with no luck.

zorblek 1 solutions 10 answers

Helpful Reply

I should add that, unlike the original poster, the problem started for me in Firefox 11, not 10. And as far as I can tell, it didn't happen following any Firefox or add-on updates.

ClearD 0 solutions 1 answers

I found this just now:

http://forums.adobe.com/thread/1026022

It fits the question, and I had the same problem. Their temporary solution for windows 7 was to lower the bitrate to 44100 KHz and that solved the problem for me. :) Figured I'd share.