X
Tap here to go to the mobile version of the site.

Support Forum

Add new Bookmarks folder name entry not working

Posted

(There's a reason I'm duping the previous thread on this topic,as well as my response to that thread: I couldn't find a way to add FireFox 10.0.2 to the thread's tags. If thread tags could be edited/appended, I wouldn't have to highlight problems with FireFox 10.0.2 by starting this new thread.) RE add new bookmark folder, can't enter name of new folder:

I'm now having this problem with FireFox 10.0.2, 03/11/2012

When I click on Add Folder, a new folder appears in the tree and the folder name field is highlighted for input. But when I start to type characters in the field, I can only type 1 or 2 chars at the most before it stops accepting input. I have to then go into the Bookmarks menu, locate the new folder, right click on it, click on Properties, and complete entry of the folder name.

At worst, the folder name field will stop accepting input as soon as I type the first char, in which case the folder name will remain as "New Folder". I locate the new folder in the Bookmarks menu to change the name as described above.

This is very annoying because it adds a number of extra steps just to add a new folder to the bookmarks menu. Adding the new folder via "Show All Bookmarks" and navigating the folder tree is another workaround but that doesn't save any steps.

Any ideas or solutions?

''(There's a reason I'm duping the previous thread on this topic,as well as my response to that thread: I couldn't find a way to add FireFox 10.0.2 to the thread's tags. If thread tags could be edited/appended, I wouldn't have to highlight problems with FireFox 10.0.2 by starting this new thread.)'' '''RE add new bookmark folder, can't enter name of new folder:''' I'm now having this problem with FireFox 10.0.2, 03/11/2012 When I click on Add Folder, a new folder appears in the tree and the folder name field is highlighted for input. But when I start to type characters in the field, I can only type 1 or 2 chars at the most before it stops accepting input. I have to then go into the Bookmarks menu, locate the new folder, right click on it, click on Properties, and complete entry of the folder name. At worst, the folder name field will stop accepting input as soon as I type the first char, in which case the folder name will remain as "New Folder". I locate the new folder in the Bookmarks menu to change the name as described above. This is very annoying because it adds a number of extra steps just to add a new folder to the bookmarks menu. Adding the new folder via "Show All Bookmarks" and navigating the folder tree is another workaround but that doesn't save any steps. Any ideas or solutions?

Chosen solution

Hi John99, It worked fine in Safe Mode. Thanks for the suggestion!

I'll have to go offline a bit to figure out which add-on, plugin, etc, might be causing it. In the meantime, I've marked your suggestion to use Safe Mode as Helpful so that anyone else coming here might get the hint.

I should probably drop another line in the thread for the guy who's (or who was) using FireFox 7...

I'll post my results whether or not I can figure it out.

UPDATE:

I went after any add-on that had anything to do with bookmarks.

It was the first Add-On I tried, SortPlaces 1.9.1, which automatically sorts bookmarks in various ways depending on the settings. When I disabled it the problem went away.

I re-enabled it and checked the options to see if I could figure out why it was butting into add new folder. On the "Options" tab there's a delay interval for how long SortPlaces will wait before sorting a changed or added bookmark. It was set to 3 seconds.

That's not long enough for old men typing new folder names. I set it to 10 seconds. Then I created a new bookmark folder and started typing a long nonsense name while I watched the clock. After 10 seconds it stopped accepting input, right on the mark. What concealed this to me earlier was that when it stops accepting input, you don't see the new folder move into the sort position in the Add Folder menu. You only see that if you later expand the folder. This is probably why I wasn't connecting the two.

Anyway, problem solved. I'm leaving the delay at 10 seconds. If I ever need it to be longer, I'll just increase it.

Thanks again for the Safe Mode suggestion and enjoy the coming mud season,

Alan Mintaka

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.1 r102
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.3.633
  • Next Generation Java Plug-in 1.6.0_29 for Mozilla browsers
  • 4.0.60831.0
  • IE Tab 2 Plug-in for Mozilla/Firefox
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 12.0.1.609
  • GEPlugin
  • Foxit Reader Plug-In For Firefox and Netscape
  • Coupons, Inc. Coupon Printer Plugin
  • Package Installer & Install Conduit

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:10.0.2) Gecko/20100101 Firefox/10.0.2

More Information

John99 971 solutions 13138 answers

Firstly your last thread may or may not be the same subject but has an unanswered question, I suggest you start by answering that /questions/918095#answer-310264

Firstly your last thread may or may not be the same subject but has an unanswered question, I suggest you start by answering that [/questions/918095#answer-310264]

Question owner

John99, That thread has nothing to do with this one. What's your point here? Do we have to respond in other threads on totally unrelated topics before we can proceed with new threads?

Getting back to the question asked in this thread, do you know why Add New Folder doesn't accept name entry?

John99, That thread has nothing to do with this one. What's your point here? Do we have to respond in other threads on totally unrelated topics before we can proceed with new threads? Getting back to the question asked in this thread, do you know why Add New Folder doesn't accept name entry?
John99 971 solutions 13138 answers

I think I may have seen something similar recently. I have not however tried to follow it up. Maybe someone else will comment with a more knowledgeable answer. I am also fairly certain there is a problem with some of the favicon icons for bookmarked items, but again I have not tried too hard to follow up on the problem.

You will need to try it out in Troubleshoot Firefox issues using Safe Mode using the default theme, and with all plugins disabled, you should also compare a recent nightly. If you can prove reproducibly there is a problem then we need to try to look for an already filed bug or file a bug.

I think I may have seen something similar recently. I have not however tried to follow it up. Maybe someone else will comment with a more knowledgeable answer. I am also fairly certain there is a problem with some of the favicon icons for bookmarked items, but again I have not tried too hard to follow up on the problem. You will need to try it out in [[safe mode]] using the default theme, and with all plugins disabled, you should also compare a recent nightly. If you can prove reproducibly there is a problem then we need to try to look for an already filed bug or file a bug.

Question owner

Safe Mode is a good idea, as long as it doesn't require me to re-enter my profile settings all over again. I'll look into that.

RE favicons: I'm not sure if this is related or not, but I've been using the extension Favicon Picker 2. The icons I use to replace the default bookmark favicons have been staying put regardless of how many times I visit those sites, i.e. the sites can't replace my favicons with theirs, which is how the extension is supposed to work. Does that offer up any kind of clue to the other favicon problem?

PS: I did answer that other question before I posted this response....

Safe Mode is a good idea, as long as it doesn't require me to re-enter my profile settings all over again. I'll look into that. RE favicons: I'm not sure if this is related or not, but I've been using the extension Favicon Picker 2. The icons I use to replace the default bookmark favicons have been staying put regardless of how many times I visit those sites, i.e. the sites can't replace my favicons with theirs, which is how the extension is supposed to work. Does that offer up any kind of clue to the other favicon problem? PS: I did answer that other question before I posted this response....

Modified by AlanMintaka

Chosen Solution

Hi John99, It worked fine in Safe Mode. Thanks for the suggestion!

I'll have to go offline a bit to figure out which add-on, plugin, etc, might be causing it. In the meantime, I've marked your suggestion to use Safe Mode as Helpful so that anyone else coming here might get the hint.

I should probably drop another line in the thread for the guy who's (or who was) using FireFox 7...

I'll post my results whether or not I can figure it out.

UPDATE:

I went after any add-on that had anything to do with bookmarks.

It was the first Add-On I tried, SortPlaces 1.9.1, which automatically sorts bookmarks in various ways depending on the settings. When I disabled it the problem went away.

I re-enabled it and checked the options to see if I could figure out why it was butting into add new folder. On the "Options" tab there's a delay interval for how long SortPlaces will wait before sorting a changed or added bookmark. It was set to 3 seconds.

That's not long enough for old men typing new folder names. I set it to 10 seconds. Then I created a new bookmark folder and started typing a long nonsense name while I watched the clock. After 10 seconds it stopped accepting input, right on the mark. What concealed this to me earlier was that when it stops accepting input, you don't see the new folder move into the sort position in the Add Folder menu. You only see that if you later expand the folder. This is probably why I wasn't connecting the two.

Anyway, problem solved. I'm leaving the delay at 10 seconds. If I ever need it to be longer, I'll just increase it.

Thanks again for the Safe Mode suggestion and enjoy the coming mud season,

Alan Mintaka

Hi John99, It worked fine in Safe Mode. Thanks for the suggestion! I'll have to go offline a bit to figure out which add-on, plugin, etc, might be causing it. In the meantime, I've marked your suggestion to use Safe Mode as Helpful so that anyone else coming here might get the hint. I should probably drop another line in the thread for the guy who's (or who was) using FireFox 7... I'll post my results whether or not I can figure it out. UPDATE: I went after any add-on that had anything to do with bookmarks. It was the first Add-On I tried, SortPlaces 1.9.1, which automatically sorts bookmarks in various ways depending on the settings. When I disabled it the problem went away. I re-enabled it and checked the options to see if I could figure out why it was butting into add new folder. On the "Options" tab there's a delay interval for how long SortPlaces will wait before sorting a changed or added bookmark. It was set to 3 seconds. That's not long enough for old men typing new folder names. I set it to 10 seconds. Then I created a new bookmark folder and started typing a long nonsense name while I watched the clock. After 10 seconds it stopped accepting input, right on the mark. What concealed this to me earlier was that when it stops accepting input, you don't see the new folder move into the sort position in the Add Folder menu. You only see that if you later expand the folder. This is probably why I wasn't connecting the two. Anyway, problem solved. I'm leaving the delay at 10 seconds. If I ever need it to be longer, I'll just increase it. Thanks again for the Safe Mode suggestion and enjoy the coming mud season, Alan Mintaka

Modified by AlanMintaka

John99 971 solutions 13138 answers

Glad you sorted out the problem, thanks for posting back.

Glad you sorted out the problem, thanks for posting back.

Question owner

Well, you solved it as far as I'm concerned. I flagged my last post as "Solved it" only because that's where a detailed description of the solution is.

I let the guy in the older thread for FireFox 7 know about it too, just in case he ever checks back there. This one really is sneaky because of not seeing the sort take place when the new folder stops taking name input.

Have a good one,

Alan Mintaka

Well, you solved it as far as I'm concerned. I flagged my last post as "Solved it" only because that's where a detailed description of the solution is. I let the guy in the older thread for FireFox 7 know about it too, just in case he ever checks back there. This one really is sneaky because of not seeing the sort take place when the new folder stops taking name input. Have a good one, Alan Mintaka

Modified by AlanMintaka

mimi123 0 solutions 5 answers

I just updated Firefox to 11.0, and now have this same problem. I followed the suggestion on restarting with add-ons disabled, but it didn't change anything. I do not have the Sort Places installed, so that was not the issue. To add a new bookmark, and create a new folder, the new folder comes up in blue ready for me to rename it, but it won't let me type any letters. Once in a while I can type one or two letter and that's it. This problem started with the new update. Every time there is a new Firefox or Thunderbird update I cringe, there are always time consuming problems to deal with. I need help with this as I can't save any bookmarks any longer. Thank you.

I just updated Firefox to 11.0, and now have this same problem. I followed the suggestion on restarting with add-ons disabled, but it didn't change anything. I do not have the Sort Places installed, so that was not the issue. To add a new bookmark, and create a new folder, the new folder comes up in blue ready for me to rename it, but it won't let me type any letters. Once in a while I can type one or two letter and that's it. This problem started with the new update. Every time there is a new Firefox or Thunderbird update I cringe, there are always time consuming problems to deal with. I need help with this as I can't save any bookmarks any longer. Thank you.
cor-el
  • Top 10 Contributor
  • Moderator
17413 solutions 157295 answers

Helpful Reply

Are you using Firefox Sync?

If you do then Sync maybe interfering and trying to access the sync server too quickly.

Are you using Firefox Sync? If you do then Sync maybe interfering and trying to access the sync server too quickly.
mimi123 0 solutions 5 answers

Helpful Reply

You hit it on the nail, bravo!! I never would have thought to look there. I unlinked this computer and now it works. Sigh of relief. So now if I want to sync this desktop with my laptop, I have to turn the sync option off every time I need to bookmark something? Or do you have any suggestions as to how to deal with this? I thought I had the sync option enabled a long time ago and didn't have the bookmarks problem until I did the firefox update...

You hit it on the nail, bravo!! I never would have thought to look there. I unlinked this computer and now it works. Sigh of relief. So now if I want to sync this desktop with my laptop, I have to turn the sync option off every time I need to bookmark something? Or do you have any suggestions as to how to deal with this? I thought I had the sync option enabled a long time ago and didn't have the bookmarks problem until I did the firefox update...
cor-el
  • Top 10 Contributor
  • Moderator
17413 solutions 157295 answers

You're welcome

You can try to paste the name from the clipboard.
I'm not sure if there is a simple solution possible as sync should only update after some idle time.

You're welcome You can try to paste the name from the clipboard.<br /> I'm not sure if there is a simple solution possible as sync should only update after some idle time.
mimi123 0 solutions 5 answers

OK. From what I can read about Sync there is no option to delay the sync operation to allow more idle time. That's a pity and maybe something the Mozilla developers may want to work on as it appears I am not the only one having this problem. Thanks again, I'll live without sync for the benefit of bookmarking...!

OK. From what I can read about Sync there is no option to delay the sync operation to allow more idle time. That's a pity and maybe something the Mozilla developers may want to work on as it appears I am not the only one having this problem. Thanks again, I'll live without sync for the benefit of bookmarking...!
cor-el
  • Top 10 Contributor
  • Moderator
17413 solutions 157295 answers

In case you want to backup your bookmarks, see:

In case you want to backup your bookmarks, see: *http://kb.mozillazine.org/Backing_up_and_restoring_bookmarks_-_Firefox

Question owner

You could always use Xmarks to sync the bookmarks.

Just remember to disable Xmarks if you ever activate FireFox sync again! I made that mistake once. Oh, the humanity....

You could always use Xmarks to sync the bookmarks. Just remember to disable Xmarks if you ever activate FireFox sync again! I made that mistake once. Oh, the humanity....
MordecaiWalfish 0 solutions 1 answers

cor-el has presented the underlying culprit here.

I had just installed Sync for the first time ever today and was adding a bookmark folder only to have this *VERY* annoying cut-off prevent me from naming the folder.

This is obviously a flaw in the way Sync and Bookmarks work and I hope it gets sorted out soon!

Thanks for the help guys!

cor-el has presented the underlying culprit here. I had just installed Sync for the first time ever today and was adding a bookmark folder only to have this *VERY* annoying cut-off prevent me from naming the folder. This is obviously a flaw in the way Sync and Bookmarks work and I hope it gets sorted out soon! Thanks for the help guys!
mimi123 0 solutions 5 answers

I miss not being able to use the Thunderbird Sync, between my laptop and desktop. I was hoping by now they would have fixed the delay issue, so you can use sync and also bookmark sites... so, still waiting....

I miss not being able to use the Thunderbird Sync, between my laptop and desktop. I was hoping by now they would have fixed the delay issue, so you can use sync and also bookmark sites... so, still waiting....