X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

When firefox crashes I am no longer given the session restore option so I lose all of my tabs, it is extremely frustrating!

Posted

I am not talking about the "save and quit" option. I mean when the mozilla crashes it no longer gives me the option to restore my session, instead a page comes up that says new tab, its not even the google/mozilla homepage. Is there a way to fix this. I have not changed any of my settings.

Chosen solution

The settings were wrong by default with the new version because I never made any changes to my personal settings(the new version just changed the session restore I believe). But this is how I solved the problem(I haven't have any crashes but after an auto restart for updates I did have the option to restore tabs again). I will bold the part that resolved the issue:

"For other session restore problems, you may need to make corrections to your Firefox settings:

   At the top of the Firefox window, click on the Firefox button (Tools menu in Windows XP) and then click Options
   Select the Privacy panel and make sure Firefox will: is set to either Remember history or Use custom settings for history.
       If Firefox will: is set to Use custom settings for history then make sure that Permanent Private Browsing mode is not selected.
       If Firefox will: is set to Use custom settings for history and Clear history when Firefox closes is selected, then click the Settings button and make sure that Browsing History is not selected.
   Click OK to close the Options window"

I think the problem was I have always had browsing history selected which doesn't work like it used to with the new version.

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.1 r102
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_30 for Mozilla browsers
  • GEPlugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 4.0.60831.0
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.5"
  • Provides additional functionality on Facebook. See our web site for details.
  • Yahoo Application State Plugin version 1.0.0.7
  • RealJukebox Netscape Plugin
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.69
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:10.0.1) Gecko/20100101 Firefox/10.0.1

More Information

Hasan 477 solutions 5600 answers

Perform the suggestions mentioned in the following article:

Check and tell if its working.


The next time your Firefox Crash, perform the suggestions mentioned in the following article:

Modified by Hasan

Snazi 0 solutions 1 answers

Please download flash player from abobe website using firefox brower to get compatible package. The software will download, close firefox then install. You should be ok. Hope this helps you.

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

You can use "History > Restore Previous Session" to get the previous session at any time.
Click the orange/gray Firefox button to see the History item if the menu bar is hidden.
There is also a "Restore Previous Session" button on the default about:home Home page.

Using the "Show my windows and tabs from last time" setting is a more reliable way to restore session data.

  • Tools > Options > General > Startup: "When Firefox Starts": "Show my windows and tabs from last time"

Chosen Solution

The settings were wrong by default with the new version because I never made any changes to my personal settings(the new version just changed the session restore I believe). But this is how I solved the problem(I haven't have any crashes but after an auto restart for updates I did have the option to restore tabs again). I will bold the part that resolved the issue:

"For other session restore problems, you may need to make corrections to your Firefox settings:

   At the top of the Firefox window, click on the Firefox button (Tools menu in Windows XP) and then click Options
   Select the Privacy panel and make sure Firefox will: is set to either Remember history or Use custom settings for history.
       If Firefox will: is set to Use custom settings for history then make sure that Permanent Private Browsing mode is not selected.
       If Firefox will: is set to Use custom settings for history and Clear history when Firefox closes is selected, then click the Settings button and make sure that Browsing History is not selected.
   Click OK to close the Options window"

I think the problem was I have always had browsing history selected which doesn't work like it used to with the new version.