X
Tap here to go to the mobile version of the site.

Support Forum

Session restore showing no previous tabs

Posted

Today I tried to restore a Firefox session after a crash and the Session Restore page came up with the restore session button greyed out and the list of tabs to restore is empty.

There is also no option to restore the previous session in the settings drop-down menu.

The next thing I did was check the Mozilla Support forums and found some helpful advice: https://support.mozilla.org/en-US/questions/1204253 https://support.mozilla.org/en-US/questions/1216918 https://support.mozilla.org/en-US/questions/1224948


Based on this advice I went to "sessionstore-backups" in \Users\your-user-name\AppData\Roaming\Mozilla\Firefox\Profiles\ and backed up the files I found there. I even used ShadowExplorer to find some earlier copies of said files and copied those as well.

So -with Firefox closed- I copied an older recovery.jsonlz4 and replaced the new one with it.

Sadly, when I then open Firefox, the same thing happens. Recovery page with no option to recover, 0 tabs present.


Am I doing something wrong?


P.S. I should add that I simply DO NOT HAVE a restore session option in my drop-down menu. See attached images.

P.P.S. No longer having the option to get the "ask to save and quit" notification when exiting the browser is a travesty. That option should be brought back ASAP. Both for the extra warning before quitting, and to give you the ability to choose whether or not to discard certain tabs.

Today I tried to restore a Firefox session after a crash and the Session Restore page came up with the restore session button greyed out and the list of tabs to restore is empty. There is also no option to restore the previous session in the settings drop-down menu. The next thing I did was check the Mozilla Support forums and found some helpful advice: https://support.mozilla.org/en-US/questions/1204253 https://support.mozilla.org/en-US/questions/1216918 https://support.mozilla.org/en-US/questions/1224948 Based on this advice I went to "sessionstore-backups" in \Users\your-user-name\AppData\Roaming\Mozilla\Firefox\Profiles\ and backed up the files I found there. I even used ShadowExplorer to find some earlier copies of said files and copied those as well. So -with Firefox closed- I copied an older recovery.jsonlz4 and replaced the new one with it. Sadly, when I then open Firefox, the same thing happens. Recovery page with no option to recover, 0 tabs present. Am I doing something wrong? P.S. I should add that I simply DO NOT HAVE a restore session option in my drop-down menu. See attached images. P.P.S. No longer having the option to get the "ask to save and quit" notification when exiting the browser is a travesty. That option should be brought back ASAP. Both for the extra warning before quitting, and to give you the ability to choose whether or not to discard certain tabs.
Attached screenshots

Modified by Hasssun

Chosen solution

You need to replace the sessionstore.jsonlz4 in profile folder with the recovery.jsonlz4 file (i.e. rename the file) to make Firefox use this sessionstore file.

  • History -> Restore Previous Session
  • History -> Recently Closed Tabs/Windows

Use one of these to close Firefox if you are currently doing that by clicking the close X on the Firefox title bar.

  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit
Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

More Information

WestEnd
  • Top 25 Contributor
60 solutions 5376 answers

That would mean it didn't cache the sessions. I know because when I force restart my computer I can restart firefox and it ask to restore sessions. So your going to have to check your settings to find out what is checked to save the history or cache.

That would mean it didn't cache the sessions. I know because when I force restart my computer I can restart firefox and it ask to restore sessions. So your going to have to check your settings to find out what is checked to save the history or cache.

Question owner

WestEnd said

That would mean it didn't cache the sessions. I know because when I force restart my computer I can restart firefox and it ask to restore sessions. So your going to have to check your settings to find out what is checked to save the history or cache.

Which settings do I have to check?

''WestEnd [[#answer-1189325|said]]'' <blockquote> That would mean it didn't cache the sessions. I know because when I force restart my computer I can restart firefox and it ask to restore sessions. So your going to have to check your settings to find out what is checked to save the history or cache. </blockquote> Which settings do I have to check?
McCoy
  • Top 10 Contributor
521 solutions 4895 answers

Hello Hasssun,

Would you please make sure that you're not in permanent Private Browsing mode :

3-bar menu (or 'Tools') => Options => Privacy & Security => under 'History' => Firefox will : choose : 'Use custom settings for history' Uncheck : 'Always use private browsing mode'

Hello Hasssun, Would you please make sure that you're not in permanent Private Browsing mode : 3-bar menu (or 'Tools') => Options => Privacy & Security => under 'History' => Firefox will : choose : 'Use custom settings for history' Uncheck : 'Always use private browsing mode'
cor-el
  • Top 10 Contributor
  • Moderator
17421 solutions 157409 answers

Chosen Solution

You need to replace the sessionstore.jsonlz4 in profile folder with the recovery.jsonlz4 file (i.e. rename the file) to make Firefox use this sessionstore file.

  • History -> Restore Previous Session
  • History -> Recently Closed Tabs/Windows

Use one of these to close Firefox if you are currently doing that by clicking the close X on the Firefox title bar.

  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit
You need to replace the sessionstore.jsonlz4 in profile folder with the recovery.jsonlz4 file (i.e. rename the file) to make Firefox use this sessionstore file. *History -> Restore Previous Session *History -> Recently Closed Tabs/Windows Use one of these to close Firefox if you are currently doing that by clicking the close X on the Firefox title bar. *"3-bar" menu button -> Exit (Power button) *Windows: File -> Exit *Mac: Firefox -> Quit Firefox *Linux: File -> Quit

Question owner

McCoy said

Hello Hasssun, Would you please make sure that you're not in permanent Private Browsing mode : 3-bar menu (or 'Tools') => Options => Privacy & Security => under 'History' => Firefox will : choose : 'Use custom settings for history' Uncheck : 'Always use private browsing mode'

The setting says "Firefox will Remember history"


cor-el said

You need to replace the sessionstore.jsonlz4 in profile folder with the recovery.jsonlz4 file (i.e. rename the file) to make Firefox use this sessionstore file.

Ah so that's what I was doing wrong!

Thank you very much.

''McCoy [[#answer-1189370|said]]'' <blockquote> Hello Hasssun, Would you please make sure that you're not in permanent Private Browsing mode : 3-bar menu (or 'Tools') => Options => Privacy & Security => under 'History' => Firefox will : choose : 'Use custom settings for history' Uncheck : 'Always use private browsing mode' </blockquote> The setting says "Firefox will Remember history" ''cor-el [[#answer-1189391|said]]'' <blockquote> You need to replace the sessionstore.jsonlz4 in profile folder with the recovery.jsonlz4 file (i.e. rename the file) to make Firefox use this sessionstore file.</blockquote> Ah so that's what I was doing wrong! Thank you very much.
McCoy
  • Top 10 Contributor
521 solutions 4895 answers

Hasssun said

The setting says "Firefox will Remember history"

When you click on the little black arrow next to "Remember history" you will get a dropdown where you can choose "Use custom settings for history" .......

(most people don't know that)

''Hasssun [[#answer-1189453|said]]'' <blockquote> The setting says "Firefox will Remember history" </blockquote> When you click on the little black arrow next to "Remember history" you will get a dropdown where you can choose "Use custom settings for history" ....... (most people don't know that)

Question owner

Good to know.

Good to know.