X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

new tab shows history

Posted

This has only just started to happen every time I open a new tab I get boxes coming up showing all my history I can click in the corner and it all goes away and leaves a little box but i never had this b4.

B 4 this happened i would open a new tab and it would be all white how can I get it back this way ?

Chosen solution

Hi,

Please try right-clicking and Reset for the preferences browser.newtabpage.enabled and browser.newtab.url in about:config.

about:config

about:config Entries

Read this answer in context 6

Additional System Details

Installed Plug-ins

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_30 for Mozilla browsers
  • 5.0.61118.0
  • Shockwave Flash 11.1 r102
  • iTunes Detector Plug-in
  • NPWLPG

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a2) Gecko/20120210 Firefox/12.0a2

More Information

Vivek 310 solutions 2084 answers

Chosen Solution

Hi,

Please try right-clicking and Reset for the preferences browser.newtabpage.enabled and browser.newtab.url in about:config.

about:config

about:config Entries

Question owner

Thanks so much I have changed it to google when is opens a new tab. Even better than b 4 thanks

Modified by Katfish69uk

Vivek 310 solutions 2084 answers

You are welcome :)

evete 0 solutions 2 answers

Please where on earth is the preference tab to right click on? I have looked on Firefox homepage, every tab of the options and i just can't find anything called preference.

Many thanks

Evete

cor-el
  • Top 10 Contributor
  • Moderator
10758 solutions 96834 answers

Helpful Reply

Type about:config in the location (address) bar to open the about:config page and press the "Enter" key, just like you type the URL of a website to open a website.
If you see a warning then you can confirm that you want to access the about:config page.

  • Use the Filter bar at the top of the about:config page to locate a preference more easily.
  • Preferences that have been modified show as bold (user set).
  • Preferences can be reset to the default via the right-click context menu if they are user set
  • Preferences can be changed via the right-click context menu: Modify (String or Integer) or Toggle (Boolean) or by double-clicking the line with the pref
  • Preferences can be created via the right-click context menu: New -> String, Integer, Boolean
jscher2000
  • Top 10 Contributor
2365 solutions 20925 answers

The about:config preferences editor is opened by typing about:config in the url bar and pressing Enter.

The steps to return to a completely blank new tab are listed in this article:

New Tab Page > How do I turn the new tab page off?.

evete 0 solutions 2 answers

Thank you for your help but I'm still not getting it to work. I have followed intructions down to right clicking on browser.newtabpage.enabled and I selected reset, but this just resulted in the tab view being reactivated again, when i tested it.

I'm not a techie and I'm not sure what modify string or boolean means. I tried right clicking on the default, boolean and true headings for something to switch off, but i wasn't sure what to look for.

Many thanks for your advice

Evete

jscher2000
  • Top 10 Contributor
2365 solutions 20925 answers

Helpful Reply

Hi evete, what do you want to see displayed when you open a new tab? Here is what I think you can do with the browser.newtab.url preference:

(1) Page thumbnails (default)

browser.newtab.url = about:newtab

(2) Blank tab

browser.newtab.url = about:blank

(3) Built-in Firefox home page

browser.newtab.url = about:home

(4) Some other page

browser.newtab.url = URL to the page

Note: browser.newtab.url not browser.newtab.enabled

Modified by jscher2000

polalor 1 solutions 18 answers

Hi,

    I read all the answers but thought your's most helpful.

Previously, when I opened a new tab in FF Black Lava; the Lava Sphere would appear. All right and neat. I updated java today and found instead the white blocks with tab history. Very messy.

    To answer your question: I'd like to have the Java Sphere return. What number above is this? Thank you in advance. I have screenshots if they would help.
polalor 1 solutions 18 answers

Now it's getting weird. As you can see above there are two different typographies.

polalor 1 solutions 18 answers

I tried a restore point and was cautioned that along with the recent Java updates would be deleted but FF update and FF maintenance may be deleted and may not work properly.. FYI

jscher2000
  • Top 10 Contributor
2365 solutions 20925 answers

Hi polalor, if you start a line with a space on this site, it turns the line into monospace text.

I don't recommend using Windows' System Restore feature to address Firefox problems because Windows only tracks a limited part of your Firefox settings.

Are you using the LavaFox theme? https://addons.mozilla.org/en-US/firefox/addon/lavafox-v1/

If you only want the sphere and not the thumbnails, try switching the setting back to "about:blank" and see whether that works. It's a fairly quick change in the about:config preferences editor. The steps are listed in this article:

New Tab Page > How do I turn the new tab page off?.

polalor 1 solutions 18 answers

Thanks I at least got rid of the history RE: about:config: Warning appeared stating "May violate warranty." PS: I do not have an icon in upper right. Attaching a screen shot, Thanks again.

jscher2000
  • Top 10 Contributor
2365 solutions 20925 answers

Yes, there is a warning when you go into about:config since it's possible to change some things in a way that prevents Firefox from working correctly.

When you refer to the icon in the upper right, could that the little 9-box grid on a new tab page (Ctrl+t)? Not sure exactly what that was referring to.

emthornton 0 solutions 1 answers

This worked, but there needs to be a much easier way to turn this off, in the preferences. This is invasive as hell, whether at work or at home. Boo.

polalor 1 solutions 18 answers

Thank you jscher! Huzzah!