X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

400 Bad Request Request Header Or Cookie Too Large nginx - What does this error mean?

Posted

On CNN.com i get this error when trying to view video or when clicking on one of their tabs:

400 Bad Request Request Header Or Cookie Too Large nginx

Chosen solution

That issue can be caused by corrupted cookies.

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

See also:

Read this answer in context 22

Additional System Details

Sites Affected

//http://www.cnn.com/LIVING/

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.2
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 11.1 r102
  • iTunes Detector Plug-in
  • AmazonMP3DownloaderPlugin 1.0.14
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_29 for Mozilla browsers
  • 4.0.60831.0
  • Picasa plugin
  • NPWLPG

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0) Gecko/20100101 Firefox/10.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10752 solutions 96760 answers

Chosen Solution

That issue can be caused by corrupted cookies.

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

See also:

Question owner

Worked perfectly! Thanks, cor-el

Kohiro 0 solutions 1 answers

Thank you very much cor-el. You just save me lots of time looking for the problem myself or deleting FF completely...

sdscreenwriter 0 solutions 1 answers

Under Tools, Firefox has no entry called "Options"...so this solution doesn't work...

cor-el
  • Top 10 Contributor
  • Moderator
10752 solutions 96760 answers

Instead of Tools > Options use:

  • Mac: Firefox > Preferences
  • Linux: Edit > Preferences
  • Windows: Firefox > Options

Press F10 if the menu bar is hidden on Windows and Linux or use "Firefox > Options/Preferences"