X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Google search result links won't load (not a re-direct problem)

Posted

Simple problem: 1. Enter a term for Google to search for (either using the installed Google toolbar or via their landing page). 2. Results are returned correctly. 3. However, returned links will not open up in the same search result tab, or within a new tab or new window. 4. Selecting the link in the search results tab does nothing. Firefox appears to make a momentary load attempt before remaining at the same location. 5. Launching the link in a new tab/window returns a long-string Google prefix-based (i.e. www.google...) address in the navigation window of a blank tab/window. 6. Web addresses returned from the search can be copied and pasted into new tabs/windows to load without issue. Normal Google search process using this query works from IE every time.

Test: "Energizer Bunny" Returned Link: www.energizer.com/energizer-bunny/pages/bunny-center.aspx Failed Address: http://www.google.ca/url?sa=t&rct=j&q=energizer%20bunny&source=web&cd=1&ved=0CDYQFjAA&url=http%3A%2F%2Fwww.energizer.com%2Fenergizer-bunny%2Fpages%2Fbunny-center.aspx&ei=ruYyT47cIYHjiALj69XGCg&usg=AFQjCNHg-eabuCQBx6Bv36V9F4pN4tQRYA&cad=rja

Be advised this is not the Google redirect problem that many users have encountered but something different.

Chosen solution

John99's suggestion above that the cause of the problem is a Google update issue I think is correct. The discussion link provided: https://support.mozilla.org/forums/contributors/708153 indicated that Mozilla was working with Google and that a rollback would be enacted.

Well as far as I can tell that has been done because the Google search feature is working again (as of 4PM MDT). I tried with some first-time queries and they worked as advertised. Full functionality restored.

(For the record, cookies were already enabled on my machine but I did clear them and the cache as per the first reply - that did not work. No other solves above did I implement. So as far as I'm concerned it was a 'Google problem', it was a 'Google fix'.)

Hope everyone else affected now has the same experience. Thanks to those who offered their smarts.

Read this answer in context 2

Additional System Details

Sites Affected

http://www.google.ca

Installed Plug-ins

  • Google Update
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.2
  • Shockwave Flash 11.1 r102
  • iTunes Detector Plug-in
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_29 for Mozilla browsers
  • PopCap Games Plugin
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Npdsplay dll
  • np-mswmp
  • Office Plugin for Netscape Navigator

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:9.0.1) Gecko/20100101 Firefox/9.0.1

More Information

Windows XP SP3
Firefox 9.0.1

Hasan 477 solutions 5600 answers

The link http://www.energizer.com/energizer-bunny/pages/bunny-center.aspx is opening fine on my system using Win Xp & Firefox 10.

-> Update Firefox to the latest version 10

Perform the suggestions mentioned in the following articles:

Check and tell if its working.

Modified by Hasan

ClaytonBerg 0 solutions 1 answers

Yeah, that didn't work. No theme or extension has been changed to cause this failure.

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8010 answers

Try enabling cookies. (And presumably checking nothing is blocking the action of saving cookies)

This may well be due to a Change that google has made, that is under investigation at present, (from discussion /forums/contributors/708153

Sometime last night, Google updated its search results page. We are seeing some reports that search results when clicked take you to a blank interstitial page rather than the final result.
The issue is that if you don't have cookies enabled or working (blocked by extensions/privacy settings), the links don't work. The only workaround is to enable cookies, use a different search engine or use Chrome (which somehow works even with cookies disabled).   )

Update
Google expecting a fix within a few hours

Modified by John99

Chosen Solution

John99's suggestion above that the cause of the problem is a Google update issue I think is correct. The discussion link provided: https://support.mozilla.org/forums/contributors/708153 indicated that Mozilla was working with Google and that a rollback would be enacted.

Well as far as I can tell that has been done because the Google search feature is working again (as of 4PM MDT). I tried with some first-time queries and they worked as advertised. Full functionality restored.

(For the record, cookies were already enabled on my machine but I did clear them and the cache as per the first reply - that did not work. No other solves above did I implement. So as far as I'm concerned it was a 'Google problem', it was a 'Google fix'.)

Hope everyone else affected now has the same experience. Thanks to those who offered their smarts.

cor-el
  • Top 10 Contributor
  • Moderator
10747 solutions 96719 answers

From comment 11 in bug 725634:

Google has pushed a fix for this issue. Please test and let us know if there are any more problems.
Axis 2 solutions 46 answers

Hi all--

I posted something similar last night as well as marking "I have this problem too" for this thread. I did several things, so too many variables on my end to say if anything I did "fixed" the problem, the emails I sent through chrome and directly on the search page with Firefox, or Google found out the problem; but as of right now I can easily use Google again without cookies enabled.

(I did find that something had got stuck on my end where even when I closed Firefox it was still running under "Processes" in the task manager. I stopped that and restarted and around that time Google "worked" again without cookies. I had also noticed that I could search without cookies in "Private Browsing" mode. Like I said above, too many variables all at once.)

End result, this "disturbance in the force" has ended for now. Do No Evil ;-)

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8010 answers

Yes the "disturbance", changed Google backed out some code changes.

Basically the problem does not now exist.

(So if anyone has a problem it is a different problem and it would be best to start your own new thread by asking a question )

j3pflynn 0 solutions 4 answers

For me this problem turned out to be related to an add-on/plugin. I believe it was NoScript that was messing things up. Once I disabled it and re-enabled it it showed the usual NoScript homepage you see after an update. Then the google search results worked fine with all my extensions/plug ins enabled.