X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 10 does not prompt for saving passwords

Posted

Even though the setting to save passwords is checked and I am not in private browsing mode the "pop-up" prompt to save passwords does not appear anymore. Some sites do not allow this function however, it does not appear on any site (sites that work with a firefox 10 on a different computer and also chrome on the same computer).

Even though the setting to save passwords is checked and I am not in private browsing mode the "pop-up" prompt to save passwords does not appear anymore. Some sites do not allow this function however, it does not appear on any site (sites that work with a firefox 10 on a different computer and also chrome on the same computer).

Chosen solution

You can also try disabling Use hardware acceleration when possible in Tools (Alt + T) > Options > Advanced > General.

Options > Advanced

Tools > Options

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_30 for Mozilla browsers
  • Shockwave Flash 11.1 r102
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.2
  • npFFApi
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • 4.0.60831.0
  • Enables the interaction of Mathematica content with the latest installed version of Mathematica.
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0) Gecko/20100101 Firefox/10.0

More Information

I bought a new 64bit Dell laptop and did a clean install. Running Windows 7 Enterprise.

Cheng Wang 34 solutions 435 answers

Firefox > Options

Select Security tab

Next to [ ] Remember passwords for sites, click Exceptions and make sure no exceptions show up.

Firefox > Options Select Security tab Next to [ ] Remember passwords for sites, click Exceptions and make sure no exceptions show up.

Question owner

No exceptions show up. I figured out that it works in safe mode, i.e. the pop-up will appear beneath the key icon. No further updates yet.

No exceptions show up. I figured out that it works in safe mode, i.e. the pop-up will appear beneath the key icon. No further updates yet.
Cheng Wang 34 solutions 435 answers

If it works in safe mode, it's possible one of your extensions is hijacking the password manager (usually security software -- possibly something that was bundled with your new machine).

Go through the extensions in Tools > Add-ons and disable them to figure out which it is.

If it works in safe mode, it's possible one of your extensions is hijacking the password manager (usually security software -- possibly something that was bundled with your new machine). Go through the extensions in Tools > Add-ons and disable them to figure out which it is.

Question owner

It is a clean install of firefox - so no add-ons installed. During the process, I have only installed Password editor, which did not affect the problem. I tried to disable all plug-ins in normal mode, also did not help.

It is a clean install of firefox - so no add-ons installed. During the process, I have only installed Password editor, which did not affect the problem. I tried to disable all plug-ins in normal mode, also did not help.
Cheng Wang 34 solutions 435 answers

Not quite what I asked. Often security software (such as Norton or Kaspersky) will install add-ons that you didn't explicitly approve.

Not quite what I asked. Often security software (such as Norton or Kaspersky) will install add-ons that you didn't explicitly approve.

Question owner

Nothing is in my add-on list at least. Not sure what you were asking exactly then if not that what I answered.

Nothing is in my add-on list at least. Not sure what you were asking exactly then if not that what I answered.
cor-el
  • Top 10 Contributor
  • Moderator
17421 solutions 157400 answers

Create a new profile as a test to check if your current profile is causing the problems.

See "Basic Troubleshooting: Make a new profile":

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.

If that new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.

See:

Create a new profile as a test to check if your current profile is causing the problems. See "Basic Troubleshooting: Make a new profile": *https://support.mozilla.org/kb/Basic+Troubleshooting#w_8-make-a-new-profile There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems. If that new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files. See: *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

Question owner

Thanks for the suggestion! I created a new profile and started firefox with the new profile - unfortunately also here the pop-up box is suppressed for some reason. As for the default profile, there is a key appearing next to the "go back" button but no question to save the password.

In the new profile, there was no extension installed (at least non visible in the list); however, several plug-ins. Again, disable all plug-ins does not help either.

I am running Avira and Zonealarm on this machine - I disabled realtime protection and switched off Zonealarm, but again, no luck. Maybe I should try to uninstall them, but actually I am running the same combination on my desktop computer (Avira, Zonealarm, and Firefox; also the same updated version of each program) and there it works just fine.

Thanks for the suggestion! I created a new profile and started firefox with the new profile - unfortunately also here the pop-up box is suppressed for some reason. As for the default profile, there is a key appearing next to the "go back" button but no question to save the password. In the new profile, there was no extension installed (at least non visible in the list); however, several plug-ins. Again, disable all plug-ins does not help either. I am running Avira and Zonealarm on this machine - I disabled realtime protection and switched off Zonealarm, but again, no luck. Maybe I should try to uninstall them, but actually I am running the same combination on my desktop computer (Avira, Zonealarm, and Firefox; also the same updated version of each program) and there it works just fine.

Modified by ulmeter

cor-el
  • Top 10 Contributor
  • Moderator
17421 solutions 157400 answers

ZoneAlarm installs a ForceField plugin (npFFApi), so you can try to disable that plugin.
ZoneAlarm ForceField is known to interfere with a lot of things in Firefox.
You can try to ask advice in the ZoneAlarm forum.

ZoneAlarm installs a ForceField plugin (npFFApi), so you can try to disable that plugin.<br /> ZoneAlarm ForceField is known to interfere with a lot of things in Firefox.<br /> You can try to ask advice in the ZoneAlarm forum.

Question owner

Again. I disabled all plug-ins and therefore also the npFFApi. This did not work either. Also I am running the same combination of programs (avira, zonealarm, and firefox) on my desktop computer with the plug-in. There it works just fine. Nevertheless, I am going through this cumbersome test and will uninstall zonealarm today. I'll keep you posted.

Again. I disabled all plug-ins and therefore also the npFFApi. This did not work either. Also I am running the same combination of programs (avira, zonealarm, and firefox) on my desktop computer with the plug-in. There it works just fine. Nevertheless, I am going through this cumbersome test and will uninstall zonealarm today. I'll keep you posted.

Question owner

I uninstalled Zonealarm and tried it - didn't work. Then I uninstalled Avira and Firefox and reinstalled a clean Firefox 10 (without having any firewall nor antirvirus installed) - still whenever I visit a site where passwords can be saved, the key symbol appears next to the history back button but the pop-up is simply missing...I think I have to switch to Chrome...

I uninstalled Zonealarm and tried it - didn't work. Then I uninstalled Avira and Firefox and reinstalled a clean Firefox 10 (without having any firewall nor antirvirus installed) - still whenever I visit a site where passwords can be saved, the key symbol appears next to the history back button but the pop-up is simply missing...I think I have to switch to Chrome...
Vivek 289 solutions 2084 answers

Chosen Solution

You can also try disabling Use hardware acceleration when possible in Tools (Alt + T) > Options > Advanced > General.

Options > Advanced

Tools > Options

You can also try disabling '''Use hardware acceleration when possible''' in '''Tools''' ('''Alt''' + '''T''') > '''Options''' > '''Advanced''' > '''General'''. [https://support.mozilla.org/en-US/kb/Options%20window%20-%20Advanced%20panel?as=u Options > Advanced] [https://support.mozilla.com/en-US/kb/Options%20window Tools > Options]

Modified by Vivek

Question owner

Thank you so much for this suggestion Vivek.Wilfred! That did the trick - my password pop-up is back!!! So bottom line, as I expected, it is neither zonealarm nor avira or AVG but simply an issue with a certain hardware driver. For all interested people who might have the same issue: I am running a Dell XPS 15 (L502). Thanks again to everyone who replied!

Thank you so much for this suggestion Vivek.Wilfred! That did the trick - my password pop-up is back!!! So bottom line, as I expected, it is neither zonealarm nor avira or AVG but simply an issue with a certain hardware driver. For all interested people who might have the same issue: I am running a Dell XPS 15 (L502). Thanks again to everyone who replied!
Vivek 289 solutions 2084 answers

Thank you very much for posting the helpful details. Another user also had reported a similar issue; in that case after updating the graphics card drivers.

Thank you very much for posting the helpful details. Another user also had reported a similar issue; in that case after updating the graphics card drivers.

Question owner

So updating is not always recommended, never change a running system!

So updating is not always recommended, never change a running system!

Modified by ulmeter