X
Tap here to go to the mobile version of the site.

Support Forum

I'm on a Mac. I can't make the text italics or underlined. How do I do that?

Posted

I'm on a Mac. I can't make the text italics or underlined. I haven't found anywhere to do that. What you show in blue above this message does not show up on my toolbar or anywhere else.

I'm on a Mac. I can't make the text italics or underlined. I haven't found anywhere to do that. What you show in blue above this message does not show up on my toolbar or anywhere else.

Chosen solution

Make sure that you allow pages to choose their colors and that you haven't enabled High Contrast in the Accessibility settings.

  • Firefox > Preferences > Content : Fonts & Colors > Colors : [X] "Allow pages to choose their own colors, instead of my selections above"

Make sure that you do not block JavaScript.

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.1 r102
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.3
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • 4.0.60531.0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:8.0.1) Gecko/20100101 Firefox/8.0.1

More Information

cor-el
  • Top 10 Contributor
  • Moderator
12322 solutions 114011 answers

Chosen Solution

Make sure that you allow pages to choose their colors and that you haven't enabled High Contrast in the Accessibility settings.

  • Firefox > Preferences > Content : Fonts & Colors > Colors : [X] "Allow pages to choose their own colors, instead of my selections above"

Make sure that you do not block JavaScript.

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

Make sure that you allow pages to choose their colors and that you haven't enabled High Contrast in the Accessibility settings. *Firefox > Preferences > Content : Fonts & Colors > Colors : [X] "Allow pages to choose their own colors, instead of my selections above" ---- Make sure that you do not block JavaScript. Start Firefox in <u>[[Safe Mode]]</u> to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes). *Don't make any changes on the Safe mode start window. *https://support.mozilla.org/kb/Safe+Mode

Question owner

thanks, but I don't care about the colors. I am trying to change the text to italics and underline.

thanks, but I don't care about the colors. I am trying to change the text to italics and underline.
cor-el
  • Top 10 Contributor
  • Moderator
12322 solutions 114011 answers

You may be hiding those buttons if settings are wrong or you have an extension that hide the toolbar or its icons.

You may be hiding those buttons if settings are wrong or you have an extension that hide the toolbar or its icons.

Question owner

Where do I look to check that?

Where do I look to check that?
cor-el
  • Top 10 Contributor
  • Moderator
12322 solutions 114011 answers

If buttons or other active elements appear when you hover them on a web page then they are obviously hidden and that shouldn't happen. That can happen if the button is only a (background) image and that image is hidden. Toolbars with the buttons on it may also be created via JavaScript.

If buttons or other active elements appear when you hover them on a web page then they are obviously hidden and that shouldn't happen. That can happen if the button is only a (background) image and that image is hidden. Toolbars with the buttons on it may also be created via JavaScript.

Question owner

Okay, but I don't know how to create it in Java Script.

Okay, but I don't know how to create it in Java Script.
cor-el
  • Top 10 Contributor
  • Moderator
12322 solutions 114011 answers

Such formatting choices should be part of the editor that is used to enter your text.

Are you talking about composing new mail or answering mail or writing messages on a forum?

Such formatting choices should be part of the editor that is used to enter your text. Are you talking about composing new mail or answering mail or writing messages on a forum?

Question owner

Composing any email. There is nowhere to choose i or b. It is very frustrating.

Composing any email. There is nowhere to choose i or b. It is very frustrating.
cor-el
  • Top 10 Contributor
  • Moderator
12322 solutions 114011 answers

Did you check the settings in my first answer and tried my suggestion about safe mode?

Did you check the settings in my first answer and tried my suggestion about safe mode?

Question owner

I started in safe mode, changed to default where you said, restarted Firefox and still no options for text. Was there something else I was supposed to do?

I started in safe mode, changed to default where you said, restarted Firefox and still no options for text. Was there something else I was supposed to do?
cor-el
  • Top 10 Contributor
  • Moderator
12322 solutions 114011 answers

Are you sure that the mail does support that feature on its text editor?

Did it work before, maybe with another Firefox version?

Are you sure that the mail does support that feature on its text editor? Did it work before, maybe with another Firefox version?

Modified by cor-el

Question owner

Have never worked in Firefox. I guess I don't have that feature. Thanks for all your help and the time you spent. I appreciate it.

Have never worked in Firefox. I guess I don't have that feature. Thanks for all your help and the time you spent. I appreciate it.
cor-el
  • Top 10 Contributor
  • Moderator
12322 solutions 114011 answers

You're welcome

You're welcome