X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How can I make Mozilla Firefox Start Page use Google search instead of Aol search?

Posted

A few months ago, the Mozilla Firefox Start Page suddenly started using Aol search instead of Google when I used the search bar. I can't remember whether I did anything to AIM or something when it happened, but on the navigation bar, my search engine is still Google... I really want to use Google instead of Aol search, and I don't want to change my home page?

Chosen solution

Change the about:home search engine back to Google.

Firefox button > Web Developer -> Scratchpad -
copy and paste this script into Scratchpad > then hit Execute > Run

 
javascript:{localStorage["search-engine"]="{\"name\":\"Google\",\"searchUrl\":\"http://www.google.com/search?q=_searchTerms_&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a\"}";void(0);}
 
Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.1 r102
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.5"
  • 4.0.60310.0
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.615
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • NPWLPG
  • npdnupdater2
  • npdnu

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1

More Information

the-edmeister
  • Top 10 Contributor
  • Moderator
3197 solutions 24401 answers

Chosen Solution

Change the about:home search engine back to Google.

Firefox button > Web Developer -> Scratchpad -
copy and paste this script into Scratchpad > then hit Execute > Run

 
javascript:{localStorage["search-engine"]="{\"name\":\"Google\",\"searchUrl\":\"http://www.google.com/search?q=_searchTerms_&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a\"}";void(0);}
 
cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96785 answers

You can also reset the browser.startup.homepage_override.mstone pref via the right-click context menu to the default on the about:config page and close and restart Firefox to restore the about:home page to its default.

  • Open the about:config page via the location bar
  • Type in the Filter bar: mstone
  • Right-click the browser.startup.homepage_override.mstone line and select: Reset
  • Close and restart Firefox
sydneyc1234 0 solutions 1 answers

This is what you could do because i had this problem: 1. Go to the upper left corner which says firefox and click it 2. When you get there look under add-ons and click options. 3. Right next to options would say options again. 4. Go to general then you will see home page. 5. Write the site you want it to ( http://www.google.com/ ) And then you got your main site.