Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can I download an older version of firefox ?

  • 2 replies
  • 2 have this problem
  • 9 views
  • Last reply by Lorraine33

more options

FAFSA application does not support my brouser version of safari and I do not want to try using an older version. FAFSA tech suggested downloading a firefox version between 3.5-4. Can I download an older version of firefox ? Will this strategy adversely affect my computer in any way? I do not have firefox installed on my computer

FAFSA application does not support my brouser version of safari and I do not want to try using an older version. FAFSA tech suggested downloading a firefox version between 3.5-4. Can I download an older version of firefox ? Will this strategy adversely affect my computer in any way? I do not have firefox installed on my computer

All Replies (2)

more options

The latest supported version(except 9.0.x) is 3.6.25 you can download from here:

http://www.mozilla.org/en-US/firefox/all-older.html

it is supported, so you do not have any problem


thank you

Please mark "Solved" the answer that really solve the problem, to help others with a similar problem.

more options

No luck. I still got an "unsupported browser" error message from FAFSA. I called them and they suggested that I may need firefox 3.5 (with no numbers following) or 3.6 (with no numbers following) or 4.o (with no numbers following) ... what do you suggest I try next?