Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I just need a step by step instruction as to how to upgrade to the next upgrade, ex: 4.0 NOT to the newest one, thank you.

more options

I cannot figure out where to go to upgrade to the next level when the desktop is saying that the level I am on will expire soon. Can I upgrade before it expires, to the next level NOT the newest one and how do I do it?

Chosen solution

Firefox 3.6 will probably be supported until mid-April 2012. Firefox 4, 5, 6, 7, & 8 aren't supported any longer, only 3.6.25 and 9.0.1.

Read this answer in context 👍 2

All Replies (2)

more options

Chosen Solution

Firefox 3.6 will probably be supported until mid-April 2012. Firefox 4, 5, 6, 7, & 8 aren't supported any longer, only 3.6.25 and 9.0.1.

more options

Thank You! especially for your prompt response!