X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why doesn't Firefox 9.01 work with Netflix streaming?

Posted

I watch shows and movies online via Netflix every day. As of yesterday, Firefox 9.0 was released, today the 9.0.1 update was released. When I try to watch anything on Netflix on Firefox 9.0.1 I get nothing but a blank screen, so I have to go back to 8.0.1 to watch them instead.

Additional System Details

Sites Affected

http://movies.netflix.com

Installed Plug-ins

  • 5.0.61118.0
  • Shockwave Flash 11.1 r102
  • Java Plug-In 2 for NPAPI Browsers
  • DivX VOD Helper Plug-in
  • DivX Web Player version 2.1.2.265
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:9.0.1) Gecko/20100101 Firefox/9.0.1

More Information

Question owner

Six days later, 22 other people have this problem. Instead of fixing the problem or even acknowledging it, Firefox refuses to let me continue 8.0.1 usage and replaces it with the DEFECTIVE 9.0.1. Thank you for forcing it down my throat, Mozilla. I'm leaving you forever and switching to Safari. Everybody sing, "For he's a jolly good fellow.."

Goodbye.

ahairston 0 solutions 1 answers

Folks --- the issue is the usual suspect: Microsoft Silverlight. This error is cross platform and browsers; thus it is an "error" from MS.

Keep the latest silverlight 5 update on your pc

For Win 7 64bit, go to C:\Program Files (x86)\Microsoft Silverlight\5.0.61118.0

then open Silverlight.Configuration application file -- not the extension file, but the app file.

then go to the Application Storage tab -- last one to the right delete the netflix file but make sure "allow application storage" box at bottom is checked

save changes and reload browsers

For other issues/platforms, check out this site:

go here for fixes: http://forums.silverlight.net/t/197653.aspx/1

Modified by ahairston

BrothertownBooks 0 solutions 2 answers

Helpful Reply

Well for us it is only happening on Firefox ... We cannot use Netflix Watch Instantly on Firefox but can on Safari, so it is not a Silverlight cross-browser problem, but a firefox problem. It seems netflix security program cannot recognize 9.1.

Cheng Wang
  • Administrator
  • Moderator
36 solutions 435 answers

Looking at your plugin information, you don't even have Silverlight installed/enabled in Firefox. Go to Tools > Add-ons and under plugins, see if you have Microsoft Silverlight

Cheng Wang
  • Administrator
  • Moderator
36 solutions 435 answers

Can you try restarting your mac (as in do a full shutdown from the apple menu). It's possible that you have traces of an old Silverlight version if you haven't restarted since the last update (Silverlight 5 went out mid-December but you may not have updated until recently).

Cheng Wang
  • Administrator
  • Moderator
36 solutions 435 answers

Ok, sorry, last question. What is your processor and graphics card?

Go to Apple>About this Mac, click more info.

Select hardware on the left pane and tell us your processor and speed.

Then select Graphics/Displays and provide the name of the video card(s).

--- I should clarify, I'm working with our QA team here at Mozilla as well as people from Microsoft who work on silverlight ... we've not had as much luck reproducing the problem but from all these reports, there's obviously something going on so we're trying to get the relevant details.

Modified by Cheng Wang

nleafgren 0 solutions 1 answers

I'm having the same issue as described above by others. I had, and still have the latest version of Silverlight installed (and also listed in my Plug-Ins section of Firefox 9).

Today was when I restarted Firefox, version 9 loaded, and Netflix no longer worked. Netflix still works on Safari currently, however, which indicates that there's something wrong with Firefox 9.

I've already restarted the browser and computer, and that hasn't solved the issue.

Michael Verdi
  • Administrator
  • Moderator
107 solutions 739 answers

Helpful Reply

I was able to make this work on my Mac with OS 10.6.8, Firefox 9.0.1 and the latest Silverlight plugin (5) by running Firefox in 32-bit mode. To do that:

  1. Quit Firefox
  2. In the Finder, open the Applications folder and locate Firefox.
  3. Click once on Firefox to select it and the press command + I on the keyboard. The Firefox info window will open.
  4. In the general section, check the box next to Open in 32-bit mode
  5. Then close the window and restart Firefox.
Cheng Wang
  • Administrator
  • Moderator
36 solutions 435 answers

There's now a workaround (for Mac 10.6 users) in Firefox 10 beta ... you can download that here: http://www.mozilla.org/en-US/firefox/channel/

alizrin 0 solutions 1 answers

Verdi you are a STAR! Your steps worked perfectly for me. I can't thank you enough for taking the time to spell out the actual steps, instead of just placing a link to some user group (like many people do). Thanks again, Lisa

nickjr4 0 solutions 1 answers

Check to make sure you have the latest MS Silverlight in your plug-ins. In open Firefox browser - Tools > Add-Ins > Plug-Ins

If not, download latest Silverlight (5.0.61118.0 at the time of this writing) http://www.microsoft.com/silverlight/

That was the problem in my case.