X
Tap here to go to the mobile version of the site.

Support Forum

How do I stop Firefox from caching pages?

Posted

Going to a news or weather site and seeing the news or weather from 3 days ago is ridiculous. I erased all history, I set private browsing, told Firefox to not remember history, all in vain. It still displays the old content until I refresh.

Going to a news or weather site and seeing the news or weather from 3 days ago is ridiculous. I erased all history, I set private browsing, told Firefox to not remember history, all in vain. It still displays the old content until I refresh.

Chosen solution

type in the address bar about:config

then press the button i'l be careful i promise

then type in the bar browser.cache.disk.enable

then double click on it, to make it false

exit firefox and restart-it.

do the same with browser.cache.memory.enable


if you want to read more:

http://kb.mozillazine.org/Browser.cache.disk.enable

http://kb.mozillazine.org/Browser.cache.memory.enable


thank you

Please mark "Solved" the answer that really solve the problem, to help others with a similar problem.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 10.3 r181
  • iTunes Detector Plug-in
  • 4.0.60531.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.0"
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_20 for Mozilla browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Npdsplay dll

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:8.0) Gecko/20100101 Firefox/8.0

More Information

ideato 893 solutions 6250 answers

Chosen Solution

type in the address bar about:config

then press the button i'l be careful i promise

then type in the bar browser.cache.disk.enable

then double click on it, to make it false

exit firefox and restart-it.

do the same with browser.cache.memory.enable


if you want to read more:

http://kb.mozillazine.org/Browser.cache.disk.enable

http://kb.mozillazine.org/Browser.cache.memory.enable


thank you

Please mark "Solved" the answer that really solve the problem, to help others with a similar problem.

type in the address bar '''about:config''' then press the button '''i'l be careful i promise ''' then type in the bar '''browser.cache.disk.enable''' then '''double click on it''', to make it '''false''' exit firefox and restart-it. do the same with '''browser.cache.memory.enable''' if you want to read more: http://kb.mozillazine.org/Browser.cache.disk.enable http://kb.mozillazine.org/Browser.cache.memory.enable thank you Please mark "Solved" the answer that really solve the problem, to help others with a similar problem.

Question owner

Awesome! Thank you ideato

Awesome! Thank you ideato

Question owner

Well, the solution turned out to be only temporary. Today is Friday, I opened the browser, went to http://www.reuters.com/news/world and what I see are the news from Wednesday. I refresh (F5) get the same thing. Only when I pick World Home from the Reuters menu it shows the updated page.

So: if the caching is disabled for both memory and disk (I just verified these settings with about:config and they are both false) where is the old content coming from? Could my company proxy have it's own caching mechanism? Not likely, if I use IE the fresh content is displayed. I'm lost...

Well, the solution turned out to be only temporary. Today is Friday, I opened the browser, went to http://www.reuters.com/news/world and what I see are the news from Wednesday. I refresh (F5) get the same thing. Only when I pick World Home from the Reuters menu it shows the updated page. So: if the caching is disabled for both memory and disk (I just verified these settings with about:config and they are both false) where is the old content coming from? Could my company proxy have it's own caching mechanism? Not likely, if I use IE the fresh content is displayed. I'm lost...
cor-el
  • Top 10 Contributor
  • Moderator
17205 solutions 155465 answers

Helpful Reply

No need to disable the disk cache and the memory cache as that will have performance issues.

You can set the pref browser.cache.check_doc_frequency to 1 on the about:config page.
See:

That won't work if you use session restore to reopen tabs on a next start.
In that case you need to clear the browser cache when you close Firefox.

  • Tools > Options > Privacy: History: [X] Clear history when Firefox closes > Settings
No need to disable the disk cache and the memory cache as that will have performance issues. You can set the pref <b>browser.cache.check_doc_frequency</b> to <i>1</i> on the <b>about:config</b> page.<br /> See: *http://kb.mozillazine.org/browser.cache.check_doc_frequency *http://kb.mozillazine.org/about:config That won't work if you use session restore to reopen tabs on a next start.<br /> In that case you need to clear the browser cache when you close Firefox. *Tools > Options > Privacy: History: [X] Clear history when Firefox closes > Settings *https://support.mozilla.com/kb/Clear+Recent+History