Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

my username and password are saved on my webmail site. How do i remove them so they don't pop up when I go to the site?

  • 2 replies
  • 16 have this problem
  • 248 views
  • Last reply by anneri

more options

my username and password are saved on my webmail site. How do i remove them so they don't pop up when I go to the site? I use cox.net webmail. Cox tell me it's a firefox issue. So, here I am. Can you help?

Chosen solution

Hey anneri

Go to tools->options and under the Security tab click on Saved passwords. This will give you a list of sites that you have saved a password for. Just find your site and delete that entry.

There is a lot of useful information in this article about the Firefox Password Manager. It should answer any other questions you might have.

You can also remove the cookies from that site to make the site forget you if you've created a remember me cookie.

  • Tools > Options > Privacy > Cookies: "Show Cookies"

Hopefully this helps!

Read this answer in context 👍 3

All Replies (2)

more options

Chosen Solution

Hey anneri

Go to tools->options and under the Security tab click on Saved passwords. This will give you a list of sites that you have saved a password for. Just find your site and delete that entry.

There is a lot of useful information in this article about the Firefox Password Manager. It should answer any other questions you might have.

You can also remove the cookies from that site to make the site forget you if you've created a remember me cookie.

  • Tools > Options > Privacy > Cookies: "Show Cookies"

Hopefully this helps!

more options

Thanks so much, Matt G. Of course it worked instantly! Anne