X
Tap here to go to the mobile version of the site.

Support Forum

How do I download a previous version of firefox for mac osx 10.5.8 (leopard)?

Posted

How do I download a previous version of firefox for mac osx 10.5.8 (leopard)?

How do I download a previous version of firefox for mac osx 10.5.8 (leopard)?

Chosen solution

Beginning with Firefox 4, Macs must have an Intel x86 processor (which you do NOT have; yours is a PPC Mac) and OSX 10.5 or higher

The good news is that Firefox 3.6.24 still supports OSX 10.4 and Macs with the PPC Mac architecture. The bad news is that support for the Firefox 3.6.x series is likely to end in the first quarter of 2012.

You can try the third-party product TenFourFox that supports PPC Macs. Firefox 8 version of TenFourFox is available. The product is based on Firefox released versions. All support is provided by the developer, not by this site:


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.

Read this answer in context 4

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; PPC Mac OS X 10_5_8) AppleWebKit/534.50.2 (KHTML, like Gecko) Version/5.0.6 Safari/533.22.3

More Information

SafeBrowser 543 solutions 2390 answers

Chosen Solution

Beginning with Firefox 4, Macs must have an Intel x86 processor (which you do NOT have; yours is a PPC Mac) and OSX 10.5 or higher

The good news is that Firefox 3.6.24 still supports OSX 10.4 and Macs with the PPC Mac architecture. The bad news is that support for the Firefox 3.6.x series is likely to end in the first quarter of 2012.

You can try the third-party product TenFourFox that supports PPC Macs. Firefox 8 version of TenFourFox is available. The product is based on Firefox released versions. All support is provided by the developer, not by this site:


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.

Beginning with Firefox 4, Macs must have an Intel x86 processor (which you do NOT have; yours is a PPC Mac) '''''<u>and</u>''''' OSX 10.5 or higher *System Requirements: [https://www.mozilla.org/en-US/firefox/4.0/system-requirements/index.html Firefox 4]   [https://www.mozilla.org/en-US/firefox/5.0/system-requirements/index.html Firefox 5] [https://www.mozilla.org/en-US/firefox/6.0/system-requirements/index.html Firefox 6] [https://www.mozilla.org/en-US/firefox/7.0/system-requirements/index.html Firefox 7] [https://www.mozilla.org/en-US/firefox/8.0/system-requirements/index.html Firefox 8] '''''The good news''''' is that Firefox 3.6.24 still supports OSX 10.4 and Macs with the PPC Mac architecture. '''''The bad news''''' is that support for the Firefox 3.6.x series is likely to end in the first quarter of 2012. *System requirements: [https://www.mozilla.org/en-US/firefox/3.6/system-requirements/index.html Firefox 3.6.x] *Download Firefox 3.6.24: https://www.mozilla.org/en-US/firefox/all-older.html *Also see --> http://support.mozilla.com/en-US/kb/Installing+Firefox+on+Mac You can try the third-party product '''''TenFourFox''''' that supports PPC Macs. Firefox 8 version of '''''TenFourFox''''' is available. The product is based on Firefox released versions. All support is provided by the developer, not by this site: *Home page: http://www.floodgap.com/software/tenfourfox/ *Developer's blog: http://tenfourfox.blogspot.com/ *'''''VERY IMPORTANT'''''; '''read this carefully''': https://code.google.com/p/tenfourfox/wiki/PluginsNoLongerSupported '''If this reply solves your problem, please click "Solved It" next to this reply when <u>signed-in</u> to the forum.'''

Modified by SafeBrowser