X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox regularly freezing after upgrading to 8.0

Posted

Ever since upgrading to Firefox 8.0.x, Firefox has been freezing on me.

From what I can tell, this happens when I typing in textboxes (composing e-mails, other...); in fact, Firefox froze for about 10 seconds when registering my account on these forums!

I am in safe mode with all extensions/plugins turned off and I am still experiencing this problem.

When I open the Activity Monitor app, the "% CPU" column for Firefox will spike to 100 during the freezes.

What the heck is going on here?

I am not sure how much more freezing I can take... I am tempted to switch to Chrome or Safari. :(

Chosen solution

Start Firefox in Troubleshoot Firefox issues using Safe Mode (hold down the SHIFT key when starting Firefox) to check if one of the extensions or if hardware acceleration is causing the problem and to make sure you are using the default theme:

     Firefox (Tools) -> Add-ons -> Appearance

Don't make any changes on the Safe mode start window.

     https://support.mozilla.com/kb/Safe+Mode 

See also the help article:

     Troubleshooting extensions and themes

Also make sure to update your plug-ins (Java, Flash, etc.)

     https://www.mozilla.org/en-US/plugincheck/

The following help articles address crashes in Firefox:

You can also search for similar help articles

If you have to re-install, do a clean installation:

  1. download Firefox and save installation file,
  2. uninstall Firefox,
  3. delete the Firefox program files folder, (important)
  4. reboot
  5. re-install with administrator privileges. (important)
Read this answer in context 3

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:8.0.1) Gecko/20100101 Firefox/8.0.1

More Information

sctl 36 solutions 219 answers

Chosen Solution

Start Firefox in Troubleshoot Firefox issues using Safe Mode (hold down the SHIFT key when starting Firefox) to check if one of the extensions or if hardware acceleration is causing the problem and to make sure you are using the default theme:

     Firefox (Tools) -> Add-ons -> Appearance

Don't make any changes on the Safe mode start window.

     https://support.mozilla.com/kb/Safe+Mode 

See also the help article:

     Troubleshooting extensions and themes

Also make sure to update your plug-ins (Java, Flash, etc.)

     https://www.mozilla.org/en-US/plugincheck/

The following help articles address crashes in Firefox:

You can also search for similar help articles

If you have to re-install, do a clean installation:

  1. download Firefox and save installation file,
  2. uninstall Firefox,
  3. delete the Firefox program files folder, (important)
  4. reboot
  5. re-install with administrator privileges. (important)

Question owner

Thank you sctl! Re-installing firefox, fresh/clean install, seems to have helped.

Much appreciated.

Cheers, M

kai233 0 solutions 1 answers

hi,

i've tried downgrading, disabling of extensions, reinstalling 8.0.1 again. didn't make a difference.

so i've tried, what mozilla suggests: create a new profile. it worked out and now firefox is as fast as a long time ago.

here is a good instruction. you have to use terminal, though, but it's easy. http://kb.mozillazine.org/Profile_manager#Mac_OS_X

after creating a new profile, you have to copy the whole content of your 'old' profile into the folder of the new one - and all your settings, extensions etc. will be there, again.

the only thing that didn't work, was deleting the old profile afterwards in the profile manager. but you won't realize it until you run the profile manager again.