X
Tap here to go to the mobile version of the site.

Support Forum

Google map icons do not show up as of last week. I have used firefox for months now and just recently this has stopped working.

Posted

When i log into my googlemaps account and want to add my own icons to the map, they do not appear anymore when i use firefox. It looks like there is a broken GIF error on the maps and then nothing shows up. I have tried IE and Chrome on the same computer and it works fine. Would love to have my firefox back though. Please let me know if you can help with this issue. It seems to have started late afternoon last Thursday.

When i log into my googlemaps account and want to add my own icons to the map, they do not appear anymore when i use firefox. It looks like there is a broken GIF error on the maps and then nothing shows up. I have tried IE and Chrome on the same computer and it works fine. Would love to have my firefox back though. Please let me know if you can help with this issue. It seems to have started late afternoon last Thursday.

Chosen solution

No, not directly, but I can at least make them visible (33) with a bookmarklet based on the code in this MozillaZine forum thread that removes the crossorigin attributes.

(you can't run such code via the location bar, but it works in the Scratchpad or as a bookmark)


javascript:(function(){var imgs=document.querySelectorAll('img[crossorigin]');for(i=0;imgs[i];i++){imgs[i].removeAttribute('crossorigin');imgs[i].src=imgs[i].src;}alert(i);})();
Read this answer in context 1

Additional System Details

Sites Affected

http://http://maps.google.com/

Installed Plug-ins

  • Shockwave Flash 11.0 r1
  • Version 2.4.6.4433
  • Google Talk Plugin Video Accelerator version:0.1.44.13
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_27 for Mozilla browsers
  • GEPlugin
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Npdsplay dll

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:8.0) Gecko/20100101 Firefox/8.0

More Information

the-edmeister
  • Top 10 Contributor
  • Moderator
3900 solutions 29437 answers

Try the Firefox SafeMode to see how it works there.
A troubleshooting mode, which disables most Add-ons.
(If you're not using it, switch to the Default Theme.)

  • You can open the Firefox 4/5/6/7 SafeMode by holding the Shft key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item, click on Restart with Add-ons Disabled... while Firefox is running.

Don't select anything right now, just use "Continue in SafeMode."

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shft key) to open it again.

If it is good in the Firefox SafeMode, your problem is probably caused by an extension, and you need to figure out which one.
http://support.mozilla.com/en-US/kb/troubleshooting+extensions+and+themes

When you figure out what is causing that, please let us know. It might help other user's who have that problem.

Try the Firefox SafeMode to see how it works there. <br /> ''A troubleshooting mode, which disables most Add-ons.'' <br /> ''(If you're not using it, switch to the Default Theme.)'' * You can open the Firefox 4/5/6/7 SafeMode by holding the '''Shft''' key when you use the Firefox desktop or Start menu shortcut. * Or use the Help menu item, click on '''Restart with Add-ons Disabled...''' while Firefox is running. <br /> ''Don't select anything right now, just use "Continue in SafeMode."'' ''To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shft key) to open it again.'' '''''If it is good in the Firefox SafeMode''''', your problem is probably caused by an extension, and you need to figure out which one. <br /> http://support.mozilla.com/en-US/kb/troubleshooting+extensions+and+themes ''When you figure out what is causing that, please let us know. It might help other user's who have that problem.''

Helpful Reply

Just restarted in safe mode and the same problem still occurs.

Just restarted in safe mode and the same problem still occurs.
cor-el
  • Top 10 Contributor
  • Moderator
12123 solutions 112671 answers

Can be caused by a missing cross origin access header in the response headers from the server.

See this MozillaZine forum thread "My own Google Map icons are not visible in Firefox 8":

Can be caused by a missing cross origin access header in the response headers from the server. See this MozillaZine forum thread "My own Google Map icons are not visible in Firefox 8": *http://forums.mozillazine.org/viewtopic.php?f=25&t=2359775
dirtyricky 0 solutions 2 answers

I've had this problem ever since FF8 update. I've seen the .htaccess solution and I must say it's less than satisfactory.

Of all the time I've used Firefox (since AOL took over Netscape) I have never been required to write code (even if it's easy stuff) to correct a problem created by an update.

In addition, my public webspace provider won't allow .htaccess files.

It worked in FF before, now it doesn't. It works in IE, Android, Chrome. Therefore it is FF8 that is the problem. It shouldn't be the responsibility of every individual user to fix it.

This problem is NOT solved.

I've had this problem ever since FF8 update. I've seen the .htaccess solution and I must say it's less than satisfactory. Of all the time I've used Firefox (since AOL took over Netscape) I have never been required to write code (even if it's easy stuff) to correct a problem created by an update. In addition, my public webspace provider won't allow .htaccess files. It worked in FF before, now it doesn't. It works in IE, Android, Chrome. Therefore it is FF8 that is the problem. It shouldn't be the responsibility of every individual user to fix it. This problem is NOT solved.
freak-agentur 0 solutions 2 answers

Helpful Reply

It worked in FF before, now it doesn't. It works in IE, Android, Chrome. Therefore it is FF8 that is the problem. It shouldn't be the responsibility of every individual user to fix it. I'm agree with you. Additional info: if you change the map-view from "earth" to "satelite" the marker will be visible! Here is my personal map

''It worked in FF before, now it doesn't. It works in IE, Android, Chrome. Therefore it is FF8 that is the problem. It shouldn't be the responsibility of every individual user to fix it.'' I'm agree with you. Additional info: if you change the map-view from "earth" to "satelite" the marker will be visible! Here is my [http://g.co/maps/rrdr4 personal map]

Question owner

This still isn't working. Opened up a computer with an old FF version and it worked fine. There has to be a solution to this because it works in all other browsers. Please Help. I use this daily and will have to switch to chrome if the issue isn't resolved.

This still isn't working. Opened up a computer with an old FF version and it worked fine. There has to be a solution to this because it works in all other browsers. Please Help. I use this daily and will have to switch to chrome if the issue isn't resolved.
cor-el
  • Top 10 Contributor
  • Moderator
12123 solutions 112671 answers

That is because a crossorigin attribute is added to those images and that prevents loading those images unless the server sends the correct response.
If other browsers like Google Chrome will respect that attribute then it will stop working there as well.

That is because a crossorigin attribute is added to those images and that prevents loading those images unless the server sends the correct response.<br /> If other browsers like Google Chrome will respect that attribute then it will stop working there as well. *https://forums.mozillazine.org/viewtopic.php?f=25&t=2359775&p=11511437#p11511437

Question owner

Well if that is the case why did it work in the previous version of firefox? And works in all other browsers except for this update?

Well if that is the case why did it work in the previous version of firefox? And works in all other browsers except for this update?
mowgli3000 0 solutions 1 answers

@cor-el: That is a bogus solution.

@Someone who is really competent: Can u plz help with this issue?

@cor-el: That is a bogus solution. @Someone who is really competent: Can u plz help with this issue?

Question owner

Yes please help! This seems like something that can be easily fixed as i've checked every other browser and it works great on all of them. I thinks its something that firefox should be able to fix without the user doing something to their system. Please fix this sooon!!! I love using my firefox, but i use google maps for work projects everyday and if this browser will not function I will unfortunately have to change.

Yes please help! This seems like something that can be easily fixed as i've checked every other browser and it works great on all of them. I thinks its something that firefox should be able to fix without the user doing something to their system. Please fix this sooon!!! I love using my firefox, but i use google maps for work projects everyday and if this browser will not function I will unfortunately have to change.
freak-agentur 0 solutions 2 answers

Is there somewhere an statement from Mozilla, or is this bug too trivial?

Is there somewhere an statement from Mozilla, or is this bug too trivial?
cor-el
  • Top 10 Contributor
  • Moderator
12123 solutions 112671 answers

It is not a bug, but the result of implementing safety measure to block images if they have the crossorigin attribute and if the server doesn't send the HTTP access control headers to allow those images.

It is not a bug, but the result of implementing safety measure to block images if they have the crossorigin attribute and if the server doesn't send the HTTP access control headers to allow those images. * http://enable-cors.org/ enable cross-origin resource sharing * https://developer.mozilla.org/En/HTTP_access_control
rponsoda 0 solutions 2 answers

Hi,

I see what you mean... But I don't get how to solve it. I am reading these websites byt they are complex to understand... Can you please tell me what are the steps to fix this problem?

Hi, I see what you mean... But I don't get how to solve it. I am reading these websites byt they are complex to understand... Can you please tell me what are the steps to fix this problem?
cor-el
  • Top 10 Contributor
  • Moderator
12123 solutions 112671 answers

As a user you can't do much about this.

If it is your website then you need to make the server send the correct HTTP access headers orcontact the hosting company about that.

See:

As a user you can't do much about this. If it is your website then you need to make the server send the correct HTTP access headers orcontact the hosting company about that. See: * http://enable-cors.org/ enable cross-origin resource sharing

Question owner

Best suggestion is to just use another browser. Looks like the only fix is much to complicated for a normal user. For all you who are having problems with this, the google maps add icons feature works in all other browsers and their newest updates. The only browser that seems to have the problem is this latest version of firefox. Wish there were a better solution, but there doesn't seem to be. Farewell Firefox......

Best suggestion is to just use another browser. Looks like the only fix is much to complicated for a normal user. For all you who are having problems with this, the google maps add icons feature works in all other browsers and their newest updates. The only browser that seems to have the problem is this latest version of firefox. Wish there were a better solution, but there doesn't seem to be. Farewell Firefox......
Svendus 1 solutions 10 answers

it is Firefox related Google maps customized icons runs nicely in opera, safari, google chrome and ie 9

'''it is Firefox related ''' Google maps customized icons runs nicely in opera, safari, google chrome and ie 9
cor-el
  • Top 10 Contributor
  • Moderator
12123 solutions 112671 answers

It may stop working in other browsers, Google Chrome being the most obvious candidate, if those other browsers will obey the crossorigin attribute for those images.
It is comparable to X-FRAME-OPTIONS that Mozilla servers send in the response headers that prevents opening site like this server to be opened in an iframe (you get an about:blank page if you try).

Doesn't work in Google Chrome and Firefox:

data:text/html;charset=utf-8,
<html><head><title>IFRAME test</title></head><body><iframe src="https://support.mozilla.com/en-US/questions" height="99%" width="100%"></iframe></body></html>

Works:

data:text/html;charset=utf-8,
<html><head><title>IFRAME test</title></head><body><iframe src="http://forums.mozillazine.org/viewforum.php?f=38" height="99%" width="100%"></iframe></body></html>
It may stop working in other browsers, Google Chrome being the most obvious candidate, if those other browsers will obey the crossorigin attribute for those images.<br /> It is comparable to X-FRAME-OPTIONS that Mozilla servers send in the response headers that prevents opening site like this server to be opened in an iframe (you get an about:blank page if you try). Doesn't work in Google Chrome and Firefox: <pre><nowiki>data:text/html;charset=utf-8, <html><head><title>IFRAME test</title></head><body><iframe src="https://support.mozilla.com/en-US/questions" height="99%" width="100%"></iframe></body></html> </nowiki></pre> Works: <pre><nowiki>data:text/html;charset=utf-8, <html><head><title>IFRAME test</title></head><body><iframe src="http://forums.mozillazine.org/viewforum.php?f=38" height="99%" width="100%"></iframe></body></html> </nowiki></pre>

Modified by cor-el

Question owner

I'm not sure what your last post is relating to. Just downloaded latest version of chrome and it works perfectly. The newest firefox update is the only browser it doesn't work in. Search an address, right click and save to my maps (make sure you are signed in) go to my maps, select edit, select placemarker and click edit. Press add icon, enter address of an icon you have saved. And it shows the image as broken for a millisecond. And then nothing appears. Like I said this works in all other browsers. I can't comprehend the fixes you are giving. Sorry.

I'm not sure what your last post is relating to. Just downloaded latest version of chrome and it works perfectly. The newest firefox update is the only browser it doesn't work in. Search an address, right click and save to my maps (make sure you are signed in) go to my maps, select edit, select placemarker and click edit. Press add icon, enter address of an icon you have saved. And it shows the image as broken for a millisecond. And then nothing appears. Like I said this works in all other browsers. I can't comprehend the fixes you are giving. Sorry.

Modified by Hankerdaddy

Svendus 1 solutions 10 answers

http://svendus.se/apladalen/index.html

load page in any other browser

[http://svendus.se/apladalen/index.html http://svendus.se/apladalen/index.html] load page in any other browser
cor-el
  • Top 10 Contributor
  • Moderator
12123 solutions 112671 answers

All those missing images have a crossorigin attribute that prevents Firefox from displaying them.
The map is displayed in an iframe, so I couldn't use a bookmarklet to remove those attributes (an extension may be able to do that), but it did work if I removed the crossorigin attributes with the DOM Inspector.

All those missing images have a crossorigin attribute that prevents Firefox from displaying them.<br /> The map is displayed in an iframe, so I couldn't use a bookmarklet to remove those attributes (an extension may be able to do that), but it did work if I removed the crossorigin attributes with the DOM Inspector.