Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google map icons do not show up as of last week. I have used firefox for months now and just recently this has stopped working.

  • 22 replies
  • 94 have this problem
  • 256 views
  • Last reply by cor-el

more options

When i log into my googlemaps account and want to add my own icons to the map, they do not appear anymore when i use firefox. It looks like there is a broken GIF error on the maps and then nothing shows up. I have tried IE and Chrome on the same computer and it works fine. Would love to have my firefox back though. Please let me know if you can help with this issue. It seems to have started late afternoon last Thursday.

Chosen solution

No, not directly, but I can at least make them visible (33) with a bookmarklet based on the code in this MozillaZine forum thread that removes the crossorigin attributes.

(you can't run such code via the location bar, but it works in the Scratchpad or as a bookmark)


javascript:(function(){var imgs=document.querySelectorAll('img[crossorigin]');for(i=0;imgs[i];i++){imgs[i].removeAttribute('crossorigin');imgs[i].src=imgs[i].src;}alert(i);})();
Read this answer in context 👍 1

All Replies (2)

more options

all right but this page do not depend on i frames

Google's own icons appear normally ?

more options

Chosen Solution

No, not directly, but I can at least make them visible (33) with a bookmarklet based on the code in this MozillaZine forum thread that removes the crossorigin attributes.

(you can't run such code via the location bar, but it works in the Scratchpad or as a bookmark)


javascript:(function(){var imgs=document.querySelectorAll('img[crossorigin]');for(i=0;imgs[i];i++){imgs[i].removeAttribute('crossorigin');imgs[i].src=imgs[i].src;}alert(i);})();

Modified by cor-el

  1. 1
  2. 2